Jump to content
3DCoat Forums
Hammers

Smoothing groups import from Blender, low-poly

Recommended Posts

Hi all,

 

I've seen elsewhere that 3D-coat respects smoothing groups. I've been trying to get an .obj from Blender into 3D coat today, but have had not luck as far as the smoothing groups go.

 

Of course in Blender, smoothing groups are set with  edge sharpness, but the obj exporter converts these to SGs allegedly.

 

As I'm typing this I thought to try an .fbx import, and that seems to work OK!

 

So presumably there is either a problem with Blender's .obj export, or 3Dcoat's .obj import.

 

For reference here are some images: my model in Blender, my export settings, and the model in 3D coat (obj). Posting my .obj here too in case it warrants investigating.

 

Cheers!

 

post-37883-0-77795600-1442996773_thumb.ppost-37883-0-19901800-1442996763_thumb.ppost-37883-0-10487300-1442996768_thumb.p

 

RockingHorseModelMerged&Smoothed.obj

Share this post


Link to post
Share on other sites

Hi,

That's a steps I found on YouTube:

Set your face shading to smooth, mark your sharp edges, turn on auto smooth in the Object Data panel under Normals and set the angle (start with 30 degrees and go from there). You should see your smooth mesh with the sharp edges you defined.

 

Then... see pictures. While importing in 3DC don't check Auto smoothing groups!

cheers!!!

 

p.s. there is a box to try ;)

post-896-0-49550100-1443003183_thumb.jpg

post-896-0-89043000-1443003183_thumb.png

post-896-0-37610400-1443003184_thumb.png

smoothgrpbox.obj

  • Like 1

Share this post


Link to post
Share on other sites

Edge Split modifier give better result at export

 

Bitflag Smooth groups = on, can help too

 

best result... keep exporting as fbx

Share this post


Link to post
Share on other sites

Thanks for the ideas guys! The obj from B to 3dc was ok if I applied the edge split modifier, but that messed up the topology and I couldn't delete those edges in the UVs. But with .fbx from Blender I inadvertently left "apply modifiers" on, yet it still worked! So I think your last suggestion seems the most sensible Carlosan. :)

 

@Daniel. I'd never seen that Autosmooth normals option before. Thanks for sharing that too!

Edited by Hammers

Share this post


Link to post
Share on other sites

Glad to help

 

right about Daniel tip ^_^

@Daniel: good tip ! Thanks for sharing that too!

Share this post


Link to post
Share on other sites

Just a follow up note on that, the autosmooth left at 180º just picked up the sharp edges, and seemed more discriminating than the edge split mod. This actually helped me find a couple of bad internal faces that were causing shading problems. I tried exporting fbx without the modifier, and the edges came through without a hitch. I set the export  to smooth 'normals only', not sure if that matters or not. Anyway, I think I'll be using autosmooth a lot more from now on :)

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×