Jump to content
3DCoat Forums
kitsune0

3D Coat breaks mesh after 5 or 6 subdivisions

Recommended Posts

So, as the title says, everytime I try to subdivide the mesh several time, it breaks.

For example, I create a simple cube from the library in surface mode. I subdivide fine till 5. Once I click subdivide one more time, the mesh breaks and appears with a lot of artifacts.

It happens with 3D Coat 4.5.19-21-22-23.

 

Here it how a cube looks after the 6th subdivision.

I also changed from OpenGL to DX but the problem persist.

 

1c27168515a08afbdd91ff16cc3db6bf.png
https://gyazo.com/1c27168515a08afbdd91ff16cc3db6bf

Share this post


Link to post
Share on other sites

Hi !

The default cube at 6th subdivision could have 150M polygons... you need a bigger scale in the scene to get better results.

Share this post


Link to post
Share on other sites

Hi !

The default cube at 6th subdivision could have 150M polygons... you need a bigger scale in the scene to get better results.

 

No, this cube have only 300K triangles after the 5th subdivision. And the scale have no effect, it still breaks when adding the 6th subdivision.

Ill explain a little more because I think you are not getting what is happening here.

It doesnt matter which mesh you do, in surface mode, after the 6th subdivision it breaks. It is ibviously a bug because if I convert the mesh to voxels and back to surface I can start subdividing again another 5 times. I can even use the resample option and keep the same amount then I can start subdividing again but only to the 5th subdivision. In this example I use a cube but Im actually sculpting a very low base mesh that may need probably around 10 to 15 subdivisions. As you can guess, it have no much sense working on something so low poly that it breaks after the 5th subdivision. Even 3D Max can handle that easily and even Mudbox. I dont see why the scale of the scene would affect the subdivision not breaking. Anyway I tried increasing size of cube but the problem persist. Its either a bug or I am really doing something wrong or that just dont know about limitations on this software. BTW my PC can handle that without problem if you wonder.

 

This is how it looks after 5 subdivisions. Is not that dense or big deal at all...

 

EDIT: I noticed that if I clean memory I can start subdividing again. Still, I dont think that mesh should simply break.

 

ca62920d6ed611495cbf5fcce39bf24b.png

https://gyazo.com/ca62920d6ed611495cbf5fcce39bf24b

Share this post


Link to post
Share on other sites

No, this cube have only 300K triangles after the 5th subdivision. And the scale have no effect, it still breaks when adding the 6th subdivision.

Ill explain a little more because I think you are not getting what is happening here.

It doesnt matter which mesh you do, in surface mode, after the 6th subdivision it breaks. It is ibviously a bug because if I convert the mesh to voxels and back to surface I can start subdividing again another 5 times. I can even use the resample option and keep the same amount then I can start subdividing again but only to the 5th subdivision. In this example I use a cube but Im actually sculpting a very low base mesh that may need probably around 10 to 15 subdivisions. As you can guess, it have no much sense working on something so low poly that it breaks after the 5th subdivision. Even 3D Max can handle that easily and even Mudbox. I dont see why the scale of the scene would affect the subdivision not breaking. Anyway I tried increasing size of cube but the problem persist. Its either a bug or I am really doing something wrong or that just dont know about limitations on this software. BTW my PC can handle that without problem if you wonder.

 

This is how it looks after 5 subdivisions. Is not that dense or big deal at all...

 

EDIT: I noticed that if I clean memory I can start subdividing again. Still, I dont think that mesh should simply break.

I went up as high as eight subdivision levels with import tool's subdivide button and 9 levels with subdivide tool. After that, it simply wasn't worth to wait for the result as the geometry was already so dense, that working with it didn't make any sense.

The advice I can give you is that if you're subdividing your surface with the Res+ tool - then stop! Use this tool only for increasing resolution of voxel volumes. For subdividing surfaces use the mentioned Subdivide button (available in the Import tool), or the Subdivide tool.

You said that want to go as high as 10-15 subdivisions with your low-poly mesh. I strongly discourage it. Do you realize that the polycount of a simple 6-sided cube at 10th subdivision level reaches 12 582 912 triangles, and at 15th level - 12 884 901 888 (almost 13 billion triangles)? If your initial low-poly model has even a mere 10 or 20 faces more then... Well you get the picture. ;)

Why do you need so much global resolution on your mesh anyway? Are you aware that surface LiveClay tools are capable of real-time local subdivision? My suggestion is to subdivide your mesh only a couple of times and let the LiveClay tools do the magic.

Share this post


Link to post
Share on other sites

I went up as high as eight subdivision levels with import tool's subdivide button and 9 levels with subdivide tool. After that, it simply wasn't worth to wait for the result as the geometry was already so dense, that working with it didn't make any sense.

The advice I can give you is that if you're subdividing your surface with the Res+ tool - then stop! Use this tool only for increasing resolution of voxel volumes. For subdividing surfaces use the mentioned Subdivide button (available in the Import tool), or the Subdivide tool.

You said that want to go as high as 10-15 subdivisions with your low-poly mesh. I strongly discourage it. Do you realize that the polycount of a simple 6-sided cube at 10th subdivision level reaches 12 582 912 triangles, and at 15th level - 12 884 901 888 (almost 13 billion triangles)? If your initial low-poly model has even a mere 10 or 20 faces more then... Well you get the picture. ;)

Why do you need so much global resolution on your mesh anyway? Are you aware that surface LiveClay tools are capable of real-time local subdivision? My suggestion is to subdivide your mesh only a couple of times and let the LiveClay tools do the magic.

 

Why would I want to do something isnt really the topic here. I dont think that only 6 subdivisions is really that high if you are really sculpting small details. The point here is that, if you look to the screenshots, the cube breaks in the 6th subdivision. OBVIOUSLY, my workflow doesnt include a cube, that was just an easy example for people to test if it does crash. Take into account that must be in surface mode to "break". Due the workflow Im using, I cant use liveclay plus liveclay always leave a lot of weird vertex that translates to dark spots on meshes (probably vertexs with more than 5 edges). I know there are some tools to clean the mesh but still, searching a different way of doing something that should work in first instance isnt a "fix" and just a workaround. I would like to know why it does happens and why it gets sorted if I clear memory after the 5th subdivision and if is a common bug that happens to everyone or if is tied to something else because I installed all versions since 19 to 23 and in all of them happens :S. Thanks for the reply tho.

Are you using this tool ?

Yeah that one. Sometimes I access it through the left panel or using space bar.

Share this post


Link to post
Share on other sites

Why would I want to do something isnt really the topic here. I dont think that only 6 subdivisions is really that high if you are really sculpting small details. The point here is that, if you look to the screenshots, the cube breaks in the 6th subdivision. OBVIOUSLY, my workflow doesnt include a cube, that was just an easy example for people to test if it does crash. Take into account that must be in surface mode to "break". Due the workflow Im using, I cant use liveclay plus liveclay always leave a lot of weird vertex that translates to dark spots on meshes (probably vertexs with more than 5 edges). I know there are some tools to clean the mesh but still, searching a different way of doing something that should work in first instance isnt a "fix" and just a workaround. I would like to know why it does happens and why it gets sorted if I clear memory after the 5th subdivision and if is a common bug that happens to everyone or if is tied to something else because I installed all versions since 19 to 23 and in all of them happens :S. Thanks for the reply tho.

Like I said, don't use the Res+ tool, or that button Carlos pointed to (which is a shortcut to Res+ tool). The problem you describe occurs at sixth iteration of the Res+ when it's used to increase the resolution of a VoxTree layer that is in surface mode.

Share this post


Link to post
Share on other sites

Like I said, don't use the Res+ tool, or that button Carlos pointed to (which is a shortcut to Res+ tool). The problem you describe occurs at sixth iteration of the Res+ when it's used to increase the resolution of a VoxTree layer that is in surface mode.

Thank you but, which button should I use? I have started using 3D Coat recently but I didnt know that were different ways of subdividing the mesh. I know that same button appears on the left panel as well as hitting space bar to see shortcuts and its also on the geometry top menu. Which button or option should I use? Also, would cleaning memory have any negative impact in the workflow? Im not sure if you can go back and forward through subdivisions levels like Mudbox but the last I heard is that you cant so not sure if cleaning memory would kinda make it impossible to go back if were the case. Thank you.

Share this post


Link to post
Share on other sites

If you want to subdivide the object before importing it to sculpt room:

post-12523-0-40095400-1448244186_thumb.j

Subdivide uses Catmul-Clark's algorithm. Flat subdivision doesn't.

 

If you want to subdivide an already imported object:

post-12523-0-04072100-1448244087_thumb.p

This one uses loop subdivision.

 

---

I never had to do the memory cleanup. Maybe it has some uses, but I now nothing about them, I'm afraid. Maybe someone else could tell more.

 

You can't switch between subdivision levels while sculpting per se. There's a proxy mode that you can use which will temporarily decimate / reduce the geometry specified amount of times. See Geometry->Proxy Method for selecting the proxy method and the amount of decimation / reduction. To cache / uncache the volume (to proxy /unproxy it) use either this icon:

post-12523-0-56392300-1448244819_thumb.p

 

or the Geometry->Caching menu.

 

ALWAYS do a backup of the layer you intend to cache. Remove the backup when you have unproxied the original layer and are absolute sure it's undamaged. I've seen proxy fail several times (lost some work because of that).

Edited by ajz3d

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×