Jump to content
3DCoat Forums
CognizanCe

Smooth subdividing to make a high res mesh?

Recommended Posts

I would just like to smooth + subdivide a mesh  imported into 3D coat to make it a high res mesh, then retopologize it in 3D coat as well.

Normally I export the high res mesh from maya,
But I've switched to modo indie which doesn't allow exporting a mesh with over 100k polies.
Since I prefer retopologizing in 3Dcoat, it is possible to smooth + subdivide a mesh the way Maya or modo does it?
I tried subdividing on import but it doesn't look the same.

 

post-37978-0-37531600-1448417414_thumb.j

Share this post


Link to post
Share on other sites

I do not have access to the model so knowing first hand it's structure plus subdivision routine is something I do not possess. 3DC uses Catmull-Clark subdivision. 

 

I also do not know what kind of holding edge loops you have or smoothing groups...

 

What version of 3DC are you using.

 

First, I would not import for per pixel painting. It's purpose is not design for retopoing. Yes you can do it but that is not it's designed purpose.

If you still desire to use the above method,  select auto smoothing groups in the import panel and set the max angle to 180 degrees to see if the model imports correctly.

 

I would suggest importing a reference mesh but you desire to increase smooth plus increase the polygon count.

 

The below is one of the official ways to retopo a high polygon model, there are a few more ways. You can do the below operation from the New Panel that opens when 3DC first opens but I like a more hands on approach. Test the below method and see if it works for your model.

 

Switch to the Sculpt Room and import your model "without voxelization". Subdivide (not flat subdivision) the model till it is smooth or in other words a non-facet polygon appearance.

Also if the model comes in tiny just scale it up to a working size. Press enter to complete the operation and say "Yes" to keep the scale. When exporting the model it will keep it's original scale. I show the import panel (left toolbar) with the import settings in a picture.

 

You could also try importing as voxels but you will need enough voxel resolution to capture all the details.

 

If the model is good to go, switch to the retopo room and do your retopologizing. 

 

Video for navigating 3DC's YouTube Channel. There are new and old videos here, Some interface changes of course but lots of useful information. AbnRanger has done an excellent job and others as well...

post-518-0-48287000-1448472864_thumb.jpg

Edited by digman
  • Like 1

Share this post


Link to post
Share on other sites

Unfortunately there are no subdivision surfaces in 3DC, so it's not really possible at the moment. Maybe some day Andrew & Co. will be able to implement Open SubDiv.

 

The best solution I could offer, is to not subdivide the mesh when importing, and retopologize it as a low poly object. That is, if you really want to do it in 3DC. That said, you'll still need to bake it, and since 3DC doesn't support SubD surfaces, it wont bake right. I'd bake it in Modo.

 

Because of the mesh requirements you have (SubD surface and baking those SubDs to low poly), what I would do is retopologize and bake in Modo. It's really the best option for this particular mesh you're working on.

Share this post


Link to post
Share on other sites

Because of the mesh requirements you have (SubD surface and baking those SubDs to low poly), what I would do is retopologize and bake in Modo. It's really the best option for this particular mesh you're working on.

 

Ughh.....I love retopologizing in 3dcoat. it has so many tools (point + faces, quads, add/split etc.) and it feels so fast because of all those tools.

I don't know how to retopologuze in modo, but from what I can tell it's retopology tools are very basic.

The have an equivalent of add/split and splitting edge loops, but that's about it.

I actually bought 3D coat for its retopolgy and UV tools.

I'm dreading having to do them in another program.

Edited by CognizanCe

Share this post


Link to post
Share on other sites

Hi

 

2 free choices:

- MeshLab is free and let you to smooth and subdivide your model

Filters >Smoothing

Filters >Polygonal

 

- Blender can do too
Menu: Mesh » Edges » Subdivide Smooth, Specials » Subdivide Smooth

-------------------------------------------------------

The you could import reference mesh on 3DC to finish the retopo stage.

Share this post


Link to post
Share on other sites

Did you try the Import Tool in the Sculpt Room? There is a tool there in the toolbar called "Import". In the Tool Options of that tool there is a "Select Mesh" button. Click on that to choose your model. If you don't see your model, then use the transform gizmo to scale it up until you see it in the viewport. There is a "subdivide" button there in the Tool Options too. The subdivision used there actually smooths the mesh in addition to subdividing it. When using that tool you will see a preview before importing. Click on the "Apply" button to commit the import, then switch to a different tool to get rid of the preview. Then you can go to the Retopo Room and perform retopo on it. I don't know if that is the workflow you are looking for, but you can try it out if you want.

Share this post


Link to post
Share on other sites

Did you try the Import Tool in the Sculpt Room? There is a tool there in the toolbar called "Import". In the Tool Options of that tool there is a "Select Mesh" button. Click on that to choose your model. If you don't see your model, then use the transform gizmo to scale it up until you see it in the viewport. There is a "subdivide" button there in the Tool Options too. The subdivision used there actually smooths the mesh in addition to subdividing it. When using that tool you will see a preview before importing. Click on the "Apply" button to commit the import, then switch to a different tool to get rid of the preview. Then you can go to the Retopo Room and perform retopo on it. I don't know if that is the workflow you are looking for, but you can try it out if you want.

 

Thanks for the reply, but it doesn't seem to be what I want.

That method seems to be transforming the imported mesh into voxels for a sculpting workflow.

I just want a subD smooth the mesh and retopo it.

Not continue to sculpt it.

3dcoat_import_mesh.jpg

Share this post


Link to post
Share on other sites

Yes, as Candy-floss said, there is a button in the Tool Options panel "Import Without Voxelization" which will import the mesh as a surface, not as voxels. Don't forget to also click on the "subdivide" button to get the smoothed subdivision level you want. Each time you click it, it will subdivide and smooth more.

Share this post


Link to post
Share on other sites

Yes, as Candy-floss said, there is a button in the Tool Options panel "Import Without Voxelization" which will import the mesh as a surface, not as voxels. Don't forget to also click on the "subdivide" button to get the smoothed subdivision level you want. Each time you click it, it will subdivide and smooth more.

GOT IT!

Was confused when you said to "subdivide button".

It's NOT the Subdivide BUTTON when importing, but the TOOL when the imported mesh has been converted to a surface!

-Using subdivide on import subdivided the mesh, but did not SMOOTH it. I needed it smoothed AND subdivided.

sub_D_SUCCESS.jpg

Thanks a lot though.

Thank God I don't have to install blender now, or any other programs to slow down my pipeline.

:)

EDIT:

Like I said as well, this is just for retopoing and baking purposes (can't export a high res mesh from Modo indie). No further sculpting will be done.

Edited by CognizanCe

Share this post


Link to post
Share on other sites

Ok, so I just tested out the Import Tool to make sure about this, and it is not working correctly. There is a bug in there somewhere, and we need to report it to Andrew!

 

The "Subdivide" button in the Tool Options is SUPPOSED TO use Catmull Clark subdivision, in other words, it is supposed to subdivide AND smooth. The button called "Flat Subdivision" is supposed to subdivide WITHOUT smoothing.

 

I know this is a bug because the tool works correctly if you use the "Pick From Retopo" button. For example, if you import your mesh into the Retopo Room first, then go to the Sculpt Room, use the Import Tool there, and click on "Subdivide" in the Tool Options you will see that it is subdividing AND smoothing. If you use the "Select Mesh" button instead, then you will see that the "Subdivide" button stops working correctly. It is definitely a bug.

Share this post


Link to post
Share on other sites

I checked, it works as expected. It may not work if imported mesh has sharp edges.

Share this post


Link to post
Share on other sites

Thanks for your help Carlosan! It still doesn't work for me. I'm trying to figure out why...

Share this post


Link to post
Share on other sites

Thanks for your help Carlosan! It still doesn't work for me. I'm trying to figure out why...

I don't know what it is lately, but I've had a consistent string of incidents requiring me to close the app and re-open just to get things that usually work, to start working. One day it was the Primitives tool not working at all. Close app > re-open and it was back working again. Today, it was the 2D Texture editor not allowing me to either pick a color or randomly quit allowing me to use the Clone Stamp tool in it, suddenly. This happened right in the middle of a recording....TWICE!

 

I don't know if Andrew dropped a coding wrench into the gears of the software or what, but this trend needs to stop. It's becoming way too regular.

Share this post


Link to post
Share on other sites

×