Jump to content
3DCoat Forums
Sign in to follow this  
aaronmcavinue

Can't get sculpt into UV tab?

Recommended Posts

I'm sure this is a total newb question, and I apologize if the answer is really obvious.

 

I've been watching a few tutorials on UV unwrapping as I try out 3D Coat, and all of them show the workflow for unwrapping as:

1. Import/sculpt the model.

2. Click the UV tab & start the UV unwrapping process.

 

However, this doesn't work for me as I am never able to get to the second step. In multiple different files, when I click the UV tab nothing is there. I've look through all the menus I could find, tried converting from V TO S, and looked through Google for this answer and found nothing. Anyone know what's going on here?

 

All help would be appreciated.

Thanks much!

Aaron

post-39923-0-62963000-1449577024_thumb.j

post-39923-0-71530400-1449577026_thumb.j

Share this post


Link to post
Share on other sites

The "unwrapping process" and the creation of UVs is carried out in the Retopo room. The UV room is for adjusting an already unwrapped UV mesh. The GUI should probably be adjusted so that Retopo comes after Sculpt.

  • Like 1

Share this post


Link to post
Share on other sites

Hey Tony, I tried using autopo & did some manual retopologizing. I then unwrapped it from the retopo > unwrap menu, and the UV tab is still empty!

 

Are there any tutorials or workflow on this at all? What is the "surface materials" tab on the RHS for, and what does that have to do with UVs? This is the closest thing to the voxtree in the UV tab, and it always only shows the scene (see picture above). I seems like there should be something a lot more clear & straightforward that I am missing...

Share this post


Link to post
Share on other sites

The UV tab lets you edit UVs from objects present in the Paint room... it was a bit confusing to me too, at first (no so long ago really).

 

So either from a sculpt work that you retopoed, as Tony said, and then sent to the paint room after your unwrapping there with one of the bake option in the Retopo rooms' bake menu, since such operation actually creates your low poly mesh in the paint room, its surface material(s), and its UVs.

 

That, or import an already UV'ed mesh,  of course.

 

(Edit: some typos)

Edited by Percevan
  • Like 1

Share this post


Link to post
Share on other sites

Okay thanks Percevan. I'm not sure why this isn't spelled out more clearly somewhere, but here is the process in case someone else is wondering:

 

Sculpt the form.
Autopo/retopo it.
Retopo tab > bake > Bake into normal map, bake into scene, per pixel painting, etc.
Go to UV tab and start the unwrapping process.

Share this post


Link to post
Share on other sites

 

Okay thanks Percevan. I'm not sure why this isn't spelled out more clearly somewhere, but here is the process in case someone else is wondering:

 

Sculpt the form.
Autopo/retopo it.
Retopo tab > bake > Bake into normal map, bake into scene, per pixel painting, etc.
Go to UV tab and start the unwrapping process.

 

Incorrect process in parts.

 

Sculpt the form. Correct

 

The first selection "Autopo" will upon completion put you in the Retopo room. You can switch to the Retopo and do a manual retopo as well.  Correct

 

Now in the Retopo Room... or tab as you call it.

 

Under the UV heading (left toolbar) in the Retopo room

 

Manually mark seams and unwrap for the uv set. This part of the process you have left out. 3DC is context sensitive, clicking a heading will open other tools to use. If you leave this part out when you bake, 3DC will create auto-uv seams for you. In most cases we want to create our own seams / uv islands and uv set or sets...

Side Note: Under the UV heading... Edge loops... are great for marking seams quickly... UV Path... Study it to see how it works...

 

Bake to the paint room for your maps...Correct.

 

Go to the UV room and unwrap... Incorrect. This is not needed as you have already mark seams, unwrapped and manually created your UV set earlier in the process...

Edited by digman

Share this post


Link to post
Share on other sites

Ah thanks digman. Yes I did do the seams in my process but I forgot to write them into the comment. Thanks for the help again guys!

 

Another question:

After following this process I wanted to increase the subdiv of my mesh. Do I have to unwrap/bake all over again or is there a way for 3d-Coat to just add the subdivs to the current unwrap? I tried baking again but this only created a messy unwrap -- and my previous, low-poly unwrap was much nicer.

Share this post


Link to post
Share on other sites

You will have to re-bake... 

Below is just in case you do not know this.

 

Before re-baking you must delete the current model from the paint room and any unused layers... Not doing this could be the cause of your messy rebake.

In the layer panel at the bottom is an "X" icon, after deleting the model, click on the "X" to remove any unused paint layers. If any are left manually remove them. Sometimes the curvature map can not be removed. Recalculate the curvature map when needed.

 

Back in the Retopo room, subdivide the model in the "baking panel" at the desired subdivision level you want when rebaking. 

You can subdivide the model from the left tool panel also but it is a simple subdivide not Catmull-Clark subdivision which is used when baking.

Use whatever works best for your workflow...

 

Depending upon the amount of subdividing you use you might have to do some uv set smoothing in the bake panel to avoid stretching of the uvs. Just run a few test to find out if needed or not... Make sure you have "Don't snap subdivision vertices to surface" in the baking panel selected when using Subdivision in the baking panel.

 

Also you do not have all your available tabs...like your  Paint Objects tab. etc...

Go to the Windows menu and select "Reset this page to default"

post-518-0-57226500-1450133226_thumb.jpg

Edited by digman

Share this post


Link to post
Share on other sites

What do you mean that I'll have to "delete it from the paint room"? Do you mean delete it from the VoxTree?

 

Also, I tried subdividing it through the baking panel like you suggested, but the result seems to be more or less the same -- no additional subdivisions in the retopo model or the uv map. Thoughts?

Share this post


Link to post
Share on other sites

Not the voxtree... In the picture you posted from your other thread the paint room is not at it's default setting.

Also if you do not have all your available tabs... if are missing some like your  Paint Objects tab. etc... 3DC seems to lose it's brain here everyonce in while...

Go to the Windows menu and select "Reset this page to default" 

Also remember to have Show Voxels in paint room deselected under the view menu.

 
If you can share the 3DC file for others to look at that would help as well...
Edited by digman

Share this post


Link to post
Share on other sites

This issue was solved in version 4.5.25

 

 

 

4.5.25 [beta]

- If you bake multiple times same scene again and again, 3D-Coat asks if results of previous baking shouls be deleted.

Share this post


Link to post
Share on other sites

 

This issue was solved in version 4.5.25

 

 

 

 

Fantastic... I requested this feature to help new users avoid frustration just about a week or so ago... Andrew responded...

Edited by digman

Share this post


Link to post
Share on other sites

Okay I get you -- you have to delete the paint object.

 

Still wondering about the additional subdivisions that don't seem to be appearing.

 

I've attached the .3b file to this message as requested.

 

While you're poking around in there, do you happen to know what happened to my sculpt? During all this unwrapping & retopologizing, it has somehow disappeared from that room. It's still in the VoxTree, but the sculpt is now gone.

1 Learning Spheres.zip

Share this post


Link to post
Share on other sites

I checked your scene... possible somehow you deleted that part of the voxel sculpt as I can not find it. The polygon model is in the paint room but the voxel sculpt is gone.

Since this is just a basic scene I would suggest starting a new one and now with a fuller understanding of 3DC  go through the process again from sculpting / retopoing / baking... 

3DC is a very good and powerful program, once you get the hang of the workflow processes you will be on your way...

 

Link to navigating the 3DC's Youtube Channel.

  • Like 1

Share this post


Link to post
Share on other sites

One downside for new users of a powerful program is that much of it's power comes from the choices it allows you to make (rather than an 'idiot proof' workflow that constrains your choices). A powerful program comes to rely on an experienced user rather than intuitions about a workflow.

  • Like 1

Share this post


Link to post
Share on other sites

@digman Ah yes thanks for that channel link. I've been using the tuts on the 3d-coat site, but this is a lot more helpful.

 

@tony I totally agree about the lack of choice constraints. I actually like that, but like you said, it does come with a bit of a learning curve so that you don't mess things up.

 

Thanks again for all the help!

Share this post


Link to post
Share on other sites
Sign in to follow this  

×