Jump to content
3D Coat Forums
Sign in to follow this  
Rgr2005

[Solved] Incorrect UV Mapping in C4D problem

Recommended Posts

The problem i have is the following :

 

 

 

 

-I unwrapped my UVs fine

 

 

-I then baked my normals (with the default shader & name correspondance for baking unchecked as it seemed to cause problem)

 

 

-Normals are fine in the paint room

 

 

 

 

 

I tried exporting the object from the retopo room (Export Retopo Object) & from the paint room (Export Object & Textures), and in those 2 cases, i get a weird UVW mapping in C4D :

 

 

 

 

 

466014Sanstitre1.jpg

 

 

 

 

 

 

 

 

Also, in the Retopo room, i can't move retopo meshes in other UV Sets. I tried with my mesh selected or not in the Retopo room, with the initial object layer selected in the Voxtree or not...

 

 

 

 

 

Anybody has ideas ?

 

Share this post


Link to post
Share on other sites

I see the same features in the normal map as in the C4D render. So explain further the "weird" aspect as it appears to be what one would expect from the normal map. When you try to 'move' meshes in Retopo, are they selected in your UV editor? 

Share this post


Link to post
Share on other sites

Thanks for the answer Tony. I'll answer here so it can help people in the future...

 

My normal map looks & renders like this, which i don't think is right ;) 

 

561532Sanstitre2.jpg

Edited by Rgr2005

Share this post


Link to post
Share on other sites

To use tangent normal map help your workflow ?

Share this post


Link to post
Share on other sites

I'm sorry Carlosan i'm not sure what you mean.

I tried with both Tangent Normal map & World Normal Map (but i read the tangent is better for deforming objects, correct me if i'm wrong).

 

It seems the problem comes from the Uvs themselves.

Any ideas ?

As i said i just unwrapped in 3DC, and tried exporting the mesh from the retopo room & the paint room with textures. The 2 are messed up....

 

122408Sanstitre3.jpg

Share this post


Link to post
Share on other sites

First from your picture it appears you have a problem in your uv unwrapping. The lower right uv island is overlapping itself in the right bottom part of the uv island. You can see the problem area in the uv editor and the texture editor / normal map

 

If you are also having a shading problem that could be due to using the wrong Normal map preset under the Edit \ Menu \ Preferences. Check you will see there are several and which one works for C4D, I do not know

 

I would advise fix the first issue and run a test to see if your problem is fixed . If all is well then you good to go.

Change the normal map preset in preferences if you still are having shading issues. 

 

Tangent normal map is indeed better for animation.

post-518-0-49159900-1452383843_thumb.jpg

Edited by digman

Share this post


Link to post
Share on other sites

Thanks Digman for your answer. I did another new model, as simple as possible to test with normal maps & displacement.

I still have the same problem as you can see :

 

944661Sanstitre4.jpg

 

 

801582Sanstitre5.jpg

Edited by Rgr2005

Share this post


Link to post
Share on other sites

Do you have one uvgroup and one uvset ?

 

At RetopoRoom, could you please

File > Export Retopo Object > export obj

At C4D > import obj

Assign a simple checker

Post the result screen capture

Share this post


Link to post
Share on other sites

I have one UVSet. I'm not sure of what you call UV group...

 

BTW i found the answer to my previous questions, i was not able to move the retopo mesh to a UVSet.

And finally found you had to be in Faces mode for it to be working.

 

 

That being said, here's the screen capture you asked, it's the same as i had when exporting objects & textures from the paint room (previous screen cap).

 

598192Sanstitre6.jpg

Share this post


Link to post
Share on other sites

hmmm...

 

could you share the exported obj to look it on another app.

 

ty

Share this post


Link to post
Share on other sites

Ok so i solved the messed up uv's when importing in C4D by selecting the 3ds Max preset in the OBJ import window !

 

But now i have 2 more problems :

-the first one is that seams appears at each island's border. I haven't put any seams with the same named tool in the retopo room but thought this was just to "relax" the island when unwrapping, in places where there are sharp or narrow shapes...

 

-the second one is that displacement doesn't seems to do much. I tried increasing the strength, height etc with no luck...

 

295070Sanstitre7.jpg

Share this post


Link to post
Share on other sites

I have the exact same problem. I've only imported a lowpoly model from C4D which is rigged and done UV mapping in 3Dcoat.

When i export it back to C4D and apply the tag to the model i exported out it works perfect, but when i place the tag on the rigged one (which is exactly the same) the result get messed up like the picture above. 

Is there something i should be aware of in the import or export from 3Dcoat to get the right results? 

Share this post


Link to post
Share on other sites

Are you using Constructor settings at export ?

This C4D settings helps ?

 

EC.jpg

498258097c34de8c2d46a4ac412ff77e.jpg

Share this post


Link to post
Share on other sites

Thanks for your quick reply Carlosan.

No, that did not help. I can explain exactly what i have done:

1. i model, rigged and animated

2. pulled out my model from the rig removed all tags that might cause any conflicts on export.

3. exported the model to 3Dcoat

4. unwrapped

5. imported back obj with new UV

6. placed the new uv tag to the model i used to export out of c4d,  which was rigged. works. But when i place the tag on the rigged one, even if i pull it out of the rig again it get messy.

When i move the tiles V or U they all move in all directions like they order of the polygons have changed or each poly got their own uvset. So weird

Im thanksful for all reponse, im stressing out here thinking of deadline :)

 

(If i use "keep UV" instead of automapping on import into UVroom 3Dcoat crashes)

Edited by domis

Share this post


Link to post
Share on other sites

Are you using the latest version ?

Share this post


Link to post
Share on other sites

I got version 4.19. I see there is a version 4.23 out. I can try that, but doubt that solve my problem.
Can it be the point order is changed under import or export from 3dcoat? Since from the looks of it the polygons/points are all over the place, or or in the wrong order.

Share this post


Link to post
Share on other sites

Can it be the point order is changed under import or export from 3dcoat ?

can be... what if you export using another file format ?

can you post pics of your export/import settings ?

 

Share this post


Link to post
Share on other sites

I think it's a skinning issue with the C4D rig. I use Cactus Dan's tool so I can't speak to the native rigging, but it seems likely that the new skinning should be done as any editing of the character would require this.

Share this post


Link to post
Share on other sites

Ok, i've tried tonns of things now.

I grabbed the model BEFORE i had skinned/rigged the model, which is only lowpoly with symmetry on. Did the whole process with the same funky results.

After that i tried export and import all options aviable, obj,fbx,dae ect with no luck.

Then i thought it could be symmetry that is doing something with the point order when i collaps it into one shape, but after several tries i still cant get it to work.

Starting to get desperate, give me a hint what i should try and ill try it.

 

I've attached import settings. 

The other forums which i have posted this have not a logical solution. 

1.PNG

2.PNG

Share this post


Link to post
Share on other sites

I believe this is a user here, which even doing this in Cinema4D, this should work perfectly!: God damnit!

To be clear, when i import the obj from 3Dcoat into cinema the UV is correct, its when i apply the new UV tag to the other model (which is the same) the problem  occure.

 

 

 

Edited by domis

Share this post


Link to post
Share on other sites

OK solved at last!

Sorry if this is something i should have known, but this is the first time i've encountered this in this workflow.

I had to delete the UV tag on the model, then generate UVW coordinates so the model gets a new fresh UV layout, then export to do the UV unwrapping. Then export back to cinema 4d with fbx.

That solved it. Thanks for all the help and support, so important.

  • Like 1

Share this post


Link to post
Share on other sites

Hi

I'm posting this picture in the hope that someone can explain what has happened.  I can't work out how to place seams before baking and when I move them after seams appear in the place where they were originally on the the Normalmap layer.

Any pointers would be appreciated.

Best regards

Keith

Capture.JPG

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×