Jump to content
3DCoat Forums
kitsune0

Subdivision working on triangles and not quads

Recommended Posts

So Im getting this weird issue.

 

When I hit the subdivide button either through surface tools, commands, geometry menu or even below voxtree, my model gets subdivided but like if I imported a triangulated model so quads arent splited into 4 quads like it should and instead triangles are splited into several triangles. This is totally messing my model making it full of knots and vertex stars.

 

The thing is that I never had this problem before and I have been working with 3D Coat quite for long time. I didnt change either update 3D Coat recently so I have no idea what have changed since the last time I used the application. I have though that maybe I have exported my model wrongly form 3D Max but thats not the case. The model have been exported to FBX and OBJ but that doesnt make any difference. In fact, if I subdivide the model through the import tool (both with normal and flat subdivision) it gets properly subdivided into quads. I have tried with older models that I have sculpted before and these arent working either. Am I missing something? Its there any option to control how 3DC subdivides the models that I coul have accidentally changed? I didnt include any screenshot as I find it irrelevant. I can tell that the same happens with the included models library too and that I am using 3DC 4.5.23. The models are, of course, in surface mode. Any help would be greatly apreciated, thanks.

Share this post


Link to post
Share on other sites

Ok my problem have been fixed as I found some workaround about this. I would like to delete the threat but I dont see any option for it. If thats impossible simply mark it as solved and sorry for any inconvenience.

Share this post


Link to post
Share on other sites

You can add to the thread by describing your 'work around' for importing triangulated(?) models that wont give you quads.

Share this post


Link to post
Share on other sites

You can add to the thread by describing your 'work around' for importing triangulated(?) models that wont give you quads.

No, my main problem was that I was trying to import quads into 3DC so when subdivided each quad is split in four like ZBrush or Mudbox. But it seems that 3DC cant do that as every model imported get triangulated. It seems that, by a huge coincidence, every model that I imported composed of quads had all the internal edges of each quad oriented to the same direction which gives you, when subdividing, a perfectly smooth mesh exactly as if each quad were divided into four little quads. Since the mesh I tried to import had arbitriary edge orientation (turned edges) when subdivided the mesh gets full of knots and the subdivision result is very far from smooth. Basically this makes 3DC practically useless for subdivision sculpt workaround where you can start with a low poly base and keep subdividing as needed because that will always give you knots and vertex stars. The only way of getting a somewhat smooth mesh its through voxelizing the mesh first which kinda works but you cant start sculpting on a low poly base mesh. Voxels just works in a different way and I like to start with a low quality mesh where I have total control and subdivided only when needed after sculpting bigger details. You can have different quality on voxels but due their nature, isnt well suitable for importing low poly meshes. So, basically, due the workflow and the kind of meshes that I have to do, Ill be forced to use ZBrush whre this kind of workflow its totally possible and less painfull. Would be great if 3DC had a sculpting mode where you can preserve all quads and work only in quads like ZB and Mudbox and just switch to triangles when your model is finished and you need to use Live Clay for aditional details.

Share this post


Link to post
Share on other sites

All models are triangulated upon import into surface mode, just like a game engine triangulates a model upon import. 3DC works with tris unless your are retopoing, baking to the paint room or importing into the paint room.

 

All models imported into voxel mode are turned into the 3D voxel cubes which have real depth, not just a surface representation like polygons.

 

Import the model as is into surface mode and then use the resample or res+ tools (Left tool bar) and see how that works for you...

 

3DC is a different animal than ZBbrush.. Use the strengths of both...

 

You of course can add a feature request but that is for the feature request thread..

Edited by digman

Share this post


Link to post
Share on other sites

Im not talking about voxel mode but surface mode which still works on triangles. Since I often work on voxels directly, I never noticed or needed this kind of workflow but I need to work on base meshes that have been built into 3D Max with quads. Its subdividing into surface mode which gives me an useless mesh which would require hours to repair and smooth all vertex stars and knots while in other app like ZB or Mud I dont even have to bother about that. Im not requesting any feature nor am I saying that 3DC isnt a great software. It simply that I didnt know that 3DC doesnt work on quads directly and trust me that I have been working on 3DC for a couple of years. So that litte lack of "ability" just breaks my workflow and makes my latest works harder hence why switching to ZB. Not like I like ZB anyway but no option since Mud its so limited. Anyway thank you guys for the reply but there is not much to do about this.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×