Jump to content
3D Coat Forums
rooattack

Serious voxel bug ruining all my models

Recommended Posts

There is a bug affecting every model I create. It's really inconsistent. Sometimes when I undo or smooth, or turn symmetry off, it corrupts my mesh and is irreparable. It basically causes he mesh to have zero width on some part of it. I can't even undo to reverse the changes and hope to god that I have saved a recent backup. See attachment to view what happens. Notice the top part of the model's head that looks like its see through and pixelated almost.

post-40222-0-98871300-1458526614_thumb.p

  • Like 1

Share this post


Link to post
Share on other sites

Is this voxels? Your version and OS?

 

If you create a cube and start working it does the same?

 

Can you post a video showing the problem?

Share this post


Link to post
Share on other sites

Yes it happens with every model I have. It's random so I can't reproduce it always. I just had to completely redo a model a few mins ago because it corrupted multiple voxels. See attached. It always creates these jagged edges around the model. 

post-40222-0-52046600-1458585790_thumb.p

  • Like 1

Share this post


Link to post
Share on other sites

That is super weird.

 

One thing that might help shine some light on this, is if you could get something like Bandicam and record yourself as you work, then, when it happens again, just upload the video to youtube and we can take a look at what might be causing it.

 

Aside from that though, can you give us a rough break-down of your usual procedure? ie:

- import mesh from other app into voxel room / create primitive in voxel room

- mostly use tools X,Y,Z

- etc

  • Like 1

Share this post


Link to post
Share on other sites

Could try to use another version as CUDA or DX or openGL ?

  • Like 1

Share this post


Link to post
Share on other sites

Ive attached one of the models that it has affected. Not sure if it can be diagnosed this way. If I reinstall 3D coat, will I lose all of my workspace and presets?

It's a necessary practice to save your UI Workspace/Layouts (WINDOWS menu), Hotkey layouts (EDIT menu), if you added your own custom hotkeys, Presets (via drop0list toggle in upper right portion of the panel), and any Custom Navigation settings. Also, if you created a Custom Theme, you will want to save that as well. Once done, whenever you have really strange, bug-like behavior, try the simplest thing first...restart the app. Sometimes that is all it takes. If that doesn't help, one or more of the .XML files in your "MyDocs/3D Coat 4.5" directory may have gotten fudged up. I will delete all of those .xml files (careful not to delete the LICENSE.DAT or any of the sub folders) > Re-install. That fixes the problem many times.

 

There was an UNDO bug that was recently reported and supposedly fixed in the latest build (4.5.32), so I would try the steps I mentioned > install the latest build > reload your layout and presets. It may seem like a lot, but in practice, it only takes a couple of minutes at most..

  • Like 2

Share this post


Link to post
Share on other sites

You have a couple maybe more solutions to try now , please let us know for the outcome.

Share this post


Link to post
Share on other sites

I did exactly as mentioned with reinstalling. The issue is intermittent, so I will have to create some models and come back to respond. Thank you so much for that advice!

Share this post


Link to post
Share on other sites

Hi. Its happening quite often but what helps Is to convert mesh to global (assign shortcut) So after every major tweak, make it global. Maybe its not a right solution though. 

Share this post


Link to post
Share on other sites

Hi. Its happening quite often but what helps Is to convert mesh to global (assign shortcut) So after every major tweak, make it global. Maybe its not a right solution though. 

 

When I do that, it changes the position of the object sometimes. I just found out that this is consistently occurring when I 'subtract' elements from other elements. So if I use an 'import' object and hold 'ctrl' to subtract that shape from another shape, it happens. Or when I use a Primitive to subtract from another object. I wonder if it could be some kind of graphics card thing. Attached an image of my Apple hardware build

post-40222-0-35993700-1460401999_thumb.p

post-40222-0-69612200-1460402003_thumb.p

post-40222-0-03024500-1460402071_thumb.p

Share this post


Link to post
Share on other sites

Are you pressing the button apply in Tool Options ?

Share this post


Link to post
Share on other sites

Shooting in the dark here, but have you perhaps tried importing your models without voxelization? If you're importing to voxels you need to be sure that everything is watertight. The mesh needs to have some thickness, or you may run into some problems when 3D-Coat takes the process of making it thick into its own hands.

 

I made it my habit to import everything without voxelization. This gives me 100% assurance that my mesh will import WYSIWYG. And only after my objects are imported, I convert them to voxels if it is necessary. This gives me total control over what happens with my mesh.

 

Can you provide source geometry files which, when imported, will randomly generate this bug?

Share this post


Link to post
Share on other sites

Shooting in the dark here, but have you perhaps tried importing your models without voxelization? If you're importing to voxels you need to be sure that everything is watertight. The mesh needs to have some thickness, or you may run into some problems when 3D-Coat takes the process of making it thick into its own hands.

 

I made it my habit to import everything without voxelization. This gives me 100% assurance that my mesh will import WYSIWYG. And only after my objects are imported, I convert them to voxels if it is necessary. This gives me total control over what happens with my mesh.

 

Can you provide source geometry files which, when imported, will randomly generate this bug?

Do what AJZ said...just switch the layer to Surface mode before you hit the APPLY button or ENTER key, and it will commit the object to that layer as a surface mode (mesh only) object. Then, if you want to use voxels, first RMB + Click the layer > choose THICKEN. The default is probably way too thick. Try .5 first and work from there.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×