Jump to content
3D Coat Forums
rosalie.mantion

Ctrl-P export texture with wrong padding settings

Recommended Posts

Hello everyone! 

 

I'm Still getting the hang of 3D Coat. I've been using the Edit All layers in Ext. Editor  (Ctrl-P) to export all my layers to Photoshop. I LOVE this feature! It is awesomely integrated. However, I have been experiencing problems trying to do pixel art using the feature. Basically when ever I use it, 3D Coat exports a .psd file with padding, Even though I have set all the padding settings to Never and 0. 

 

However, if I export my textures using textures/export/all layer colours , It will respect the padding settings that I have set. Is there a way of using Ctrl-P with my padding settings or is it a bug? 

 

Cheers,

Rosalie M.

Share this post


Link to post
Share on other sites

Hello everyone, 

 

I`m just going to bump this up a bit,  and also ask a new questions that has risen up from trying to circumvent this issue. 

 

So like I mentioned earlier, I now export my textures to .psd by using the textures/export/all layer color, which is a lot more clicks that i wish it was... But, i am now facing some issues with grouping of my layers using Layer Folders. I do it inside 3D coat, and as soon as I export them to Photoshop, it will tell me that my folders are corrupted. Thankfully, the paint layers are safe and sound, and I can try to reorganize in Photoshop, but if I re-import to 3D coat, the program will not take the grouping made in Photoshop. I have to do all sorts of acrobatics in order to organise them in 3D coat, and cross my fingers for it to export properly to Photoshop. Once everything seems stable, I can finally start working in both programs. But I have to do it all over again if I ever decide to create a new Layer grouping folder in 3D coat or Photoshop. 

 

 

Anybody face any of these issue before? 

Share this post


Link to post
Share on other sites

Hi Rosalie 

 

Which version are you using ?

Share this post


Link to post
Share on other sites

OK, so just got the latestest version of 3D coat installed v.4.5.19 64 bit 

 

Ctrl-P is still exporting my .psd file with padding even though I have changed my padding settings to never and 0, but the padding doesn't seem to be overlapping on geometry anymore (which was the reason I wanted to remove the padding in the first place) So this might work out for me. Still seams like something the needs to be fixed in the future tough. 

 

As for the layer grouping thing, it still acts up, but only if I do organisation changes in Photoshop. It also wont import a .psd created in 3D-Coat with layer groups properly. Instead of being beside each other, they will all be nested within each other like Russian nesting dolls.

Share this post


Link to post
Share on other sites

Thank you Carlosan for you impute, 

 

Updating also opened up all the new features I had no idea where there! But I must say, it didn't really fix any of my issues. After further testing, everything that had to do with the layer grouping is the same as in 4.1.17(Dx64). It seams that the only stable version I have is in the 3D coat scene I have. If I export it and re-import it into a new scene, the layer groups are all wonky.

 

 

Share this post


Link to post
Share on other sites

Hello everyone! 

I downloaded version 4.7.06 in the hopes of seeing the padding fixed for the Export to Photoshop feature ( ctrl-p).  I noticed a lot of new stuff have been added, but the padding settings are still not respected when it comes to using the ctrl-P hot-key. 

Is there any way this would be on the road-map for the near future or something of the sorts? 

Edited by rosalie.mantion

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×