Jump to content
3DCoat Forums
richn

Settings for importing a low poly mesh for subdivision painting

Recommended Posts

Hi guys,

 

I've been using 3dcoat for a few months but still struggling to get to grips with using it for basic texturing.  I usually model in cinema4d using and then use subdivision smoothing for my final render.  What i'm trying to do is to import my low res (unsmoothed mesh) into 3d coat to paint the textures, but have the uv's smoothed as they would need to be to work with the subdivision smoothing.

 

I'm trying to import the base mesh into 3d coat with smoothing but can't seem to get it to smooth right.  

 

As a really basic example heres what i've tried.  

 

Firstly the top two pics are the mesh in cinema4d, on the left is the low poly wireframe, and on the right is the smoothed version.  Then on the bottom row the left pic is my import settings (i'm importing as object for per pixel painting) and on the right is the resulting smoothed mesh.  But you can see the harsh edges around the edge of the smoothed model.

 

I don't really need to bake out displacements or normally maps but i'm just trying to paint on a smoothed mesh with a low poly base.  I've been unable to find any information on this from the 3dcoat videos so far, Does anyone have any tips or info on what the best workflow for doing this would be

 

Thanks

post-40399-0-41094100-1462242948_thumb.j

Share this post


Link to post
Share on other sites

Sorry for all the grammar mistakes in my first post - can't seem to edit it now.  

 

Did a bit more experimenting with it last night, and i seem to be able to get a good result if i go to retopo room and import the mesh as a retopo mesh (but without snapping it to reference mesh since i don't have one).  

 

From there uv and then finally bake with 'retopo->per pixel (no baking)' and set the initial subdivision a level higher and UV set smoothing to full UV set smoothing

 

I also tried again to load the model using the 'uv map mesh' option from the splash screen but for some reason it always seems to crash 3dcoat.  So for general importing of meshes from other apps is it better to load the mesh into the retopo room first and then send it to the paint room?

 

Thanks

Share this post


Link to post
Share on other sites

You can also try to import the model in the Sculpt Room. There is a tool there in the toolbar called "Import". In the Tool Options of that tool there is a "Select Mesh" button. Click on that to choose your model. If you don't see your model, then use the transform gizmo to scale it up until you see it in the viewport. There is a "subdivide" button there in the Tool Options too. The subdivision used there actually smooths the mesh in addition to subdividing it. When using that tool you will see a preview before importing. Click on the "Apply" button to commit the import, then switch to a different tool to get rid of the preview. Then you can go to the Paint Room and vertex paint it if you want. I don't know if that is the workflow you are looking for, but you can try it out if you want.

Share this post


Link to post
Share on other sites

If you import it to the sculpt room you'll lose your UV's, since you just want to paint on an existing UV'd object I would advise against this workflow.

Share this post


Link to post
Share on other sites

If you import it to the sculpt room you'll lose your UV's, since you just want to paint on an existing UV'd object I would advise against this workflow.

How about:

First import the subdivided high poly into the Sculpt Room, paint on it with the vertex paint method, then Import the low poly (with its UVs) to the Retopo Room, then Bake the vertex paint to the low poly, which will send the low poly to the Paint Room (with its UVs), and then finish up painting any last things on the low poly in the Paint Room. Finally export the low poly with texture maps.

Share this post


Link to post
Share on other sites

Just FYI, I discovered a bug in the Import Tool. The "Subdivide" button is currently not working correctly. It is supposed to subdivide AND smooth, but it is only subdividing right now. The button "Flat Subdivision" is for only subdividing without smoothing. Unfortunately the "Subdivide" button is doing the same thing as the "Flat Subdivision" button right now. I reported this bug to Andrew and hopefully he will fix it soon.

 

In the meantime there is a workaround. You can first import your mesh into the Retopo Room, then go to the Sculpt Room, click on the Import Tool, and choose "Pick From Retopo". If you use that method, then the "Subdivide" button will work correctly. Strangely, it doesn't work with the "Select Mesh" button right now.

Edited by carlosan

Share this post


Link to post
Share on other sites
On 5/3/2016 at 3:23 PM, richn said:

Did a bit more experimenting with it last night, and i seem to be able to get a good result if i go to retopo room and import the mesh as a retopo mesh (but without snapping it to reference mesh since i don't have one).  

From there uv and then finally bake with 'retopo->per pixel (no baking)' and set the initial subdivision a level higher and UV set smoothing to full UV set smoothing

 

This technique helped me for something similar I've been trying to do. Although I set UV Set Smoothing to 'Smooth But Keep Corners'

Thanks for posting it. Don't know why 'Import Object for Per Pixel Painting' sometimes Smooths but often doesn't when Initial Subdivision is selected.

--Shift Studio

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×