Jump to content
3DCoat Forums
AgentSam

[Solved] State of UI setting "Preferences, Hide Scrollers" is incorrect

Recommended Posts

Hi,

 

Please check and confirm if you get the same problem: http://3dcoat.com/mantis/view.php?id=2125

Below are full details of the bug-report:

SUMMARY

 

State of UI setting "Preferences, Hide Scrollers" is incorrect.

DESCRIPTION

 

In "Preferences"-dialog, in "Theme"-tab, the state of the checkbox setting called "Hide scrollers" is the opposite of what it is supposed to be.

When "Hide Scrollers" is CHECKED (enabled), the scrollers are SHOWN.

When "Hide Scrollers" is UNCHECKED (disabled), the scrollers are HIDDEN.

This behavior is the exact opposite of what the checkbox is supposed to do.

STEPS TO REPRODUCE

  • Open "Preferences, Themes".
  • Make "Hide Scrollers" checked, and scrollers will be shown (incorrect).
  • Make "Hide Scrollers" unchecked, and scrollers will be hidden (incorrect).
ADDITIONAL INFORMATION

 

Please see the attached files for a visual description of the problem.

snc4LeG.png

Cheers,

AgentSam

Share this post


Link to post
Share on other sites

Cool! I would never have realized that. I am puzzled as to why one would need to hide scrollers as they are already minuscule. I am sure that command has been wrong for a long time.

Share this post


Link to post
Share on other sites

Mmh, it could be just a translation issue. I mean, if you label the option as "Show Scrollers", then the behavior is correct.

So, either change the label (and make sure it's correct in all languages) - or change the logic.

Cheers,

AgentSam

Share this post


Link to post
Share on other sites

I definitely think it's a translation issue. I never ticked it, so very good catch! I'll make sure to change the wording to something more recognizable for what the function does. :) Thank you for the report!

Share this post


Link to post
Share on other sites

Andrew (administrator)

2016-05-14 08:19

"Hide scrollers" means that actually no right scorr bars will be shown. Instead top-bottom buttons shown that are not eating right space.

So this is nt issue.

Scroll.jpg

Share this post


Link to post
Share on other sites

"Hide scrollers" means that actually no right scroll bars will be shown. Instead top-bottom buttons shown that are not eating right space.

Based on the above, the label of this option is quite unintelligible. To verify, please tell me if I understood this correctly...

Here is how I interpreted Andrews reply:

When "Hide Scrollers = Checked", then top-bottom scroll-bars will be shown, which appear at the top and bottom of a panel.

And when "Hide Scrollers = Unchecked", then vertical scroll-bars will be shown, which appear on the right-side of a panel.

However, I don't think have ever seen any vertical scroll-bars in a 3D-Coat panel, no matter what the "Hide Scrollers" setting is.

UPDATE : Ok, scaled a few panels and toggled the option a few times in an attempt to find the "right scroll bars" and I did get the "Right scroll-bars" to appear. (I think I actually like them better than the top-bottom scrollers.)

I guess I would still maintain, that the label name is misleading; so if it ever gets fixed, I'll be happy. But if the common consensus is that this issue is now resolved, then so be it. Who am I to seek exactness, where none is desired.

Cheers,

AgentSam

Edited by AgentSam

Share this post


Link to post
Share on other sites

A commendable attitude and an example to anyone engaged in littering these forums with complaints.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×