Jump to content
3DCoat Forums
Dennis Nikolaidis

[Bug] Shortcut problem (returns to previous tool selected)

Recommended Posts

Hotkey is already assigned  ?

By pressing the “End” key on your keyboard while hovering your cursor over the tool or function, you can then define which key you want it to be assigned to.

If a hotkey is already assigned you will be asked if you wish to stack the tool/function with any previous tools/functions, allowing you to cycle between all of the tools with one hotkey.

 

 

 

Share this post


Link to post
Share on other sites

I have the same problem. selects the tool for a split second and goes back to the previously selected tool.

Edited by kait kybar
  • Like 1

Share this post


Link to post
Share on other sites

Hello.

 are you using the last stable version 4.7.06 ?

----------------------------------------------------------

Do you have assigned any stack key combination ?

Hotkeys

General Customization - Hotkey

Nearly every tool and function in 3DC can be hotkeyed. By hovering your cursor over the tool you will see the following text, “(‘END’ – Define hotkey)”. By pressing the “End” key on your keyboard while hovering your cursor over the tool or function, you can then define which key you want it to be assigned to.

If a hotkey is already assigned you will be asked if you wish to:

  • Reassign the key with the new tool/function
  • Stack the tool/function with any previous tools/functions, allowing you to cycle between all of the tools with one hotkey
  • Remove any tools/functions assigned to that key

Share this post


Link to post
Share on other sites

I get this problem with the Transform key (T)  It works from the left menu but occasionally the  T key does not accept the press so to speak,the gizmo flashes on for a brief moment . Though I have found if I tap T  twice in quick succession it seems to accept it ?

Dennis ,try tapping twice just to see.See if it works for you...

Share this post


Link to post
Share on other sites

Alright, I dont know what is the problem but one solution is to delete 3d coat from my documents (yeah, better backup your stuff first) and reinstall it. 

Share this post


Link to post
Share on other sites

Do you have assigned any stack key combination ? 

Nearly every tool and function in 3DC can be hotkeyed. By hovering your cursor over the tool you will see the following text, “(‘END’ – Define hotkey)”. By pressing the “End” key on your keyboard while hovering your cursor over the tool or function, you can then define which key you want it to be assigned to.

If a hotkey is already assigned you will be asked if you wish to:

  • Reassign the key with the new tool/function
  • Stack the tool/function with any previous tools/functions, allowing you to cycle between all of the tools with one hotkey
  • Remove any tools/functions assigned to that key

Share this post


Link to post
Share on other sites

nope, always reassign.

It looks like a bug to me, its kinda laggy when I change tools.

Also If I hold the button down, its stays on that tool, let it go and it goes back. 

But after deleting all the 3dcoat folders it runs perfectly again.  Im not sure If its necessary to delete all the folders or only the latest ver.

Share this post


Link to post
Share on other sites

Yeah, I have the same problem on a 3D-Coat-V4.7.24X(64) build, in GL and DX mode. Sometimes it works, sometimes it's acting like this, idk what causes this and what pattern is.

Here is screen capture of this behavior:

 

As you can see, it's choosing desired tool and clicking back to current, but if you click to it with mouse - everything works fine. Pose tool assigned to ALT+E, trasform to ALT+R and Cut off to SHIFT+T. It seems only voxel tools are affected, because even if I choose surface tool on this mesh - shortcut works and it activates in a moment, without delay, unlike voxel tool, as  you can see in video. Other voxel-related shortcuts seems to work OK. I'm also attaching scene file, maybe you can see something in it.

 

UPD: oh, .24 is very old, there is .35 fashionable nowadays. Yeah, with update problem disappeared, at least for now. 

Shortcutslag.rar

Edited by ostapblender

Share this post


Link to post
Share on other sites

Hi guys,

I also have the same problem. Has anybody found a solution for it?

It suddenly appeared and occurs in different versions (4.7.36, 29, 06), stable and unstable.
The only thing, that I recently changed on my system, was installing a Flash player update. Maybe it is related to this?

As I daily use Coat in production, I highly depend on it and reinstalling it everytime would be not a good workaround.

Thanks in advance.

 

  • Like 1

Share this post


Link to post
Share on other sites

Do you have assigned any stack key combination ? 

 

Share this post


Link to post
Share on other sites

Yes, but even without them, the problem occurs. Also changing the shortcuts didn't work out.

I also noticed, that the buttons on the left navigation lag as well, when clicked.

 

Share this post


Link to post
Share on other sites

Are you using latest version 4.8 ?

If yes, please contact for this issue Andrew Shpagin at

support@3dcoat.com

Thx

Share this post


Link to post
Share on other sites

To 99%  I believe, that I found the reason, after several uninstallations and testing different versions.

I had installed the "3DC_brushes" pack from the website.
After deleting it, the problem was not there anymore.

Since then, everything works out great. Still testing though.

@ Carlosan

Thanks for the support.

 

 

  • Like 1

Share this post


Link to post
Share on other sites
On 2/13/2015 at 11:55 PM, coverman said:

I was having the same problem.

 

I read help manual and it is written like this.

Sticky keys does not work with Stacked Keys.

 

So I export my hotkeys from [Edit] - [save hotkeys].

Open it with text editor, replace all

<AllowStack>true</AllowStack>

to

 <AllowStack>false</AllowStack>

 

And reimport.

I was released from that problem. :)

 

  • Like 1

Share this post


Link to post
Share on other sites
On 30.09.2017 at 2:48 PM, Carlosan said:

I was having the same problem.

 

I read help manual and it is written like this.

Sticky keys does not work with Stacked Keys.

 

So I export my hotkeys from [Edit] - [save hotkeys].

Open it with text editor, replace all

<AllowStack>false</AllowStack>

to

 <AllowStack>true</AllowStack>

 

And reimport.

I was released from that problem. :)

I tried this, problem still persists....

Share this post


Link to post
Share on other sites

i uninstalled, deleted the folder, reinstalled, copied all my preferences back over, and so far the issue has not come back.  drastic, but it works for now.  I hope they get this bug sorted out. 

  • Like 1

Share this post


Link to post
Share on other sites

Reported again. Sorry the delay.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×