Jump to content
3D Coat Forums
Andrew Shpagin

3DCoat 4.7 (BETA testing thread)

Recommended Posts

25 minutes ago, EvilNando said:

Is it possible to download a previous version of 3d coat? Im in the middle of a project and I really need the pbr workflow to work 100%

The current Win 64 version link is
http://3dcoat.com/files/3d-Coat-V4_7-35-64.exe

You can just paste that into your address bar and change the current number (35) to whatever you want.  If you need other versions you can get them by right clicking the link on the first page of this thread, then Copy Link Location and do the same as I said above.

Share this post


Link to post
Share on other sites
4 hours ago, Karnonos said:

I cannot export any textures.

Every time I try the program crashes to desktop.

I've tried several versions and breaking up my model into single UV sets, but nothing helps.

Help please!

I just tested it on 4.7.34 and .32, and it seems to export just fine. I would suggest deleting your MyDocs/3D Coat 4.7/Options.xml file and reinstalling. Something probably got corrupted in that config file.

Share this post


Link to post
Share on other sites

Is anyone having trouble with Renderman on the Mac? I've installed latest 3DC Beta and downloaded - installed Renderman. I can open RM etc and have it working, when I switch to Renderman in the render drop down 3DC tells me its not installed. ( btw Marmoset Toolbag 3 now has python scripting - would this help in using MT3 as a App Link render? I'm not into code etc so i have no clue ) I'm a big fan of the native render engine in 3DC, but I think having options like Rendman, Keyshot, MT3 is a big plus. Renderman and Keyshot are quite expensive though for commercial versions.

Share this post


Link to post
Share on other sites

 4.7.36 [stable]

- Fixed problem of Smart material editor.

- Snapping with SHIFT - navigation to 45 degrees instead of 90 degrees.

- Pressing CTRL in UV preview window (in UV room) shows selected islands cycled to neighbour UV tiles.

- Possibility to store camera position in preset

- Gizmo appears even if one point of the transform cage selected

  • Like 7

Share this post


Link to post
Share on other sites
17 minutes ago, unity2k said:

4.7.35 is still showing up on the front page. Downloaded it anyway, renamed it, installed. It's still 4.7.35.

Ok, corrected.

Share this post


Link to post
Share on other sites

A stable version IS coming out soon. ;)

:D  Be sure to report any critical bugs that you may find !

  • Like 2

Share this post


Link to post
Share on other sites

I'm still having curvature's artifacts on the Tile Plane, I know it's not a major bug but I'd really love it to be fixed one day =)

I'm also having an issue from time to time which is not really dependant to this build ( understand : I got the bug here and on many past builds ). It's about the eraser, its "ignore Back Faces" work on its own way, sometime it'll do what you want, but sometime not. Well most of the time to be fair.

I still got strange black "pixels" artifacts when ( in paint room ) :
>I attach a material to a layer
>I paint once
>I paint again and when that second stroke cross the first one, you've got some pixelated opacity arround this stoke but only when you go over the first one, awy it's fine.
BUT ! The issue hits only the smartmaterials where you have a "modulate" color option, I guess it's the same if you modulate the roughness/metalness layers but you'll just see it on these paint channels. I hope this will be fixed as linking a smartmaterial to a layer is an excellent feature =)

Another thing I think it could be nice ; Having the ability to use the smartmaterial's function : more on bright/mid/dark while filling your model with a black to white gradient. Just one click and you could do things faster like having gradually oxidized copper on the go ( on pipelines or rooftops for example =) ). For now it only use the top layer defined into your smartmaterial while filling, I tried out this morning ( before you announced the 4.7.36 build ) on the previous build and it worked almost fine, just sometimes the fill tool doesn't want to fill the mesh or fill accidentaly with the wrong color.

Share this post


Link to post
Share on other sites
3 hours ago, Andrew Shpagin said:

Ok, corrected.

I've mentioned this before, but the initial splash screen that appears when installing a new build, still says 4.5 rather than 4.7. Can we fix that?

  • Like 1

Share this post


Link to post
Share on other sites
10 hours ago, insignet said:

Is anyone having trouble with Renderman on the Mac? I've installed latest 3DC Beta and downloaded - installed Renderman. I can open RM etc and have it working, when I switch to Renderman in the render drop down 3DC tells me its not installed. ( btw Marmoset Toolbag 3 now has python scripting - would this help in using MT3 as a App Link render? I'm not into code etc so i have no clue ) I'm a big fan of the native render engine in 3DC, but I think having options like Rendman, Keyshot, MT3 is a big plus. Renderman and Keyshot are quite expensive though for commercial versions.

AFAIK, renderman in 3DC is not working on Mac yet.

Share this post


Link to post
Share on other sites
20 hours ago, AbnRanger said:

I just tested it on 4.7.34 and .32, and it seems to export just fine. I would suggest deleting your MyDocs/3D Coat 4.7/Options.xml file and reinstalling. Something probably got corrupted in that config file.

No. Tried it. No luck.

What about irregular texture sizes?

I changed my textures to 3k and some 1.5k.

Would that cause problems?

Can someone test that on their machine and let me know?

Share this post


Link to post
Share on other sites

Every so often going to bump here in the beta thread for folders in the Preset panel. I have several special kind of preset brush groups depending on what I am doing. Having to scroll a through a long list of brushes does get tedious after awhile.  Depending of course upon your development schedule adding the feature if possible.

Edited by digman

Share this post


Link to post
Share on other sites
4 hours ago, digman said:

Every so often going to bump here in the beta thread for folders in the Preset panel. I have several special kind of preset brush groups depending on what I am doing. Having to scroll a through a long list of brushes does get tedious after awhile.  Depending of course upon your development schedule adding the feature if possible.

Yep. I just asked Andrew about this, myself, and for the same reasons. Really sorry for asking, because that probably means it won't get added. Oopsie. :D

Share this post


Link to post
Share on other sites
4 hours ago, Karnonos said:

No. Tried it. No luck.

What about irregular texture sizes?

I changed my textures to 3k and some 1.5k.

Would that cause problems?

Can someone test that on their machine and let me know?

Best thing to do is test it on a simple scene from the Splash screen, such as the preset material ball or robot. If it works properly on that/those, then I would send Andrew the workfile (support @ 3dcoat.com) and see if he can find out the root of the problem.

  • Like 1

Share this post


Link to post
Share on other sites

Another try to improve 3DC gui.

My attached concept explains a way how window folders should be displayed in the future.

It is needed for all areas and one of the most important improvements in my eyes.

Drop your 2 cents if you like it.

Thank you
Chris

 

 

 

3dc_folders01.jpg

  • Like 5

Share this post


Link to post
Share on other sites

2 cents dropped lol  , using similar method to IL 1.2

Share this post


Link to post
Share on other sites
18 minutes ago, Michaelgdrs said:

2 cents dropped lol  , using similar method to IL 1.2

Thanks.

What is "IL" 1.2 ?

EDIT: Ok. Got it. You mean "Instant Light". :)

  • Like 1

Share this post


Link to post
Share on other sites

Sorry but, why Show folders as buttons = off is not useful ?

Show folders as buttons off.jpg

Share this post


Link to post
Share on other sites

Please remember

A stable version IS coming out soon. ;)

:D  Be sure to report any critical bugs that you may find !

Keep on reporting critical bugs, there is no time to add any big changes or feature request for this new version.

Thx !

Share this post


Link to post
Share on other sites

 

6 minutes ago, Carlosan said:

Sorry but, why Show folders as buttons = off is not useful ?

Show folders as buttons off.jpg

 Hmmmm it's cool ! But could it be possible to bypass the "Folder" submenu and display all folder's list directly ?

Share this post


Link to post
Share on other sites
3 hours ago, Taros said:

Another try to improve 3DC gui.

My attached concept explains a way how window folders should be displayed in the future.

It is needed for all areas and one of the most important improvements in my eyes.

Drop your 2 cents if you like it.

Thank you
Chris

 

 

 

3dc_folders01.jpg

 

Having names under the materials as an option would be really helpful. I create a lot of materials for things like dirt/grime/scratches etc and those materials are a lot harder to see in the preview than fully opaque materials. It usually comes down to me memorizing the order of my custom materials so I know which one is which without having to hover over each one to see the name again.

  • Like 2

Share this post


Link to post
Share on other sites
9 hours ago, Taros said:

Another try to improve 3DC gui.

My attached concept explains a way how window folders should be displayed in the future.

It is needed for all areas and one of the most important improvements in my eyes.

Drop your 2 cents if you like it.

Thank you
Chris

 

 

 

3dc_folders01.jpg

 

This is really necessary. With having so many materials, the icons become meaningless to a point. Having names as well as the icon would really be useful.

  • Like 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×