Jump to content
3D Coat Forums
Andrew Shpagin

3DCoat 4.7 (BETA testing thread)

Recommended Posts

On 2.9.2016 at 9:20 AM, Michaelgdrs said:

Issue with Layer 0 on paint room.

I want to get transparency so i erase parts of my model on layer 0.

I save and close.

When i re open the scene Layer 0 is there in full!!!.

Happens with any 3d model , even a autopo cube .

Latest versions on DX same happens on GL too.

in my opinion the best advice here is to never use or paint anything on layer 0. For me it is a system layer and have not to be touched ever.

What we do to get transparency is to hide layer 0 for the session.

  • Like 2

Share this post


Link to post
Share on other sites

If i erase parts only on other layers , Layer 0 interfiers on export.

Must erase on Layer 0 and export to get the transparency right.

At least on my end here.

Share this post


Link to post
Share on other sites

Instead of erasing layer 0 to get transparency, you can simply hide it.

---

Ok, I just noticed Taros has already mentioned this.

 

 

 

 

 

Edited by ajz3d
  • Like 1

Share this post


Link to post
Share on other sites

I end up hidding it ,most of the times ;)

Anyway , did anyone noticed issues on voxel scultping? Deforms badly the voxels , noticed it on move.

 

Share this post


Link to post
Share on other sites

The issue I'm finding lately, is that even with layer 0 off, there is no transparency in the layer(s) that are exported. Sure, there's an alpha channel, but like geo_n and I have been harping on (and will forever do until the end of time, or until it's implemented), is that the alpha needs to be in the transparency channel, too. It's crucial really to dealing with lots of textures, lots of objects. Each time you need to create a new transparency channel, for each layer, and then paste the alpha channel into the transparency channel, check it to make sure it didn't leave any wacky edges and then save.

It should just save the alpha into the trans channel, export from 3DC, done.

  • Like 2

Share this post


Link to post
Share on other sites

Is it possible to bring OBJ file for voxelization and keep smooth groups of geometry? When I use Import button in Sculpt room all geometry comes without smooth groups. Try to import a sample object cone, for example. Instead of smooth surface I have sharp angles.

Edited by Vipera

Share this post


Link to post
Share on other sites
3 hours ago, Tony Nemo said:

Click the "Subdivide" button as many times as you need to smooth the OBJ.

Thank you for advice! Another question about retopology mesh. Why when I go to File->Import->Reference Mesh or New file->Perform Retopology->Import reference mesh I have nice smooth reference mesh with textures but if I go to Retopo room->Retopo->Import I have a mesh without textures and smooth groups. This is kind of annoying that program has so many duplicated commands and each of them work in a different way.

Share this post


Link to post
Share on other sites
4 hours ago, Vipera said:

Thank you for advice! Another question about retopology mesh. Why when I go to File->Import->Reference Mesh or New file->Perform Retopology->Import reference mesh I have nice smooth reference mesh with textures but if I go to Retopo room->Retopo->Import I have a mesh without textures and smooth groups. This is kind of annoying that program has so many duplicated commands and each of them work in a different way.

This is because the Retopo Workspace isn't designed to work with textures or shaders. You import meshes or create ones from scratch there, for generating Retopo meshes. You could also consider it a place to bake a target mesh to which 3D Coat sends a baked copy to the Paint Workspace. REFERENCE MESH is an old, legacy option from the V2 days. Send your dense models directly to the Sculpt room.

 

  • Like 1

Share this post


Link to post
Share on other sites

For me in version 4.7.10 the Normalmap layer does NOT respect Clip Mask Layer options.   Has this always been the case or just with this latest version.  

 

I've never actually tried to do any Clip Masking on the NormalMap layers before so I have no frame of reference.  Too busy at the moment to install and try a different version.

Share this post


Link to post
Share on other sites

I use this settings for that task.

I found it resolved.

mask.jpg

mask2.jpg

Share this post


Link to post
Share on other sites
2 hours ago, ghib said:

For me in version 4.7.10 the Normalmap layer does NOT respect Clip Mask Layer options.   Has this always been the case or just with this latest version.  

 

I've never actually tried to do any Clip Masking on the NormalMap layers before so I have no frame of reference.  Too busy at the moment to install and try a different version.

 

I don't know about imported normals, I haven't done that in a while, it did used to work if it's not working now.

 

But for newly created depth layers, it does work for me in 4.7.10 on windoze. I'm using the feature on a project right now, and just in case, I tested in a new scene. It's working without a hitch over here. Just to be sure,  are you using the color channel to mask depth?

Share this post


Link to post
Share on other sites

Thanks for the responses guys.

 

@Carlosan that doesn't work with Imported NormalMaps unfortunately.  This is very much linked to an earlier post I made where I was requesting the ability to paint depth in an Opaque manner above an imported Normal Map Layer.  Currently it doesn't work.

@Javis, yes with Imported NormalMaps the clip masking doesn't work.  So you managed to mask a NormalMap layer using a Layer with an RGB Layer?

 

I believe that possibly Andrew needs to have a look at the functionality of using Imported NormalMaps and painting Depth in 3dCoat.  Currently they feel a little disconnected.

p.s. this has nothing to do with Masking depth painted on a layer in 3DCoat.

Share this post


Link to post
Share on other sites

Bug in 4.7.10:

- Flat shade mode seems to be displaying specular/metalness information instead of just albedo. I am using the roughness/metalness workflow.

- areas designated as metalness in flat shade mode show up as much brighter and colorpicking them does not sample the lighter color as seen in the viewport but rather a color much darker.

- switching from flat shade mode to specular color mode seems to display the correctly painted colors without a lighter filter over the top as seen in flat shade mode?

- In line with the above, painting roughness on a layer adds a mid grey to spec color.. is this normal behavior? Selecting a layer.. turning off all paint able channels except spec/roughness and hitting delete willl return the spec color channel to black. Is this channel meant to be black in a roughness/metalness workflow? or the mid grey?

- it appears that the brightening of metalness areas in flat shade mode isnt  happening in 4.5.40.

Edited by Boonta

Share this post


Link to post
Share on other sites

Further testing:

The following relates to what is seen when going to view > spec color mode, and view > flat shade mode (under glossyness/metalness workflow) using the "preview sphere" (and turning off the ambientocclusion layer that it opens with) Metalness is ZERO in all these cases.

4.5.39

spec color shows up as grey 23%

painting a blue stroke (zero roughness, zero metalness) of 0,0,255 shows up as 0,0,255 under flat shade mode

spec color remains as grey 23% as strokes are painted on it that also contain a roughness value. (behavior is different in 4.7.10)

4.7.10

spec color shows up as black. painting on the sphere with any value of roughness will now add 23% grey to the spec color.

blue stroke painted 0,0,255 shows up as 58,58,255 under flat shade mode!!!

deleting spec/roughness values from this layer will return the color back to the apropriate 0,0,255. when viewing in flat shade mode. Deleting this information also makes the "spec color" go to black.

 

It seems somehow this spec color is effecting what is seen in the flat shade mode.

I am expecting when entering flat shade mode to essentially see albedo only. If for whatever reason other data is showing, can we get a view mode to show albedo only or fix flat shade mode.


 

Edited by Boonta

Share this post


Link to post
Share on other sites
19 hours ago, Boonta said:

Further testing:

The following relates to what is seen when going to view > spec color mode, and view > flat shade mode (under glossyness/metalness workflow) using the "preview sphere" (and turning off the ambientocclusion layer that it opens with) Metalness is ZERO in all these cases.

4.5.39

spec color shows up as grey 23%

painting a blue stroke (zero roughness, zero metalness) of 0,0,255 shows up as 0,0,255 under flat shade mode

spec color remains as grey 23% as strokes are painted on it that also contain a roughness value. (behavior is different in 4.7.10)

4.7.10

spec color shows up as black. painting on the sphere with any value of roughness will now add 23% grey to the spec color.

blue stroke painted 0,0,255 shows up as 58,58,255 under flat shade mode!!!

deleting spec/roughness values from this layer will return the color back to the apropriate 0,0,255. when viewing in flat shade mode. Deleting this information also makes the "spec color" go to black.

 

It seems somehow this spec color is effecting what is seen in the flat shade mode.

I am expecting when entering flat shade mode to essentially see albedo only. If for whatever reason other data is showing, can we get a view mode to show albedo only or fix flat shade mode.


 

 

I can cofirm that Flat shading with specular is broken at 4.7.x. Reported it here http://3dcoat.com/mantis/view.php?id=2189

 

 

Share this post


Link to post
Share on other sites

thanks for confirming that!

- I had to just restart 4.7.10 due to the undo stack no longer recording more than 1 action. strange bug not sure if i can reproduce... will monitor it some more.

- rotate around last draw point seems to randomly reset its self at times as well.

Edited by Boonta

Share this post


Link to post
Share on other sites

On paint room each time we open 3D Coat the opacity value is different.

Sometimes 60 , 90 , 93 etc etc 

 

Just painted a hard asset with 93 opacity and now i must re do it.

Can we please fix the value to be always 100%?

 

Thank you in advance

Share this post


Link to post
Share on other sites

Beta 4.7.10 - imported normal maps are a mess. The only way to limit them is to manually erase them with a brush which takes forever. Using freeze to erase areas of the normalmap layer corrupts their edges with blocky nonsense, and there may as well be no option to mask them using another layer as it has no effect at all. Could you please at least address that last as a workaround for now? Cheers.

Win7 64

 

(Thanks to Carlosan)

Share this post


Link to post
Share on other sites

id love to see some performance improvements on the texture adjustment operations. they are pretty slow when working with many layers and prb materials. more advanced even non destructive adjustments aka Photoshop/substance would be cool to see.

i.e. to preview a change when perfoming a RGB adjustment on a layer atm in my document takes a full couple of seconds to change just one channel i.e. red from 100 to say 120 value.

 

 

also is there any planned updates for using an IDmap in paintroom to aid in masking?

Edited by Boonta
  • Like 1

Share this post


Link to post
Share on other sites

(paintroom) bug:

folders lack the ability to act as a pass through group. i.e. putting a layer set to blending mode "color" inside a folder will be overridden by the folders "standard blend" setting. Expected behavior is that the folder acts as a group only by default and allows whatever layers and blending modes are in the group to act like they should. 

though it seems like this works with some of my groups and layers. maybe its a bug related to the color blending mode only? ( i have multiply and screen layers currently in groups and they appear to be working as expected ....

 

Paintroom UNDO bug:

Undo bug just occurred again. things i was doing at the time: reordering layers. and running a hue/sat/value adjustment.  Undo stack has been wiped and cant undo.

 

Edited by Boonta

Share this post


Link to post
Share on other sites
On 9/18/2016 at 7:51 PM, Michaelgdrs said:

On paint room each time we open 3D Coat the opacity value is different.

Sometimes 60 , 90 , 93 etc etc 

 

Just painted a hard asset with 93 opacity and now i must re do it.

Can we please fix the value to be always 100%?

 

Thank you in advance

I find that depth does the same thing. It's always at some random setting I never set it at when I boot up the program.

  • Like 1

Share this post


Link to post
Share on other sites

Really?? Never noticed it as i always play with NM.

I should have a little check on my latest assets in this case.

 

Thanks a lot J you rock.

  • Like 1

Share this post


Link to post
Share on other sites
9 minutes ago, Michaelgdrs said:

Really?? Never noticed it as i always play with NM.

I should have a little check on my latest assets in this case.

 

Thanks a lot J you rock.

Yeah it's really weird. I don't know why they would be changed at all. Seems like a rather static setting until the user changes it. Or it should be anyway. :o

  • Like 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×