Jump to content
3DCoat Forums
zhivko

PBR reflections distorted

Recommended Posts

Hello guys :)

 I have a problem with the reflections of the PBR shaders. When I paint with very reflective material directly on to the high res model in the sculpt room (just for test) there is no problem, everything looks smooth. But when I bake the normal map and apply the material on to the baked low poly mesh the reflections get distorted, attached are previews of the problem.

P.S I disabled the normal map and everything looks smooth on the low poly mesh, but there are no problems with the normal map, no errors. I also tried inverting the green channel, but there was no improvement.

Any help will be much appreciated.

Thank you!

Zhivko

truck_reflections.jpg

truck_reflections_2.jpg

Share this post


Link to post
Share on other sites

Hi !

Show voxels in Paint Room is = OFF ?

Show.jpg

Share this post


Link to post
Share on other sites

Thank you again for your reply. I really appreciate it.

I just downloaded the new version and tried both GL and DX versions, also updated my video card drivers, but the result is the same. This problem appears only with very reflective materials. When I apply something like a plastic material it disappears or it is hidden in the high roughness of the material.

truck_reflections_4.jpg

Share this post


Link to post
Share on other sites

Can you also try expoting with the new unity preset in version 4.7.03?

Share this post


Link to post
Share on other sites

I cant replicate, sorry

 what if you use any default metal pbr shader ?

Can you share your PBR material (File > create extension > Material tab)

 

PBR.jpg

Share this post


Link to post
Share on other sites
48 minutes ago, Michaelgdrs said:

Can you also try expoting with the new unity preset in version 4.7.03?

Yes, I will try. Thank you for the suggestion :)

22 minutes ago, Carlosan said:

I cant replicate, sorry

 what if you use any default metal pbr shader ?

Can you share your PBR material (File > create extension > Material tab)

 

PBR.jpg

It is the same with the default shaders. Everything is ok until I bake it into the low poly mesh.

The file with the materials is getting too big 182MB. I exported the material which I'm using. Hope it helps.

truck_black.3dcpack

Share this post


Link to post
Share on other sites

PBR.jpg

My test using your PBR material, i can replicate, sorry.

 

 

Share this post


Link to post
Share on other sites

Thank you for your efforts. Do you think it can be a bug in my graphic card or some other hardware problem? It is only happening when I bake the normal map. If I turn it off while it is applied on the low poly mesh the material looks smooth again.

I also tried baking with different presets- Unknown,Unity, Substance, but with the same result.

P.S I just tried and baked the model on other machine and the result is the same..

Edited by zhivko

Share this post


Link to post
Share on other sites

hmmmm... is the AO layer off ?

if not, try to hide it

Share this post


Link to post
Share on other sites

Hi guys! :) Hope you had a good weekend.

I'm still having the same problem and I can't seem to figure out what is causing it... I've done some tests and I'm attaching shots of the testing.  I've tried to resolve this issue in 3 different machines, with different OS and hardware with the latest build of 3d coat and the result is the same. I really want to use 3d coat for texturing because of its awesome tools and flexibility, but with this problem I can't...

Any help will be much appreciated.

Jagged-reflections.jpg

Share this post


Link to post
Share on other sites

I forwarded your issue to

support@3dcoat.com

I'll keep you informed after any news

 

Share this post


Link to post
Share on other sites
9 hours ago, zhivko said:

Hi guys! :) Hope you had a good weekend.

I'm still having the same problem and I can't seem to figure out what is causing it... I've done some tests and I'm attaching shots of the testing.  I've tried to resolve this issue in 3 different machines, with different OS and hardware with the latest build of 3d coat and the result is the same. I really want to use 3d coat for texturing because of its awesome tools and flexibility, but with this problem I can't...

Any help will be much appreciated.

Jagged-reflections.jpg

3D-Coat doesn't support neither: 16-bit normal maps or anti-aliasing and dithering. This is the most probable reason of normal map artifacts. There simply isn't enough precision available to create smooth normal map transitions.

The most likely reason of why you get nice reflections on normal mapped objects in Substance Painter, is that by default SP bakes a 16-bit normal map (instead of an 8-bit one). On fifth image, I believe that you exported a 16-bit normal map from SP, imported it to 3D-Coat and at that point it got converted into an 8-bit image, but without dithering. Hence the artifacts. Try either: exporting an 8-bit normal map from SP, or open a 16-bit version in Photoshop, convert it to 8-bit, normalize, save and import it to 3DC. Photoshop will nicely dither the map on conversion from 16 to 8-bits.

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, ajz3d said:

3D-Coat doesn't support neither: 16-bit normal maps or anti-aliasing and dithering. This is the most probable reason of normal map artifacts. There simply isn't enough precision available to create smooth normal map transitions.

The most likely reason of why you get nice reflections on normal mapped objects in Substance Painter, is that by default SP bakes a 16-bit normal map (instead of an 8-bit one). On fifth image, I believe that you exported a 16-bit normal map from SP, imported it to 3D-Coat and at that point it got converted into an 8-bit image, but without dithering. Hence the artifacts. Try either: exporting an 8-bit normal map from SP, or open a 16-bit version in Photoshop, convert it to 8-bit, normalize, save and import it to 3DC. Photoshop will nicely dither the map on conversion from 16 to 8-bits.

Thank you very much for your explanation! :) I really appreciate it.

I used SP only to troubleshoot the problem. Is there a way to create a smooth normal map inside 3d Coat?

P.S I just tried export an 8-bit normal map from SP and the result is the same. I also tried converting the 16-bit normal map in PS, but the reflection is now grainy, rather then jagged as the previous ones

Edited by zhivko

Share this post


Link to post
Share on other sites

Source

I forgot to mention that it's possible to circumvent the dithering that Photoshop performs when converting between 16bit and 8bit documents by doing either of the following:
 

  1. Go to Edit> Color Settings> More Options> Uncheck 'Use Dither (8-bit/channel images)
  2. Creating a new 8bit document and pasting the 16bit data directly into it rather than doing the usual Image> Mode> 8-bits/Channel conversion.


These methods don't result in textures that look any better visually than baking natively to 8bits but if for some reason that people want to convert without the dithering it works well enough.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×