Jump to content
3DCoat Forums
Smolli

[Solved] Bugs in Mac-version of 4.7.06

Recommended Posts

Hi,

I have the Windows version of 3dc and am now evaluating the Mac version so I can better switch the systems.

I noticed that my 3D Mouse behaves differently between windows and mac. Up/Down and Front/Back are reversed and I can't switch it from the prefernces.

Annoying also thatz the keyboard is set to english and does not addapt to the system language. So, if I want to do an undo I cannot use ctrl+z but must use ctrl+y.

And of course this counts for all other shortcuts, too where the key layout is different to the english one.

I haven't tested versions prior to the newest 4.7 on the mac so I don't know if these are old bugs or have slipped in just recently.

But my question is: will this be fixed any time soon, because if not I will preferably stick to the windows version only. :(

 

Cheers

Philipp

 

Share this post


Link to post
Share on other sites

Hi, sorry for bumping this thread. Can it be that I am the only non qwerty and mac guy with a 3D-Mouse?

What should I do to get these bugs resolved? Can they be resolved? Or not, because the developer has no way to reproduce them?

Cheers

 

Share this post


Link to post
Share on other sites

That's not a bug it's the same thing with photoshop standard shortcuts. The software expect Qwerty key and in azerty lots of modifiers are involved to call said characters.

Anyway a remapping fixed the issue ;)

Share this post


Link to post
Share on other sites

Hi Carlosan,

I must admit that I don't understand what you're trying to say, that hardware mapped keys are normal?

Normally I would expect a z to be a z and y a y on all keyboards, no matter if qwerty qwertz, azerty or what else. Imagien my word-processor if I had to to type y if I needed a z :) Noooooo ;) For me that's a bug. The only other Application that behaves like that is Clip Studio Paint and they know it's a bug, ;) but being a japanese software it may be more difficult for them, don't know.

And what about the 3D Connexion , euu, bug? ;) I would suppose that it should behave the same, no matter the OS. And especially not the same software. My Rhino 3D, or sketchup or Blender, or other software under windows behave the same as under a mac, so should 3D-Coat.

 

Share this post


Link to post
Share on other sites

Let me contact support about this issue.

Share this post


Link to post
Share on other sites
On 7/23/2016 at 2:26 PM, Smolli said:

I had to to type y if I needed a z

And what about the 3D Connexion

1. Instead of “Z” on English keyboard we have “W” on French keyboard therefore Cmd-W will undo the action on French keyboard. Instead of “Z” on English keyboard we have “Y” on German keyboard therefore Cmd-Y will undo the action on German keyboard. This is known problem which should be fixed in time.
2. 3D-mouse should work in the same manner on all platforms. Please try to temporarily rename (or remove) file "~/3D-CoatV47/Options.xml" to reset 3D-mouse settings and please specify more details on "Up/Down and Front/Back are reversed".
P.S. Regarding Mac issues please contact me directly "support DOT linux AT 3dcoat DOT com".

Share this post


Link to post
Share on other sites

Hi SERGYI,

 

thanks for taking care of the topic.

1. Great news.

2. No, that didn't help unfortunately. Up = moves towards me, Down = away from me, Mouse Out = Up, Mouse In = Down. Can be seen nicely when I press the first button to get the icon to adjust the brush. Shows exactly the same behavior but animated.

I'll continue the conversation at your provided email address now.

 

Thanks

 

Share this post


Link to post
Share on other sites
On 7/25/2016 at 1:28 PM, Smolli said:

Up = moves towards me, Down = away from me, Mouse Out = Up, Mouse In = Down.

3D Mouse behaves under OS X in the same manner as under Windows starting from 3D-Coat 4.7.07 for OS X. Please download it from here:

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×