Jump to content
3DCoat Forums
Malo

[Bug] Retopo Problem

Recommended Posts

Hello at all.

 

Got some weird retopo problem today.

I have a pant

retopobug01.jpg

With that Tree

retopobug02.jpg

Then i run Autopo on that pant.

retopobug03.jpg

Everything looks nice so far.

Next step would be to add the other parts of the pants.

retopobug04.jpg

Still no problem.

The retopo is behind the newly added parts. Thats normal, becaus of autoretopo of the pants only.

retopobug05.jpg

 

Now i want to adjust the retopo to the compled modell.

And now the trouble begins.

 

I am not able to bring the vertices and faces above that pant to fit with the belt.

It looks like the autoretopo modell wont recognice the other objects. It sticks with the pants.

But why?

If i start without autopo and do my retopo manuelly it works without problems.

Whats going on here? Why did it works in that way?

Auto Snap is on. It makes no difference if i choose, Snap to closest, Outer surface or Nearest.

If i delete faces and create new ones, it works, the newly created faces and vertices snaps to the belt, but the old ones from the autopo object not.

This sucks.

 

Any idea whats going wrong here?

 

Cheers Malo

 

  • Sad 1

Share this post


Link to post
Share on other sites

Sounds like the typical hassle with 'thin' objects. A work around would be to make individual files with the "Save volume as 3B".

Share this post


Link to post
Share on other sites

Im trying to perform the same scenary.

object sculpt > retopo > add more parts.

autosnap = snap to outer surface

add/split tool > RMB > i slightly move every vertex/edge to snap it to the new surface

 

Share this post


Link to post
Share on other sites

@Tony Nemo

No, it is not a problem with the thin objects.

 

@Carlosan

Little Vid for you

 

 

Maybe that explain it a little bit better.
 

Excuse me my bad english, it is not my main language.

 

  • Like 1

Share this post


Link to post
Share on other sites

ahhhh... you right. Looks as bug.

autosnap only work from normal camera projection.

merge visible or merge subtree is not helping.

Share this post


Link to post
Share on other sites

Merging wont realy helps.

If i merge the cube and sphere with booleans, it works. because i get one object with no gabs and holes.

But as you know, in Surface Mode, you cant realy allways merge the objects. You often gets an error if you try to do that.

 

My pants and sub objects wont merge. I allways get an error. I could merge it with No Booleans, but at the end, it is the same as i would work with single objects, there is no difference.

 

 

Share this post


Link to post
Share on other sites

yes, i found the same issue. merging wont help.

  • Like 1

Share this post


Link to post
Share on other sites

Confirmed. Fully reproducible in 4.7.06. For some reason vertices try to snap to the sphere, no matter what snapping algorithm is used. Sometimes it helps to have the cube selected in the VoxTree, but not always.

BTW, why there's no snapping based on camera, like snap to nearest surface based on camera position and on what the camera is looking at? NVil has this and it works great, and while I don't use it frequently, it's an excellent mode for fixing weird snapping issues. It's completely independent of normals. It just snaps to whatever surface it finds closest to camera and what is currently under the cursor.

Edited by ajz3d
  • Like 1

Share this post


Link to post
Share on other sites

4.7.07 improvements solved this issue ?

Share this post


Link to post
Share on other sites

Just confirming this still with 4.8.16A Mac :(

Brush, relax, snap tools all don't help. Merging visible voxels also no help. This is a bit of a workflow killer...

Share this post


Link to post
Share on other sites

Test new version please

osxicon.pngmacOS [4.8.18B]: 

http://www.pilgway.com/~sergyi/3DCoat/3DCoat-4.8.18B.dmg

Ensure to check "System Preferences > Security & Privacy > click the "lock" > select "App Store and identified developers" (when only "App Store" is selected error message is displayed "3D-Coat" can't be opened because it was not downloaded from the App Store) 

3DCoat crashes on startup

Share this post


Link to post
Share on other sites

Thanks will do now.

OK Still the same in 4.8.18B Additionally I've found that deleting part of the retopo mesh to rebuild even, a lot of the time the new geometry doesn't even conform to the outer surface of the new voxels/sculpt--- e.g. using points/faces to add points, they often fall 'behind' the new sculpture parts.

Here's what I'm trying to work on: I imported the retopo mesh from Blender, no problem, brought it's geometry into Sculpt room OK, added ribs overlay layers (using vox layer I think mostly, but also curves for clavicles), then going back to retopo room, can't conform/snap the old retopo mesh to the new ouside surfaces of the sculpts. I've tried merging the voxtree, that didn't help, and tried between surfaces/voxels, also no help.

This is weird and frustrating. Normally 3Dcoat is my goto for retopo!

OK, I think I've found a workaround. As I already had a Surface material from a previous bake to paint room, If I delete that material, the Snap command etc. work again as expected to the outer surface. This still seems like buggy behaviour though, and only by accident that I discovered a 'solution'. Seems worth looking at don't you think?

Screen Shot 2018-07-26 at 1.13.40 pm.png

Edited by Hammers

Share this post


Link to post
Share on other sites

can you share the project to take a look ?

Share this post


Link to post
Share on other sites

I'm uploading to dropbox. I did find that workaround as I mentioned. But here is the earlier version.

In this version I've already merged the ribcage in the voxel room, and it still doesn't work. But Ideally I would hope you wouldn't have to necessarily. Maybe I'm missing something, but voxel layers shouldn't necessarily correspond to retopo groups etc.

Notice that in Retopo, Snap, relax, brush all fail to register the new ribcage voxels. Maybe other tools too? EDIT just retried and setting to 'Snap to Nearest' seems to work, at least with the merged voxels, but not Snap to Outer/Closest along Normal, which would make more sense I would have thought.

Thanks for looking!

https://www.dropbox.com/s/l6fx6dlv3eyhfzk/SnapBugDemo.3b.zip?dl=0

 

Edited by Hammers

Share this post


Link to post
Share on other sites

Still a bit confused, As per your screenshot I deleted the paint layers except layer 0. No difference.

The surface material is named UVMap and deleting that did the trick. To be honest I find the interrelationships between Surface Material, Paint object, UV set and retopo mesh pretty confusing. Can you point me to a nice explanation of those, for dummies?

Anyway thanks for your help. Hopefully I'll google this answer again when I forget next time :)

 

 

Share this post


Link to post
Share on other sites

I am reporting this as bug, dont worry.

Share this post


Link to post
Share on other sites
On 8/1/2018 at 4:52 PM, Carlosan said:

Hi

Retopo mesh is snapping to old baked mesh still present on Paint Room.

Go to Paint Room > Windows > Popups > Surfacematerial, delete all.

Then on Layers use the command delete unused.

Try moving again vertex using autosnap = on

Hope this help

 

 

Delete all unused.jpg

This saved my ass. Also had a snapping issue. Thanks alot

Share this post


Link to post
Share on other sites

×