Jump to content
3DCoat Forums
Sign in to follow this  
Creator

[Solved] Opposite action to extrude

Recommended Posts

Hey!

During last months I'm using 3D Coat mostly for 3D printing, which seems to be the best tool for fast prototyping and merging stuff.
Unfortunately my printer is NOT the top quality device. When I create accurate models it always adds 0,15mm of material to each side.
It happens because it's hard to keep proper thickness of heated plastic pouring from the nozzle.
Now... my solution is to create stuff with dimensions lowered by 0,15mm on each side and it works, but I would prefer to:

  1. design proper dimensions (so i can reuse it in better printers later);
  2. save file;
  3. shrink all walls on normals directions by 0,15mm;
  4. export to STL;
  5. be happy with proper print;

There is Extrude option that "inflates" object. I've tried Extrude with negative values but it creates ugly geometry.
One of the silly workarounds is to Subtract component in a cube, creating something like a mold. Then extruding it by amount you want and subtracting our "mold" from another cube.
This way you get thinner model in every place.

Is there any tool that can do something like inverted-extrude?

Share this post


Link to post
Share on other sites

Extrude accept negative values (-#)

Can you test it please ?

Share this post


Link to post
Share on other sites

As I said I tried negative values, but it looks like this:
negative_extrude.jpg

I know why it's happening, normals are getting crossed. It will happen in every 3D app, when you revert extrusion. I think I saw deflate in some 3D app that take care of all faces and normals to not intersect or cross each other. I think 3D Coat should be able to do this too :)

Share this post


Link to post
Share on other sites

May be RMB > Thicken, and subtract could help, but sorry... out of ideas :(

 

Share this post


Link to post
Share on other sites

Ok I found better workaround:

  1. Go to "Extract Shell" in layer actions => "Make Shell Mesh Using Voxels";
  2. Set thickness - it will make shell inside your mesh without artifacts;
  3. Now turn Surface mode;
  4. Run "Objectify(Separate)" - set some basic option to avoid layers with small dots - delete: 300 worked for me;
  5. Select layer with your shrank object - it will have flipped normals;
  6. Go to "Flip" => "FlipNormals";
  7. Your object is ready :)


Anyway it would be cool to have such functionality on one action ;)

  • Like 1

Share this post


Link to post
Share on other sites

Run "Objectify(Separate)

smart ! ;)

glad you found a workflow :good2:

  • Like 1

Share this post


Link to post
Share on other sites
On 20/7/2016 at 1:55 AM, Creator said:

Ok I found better workaround:

  1. Go to "Extract Shell" in layer actions => "Make Shell Mesh Using Voxels";
  2. Set thickness - it will make shell inside your mesh without artifacts;
  3. Now turn Surface mode;
  4. Run "Objectify(Separate)" - set some basic option to avoid layers with small dots - delete: 300 worked for me;
  5. Select layer with your shrank object - it will have flipped normals;
  6. Go to "Flip" => "FlipNormals";
  7. Your object is ready :)


Anyway it would be cool to have such functionality on one action ;)

Fine!;)

Share this post


Link to post
Share on other sites

I do not 3D print but it appears that the 3DC to 3D printer export has a setting that might help in your case. 

Sculpt Room: File Menu ---- Export for 3D printing which brings up the export panel. 

If this does solve your problem, please post here as I will tell others about it in the future.

help.jpg

Edited by digman
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×