Jump to content
3DCoat Forums
vladius

Spacing Issues Research Thread

Recommended Posts

OK, I've decided to make some verbose testing to diagnose the spacing issues that I've met so far.

Anyways, I welcome everybody to my journey for perfection. So far I've made the following tests with different Spacing and drawing types configurations. Stay tuned!

Hope that the devs will see this thread, as I think the whole story is very important.

 

3d-coat-spacing-test-02.png

 

Edited by vladius

Share this post


Link to post
Share on other sites

Using Absolute tool in Surface Sculpt mode.
Current discoveries:

1. Even when you turn Spacing off, there is still spacing applied. And there is even more to it. In fact, if you turn on Spacing but set it to some low value of 1% (or even %0.1) the resulting spacing is *lower* than that of using no spacing at all. This is a very cheesy behavior, if you ask me.

@developers: Make UI clear, that using Spacing with low values produces more sampling than using no Spacing atl all.

2. Spacing and curve segmentation are different things. You can decrease spacing with low spacing values, but the segmentation settings seem to be built-in and brush-size-dependent.

@developers: Make curve segmentation explicit, just like spacing is. Make some kind of Detail value, that would define how many steps are sampled during a single curve segment.

3d-coat-spacing-test-01.png

3d-coat-spacing-test-03.png

Edited by vladius

Share this post


Link to post
Share on other sites

Please drop a email at support@3dcoat.com with your Spacing Issues Research.

Ty !

Share this post


Link to post
Share on other sites

Using normals-only Brush tool in the Paint room.
Current discoveries:

1. As in Sculpt room, the minimal spacing is better than no Spacing at all.

@developers: Make UI clear, that using Spacing with low values produces more sampling than using no Spacing atl all.

2. Brush with a 1% spacing produces perfect result.

@developers: Do nothing with this case =D Try to produce similar results for the Sculpt room, please.

3d-coat-spacing-test-05.png

3d-coat-spacing-test-04.png

Share this post


Link to post
Share on other sites
3 minutes ago, Carlosan said:

Please drop a email at support@3dcoat.com with your Spacing Issues Research.

Ty !

Ok, will do it right now. Thank you for your response.

Share this post


Link to post
Share on other sites

I have found one more perfect scenario and it's in the Paint room as well. The per-pixel normals + displacement mode still yields perfect results with a 1% Spacing.

Seems like the Paint room's algorithms do sampling just right, both affecting curve segmentation and brush alpha placement.

@developers: If it hard to derive automatic values in the Sculpt room, make them at least totally explicit to the user.

3d-coat-spacing-test-06.png

Share this post


Link to post
Share on other sites

For the last issues, I have found a workaround. Uncheck the Additive Painting flag in the Depth channel paint options to get identical results for sub-curve crossings. See the illustration:

3d-coat-paint-room-sub-curves-workaround.png

  • Like 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×