Jump to content
3D Coat Forums
thinkinmonkey

Normal map "cut/flat" importing from Designer

Recommended Posts

Hello,

I need help about this: as you can see from images, the normal map created in Substance Designer creates a nice result, I tested it also in Blender.

In the first image you can see the normal map imported in 3DC, in the smart material slot, but the result is totally different: why?

Thank you.

Screenshot_49.jpg

Screenshot_50.jpg

Share this post


Link to post
Share on other sites

Hi !

Change Preferred Mapping to UV-Mapping

Share this post


Link to post
Share on other sites

Hi Carlos,

sorry, I didn't explain correctly: I'm not concerned about the mapping aroung the object, I'm concerning about the fact the normal map seems to be "cut" or "flat".

While in Designer and Blender I have this half spheres all around, in 3DC they seems flat, like cylinders or truncated spheres!

How is that possible? How can I fix that?

Share this post


Link to post
Share on other sites

can you share the project to take a look ?

orizzontale_mask is affecting anything ?

Share this post


Link to post
Share on other sites

orizzontale_mask is a layer used for the group as mask, switching on/off doesn't affect the bad result.

Anyway, I tried with a new 3DC, using the face model at the startup, duplicating a smart material in default (the chrome one) and I added the normal map, but I have the same bad result.

I can share with you that normal map, the grid of spheres.

Everything started as I saw a difference between Designer and 3DC about a more complex normal map, this is why I'm using that grid of spheres.

Please, let me know, because I need to have that fix in order to work.

Thank you again for your precious time.

black__normal.png

Edited by thinkinmonkey

Share this post


Link to post
Share on other sites

Please try this.

Is the same 32bits image, but without alpha channel -removed-

hope this help.

//edit

i cant paint with fine details using this normal map in a new smart material

but looks fine importing the same texture using Texture > Import > NormalMap.

- Please send support-related ticket with this issue to Andrew Shpagin at support@3dcoat.com

Ty

black__normal.thumb.png.adbd981ce2366238f9a8c678a63dcc20.png

Share this post


Link to post
Share on other sites

Yeap, exactly!
I was sending you a screenshot where it didn't work even with your no_alpha normal map in the smart material, but it works flawlessly if imported as you suggest.

Anyway, I'm gonna write Andrew right now.

Carlos, thank you again for your time.

Michele

 

P.S. If I could, why did you take out the alpha channel in the normal map? There's a particular reason?

Share this post


Link to post
Share on other sites

No need to use normal map for this. Export height from SD in .exr format and use it as height in your Smart Material.

Share this post


Link to post
Share on other sites
1 hour ago, ajz3d said:

No need to use normal map for this. Export height from SD in .exr format and use it as height in your Smart Material.

Hi ajz3d,

ok, as Andrew answered me: no normal map, but height map.

So I changed everything in Designer to work with that.

Now, I have a question, for sake of curiosity: why I have strange result if I put 100% in the depth value and I get a good result if I use 5%?

I mean, 100% should be using the height map as it is, and putting that value up or down should just enhance or dim the result, right?
 
 

black__height.exr

Screenshot_3.jpg

Screenshot_2.jpg

Share this post


Link to post
Share on other sites

Is depth map from the link the same as used on screenshots? Looks different.

screenshot_16-10-11_17_54_22.jpg

Edited by ajz3d

Share this post


Link to post
Share on other sites

This is in Designer, the height map coverted to normal map just to be seen in viewport:Screenshot_5.jpg

 

This is in 3DC, when material Depth is 50% and paiting depth is 50%:

Screenshot_6.jpg

 

This is when material and painting depth are 100%

Screenshot_7.jpg

Should I suppose that 50% depth value in smart material says to 3DC: hey, gray is height 0?

 

Share this post


Link to post
Share on other sites

Here's how it looks on my 3DC instance. 100% SM depth, 100% brush depth.

screenshot_16-10-11_21_22_27.jpg

Maybe your paint layer has depth opacity > 100%, or you made some changes in SM height channel's extended parameters window?

Share this post


Link to post
Share on other sites

ajz3d,

I checked what you said, but everything seems normal to me.

But now I don't know what to say, because the texture is working right now: I switched to depth & opacity pressure stroke mode and modified the contrast in the sm as you have done and the problem seems gone now.

I'll check with the final texture and I'll let you know.

For the moment, thank you, guys.

Good night

Share this post


Link to post
Share on other sites

Your height map from SD is pure black and white. zero height in 3DC is 127,127,127 gray.  White would be 100%. Smart Materials depth is base off the percentage of  your setting in the depth setting in the top menu.  100% in the main setting and a setting of 50% in your smart materials = 50% height of the 100% in the top menu.  That is how 3DC smart materials work.  Always make your SM materials at 100% in the top menu and adjust your percentage of that in the Smart Material. That is my recommendation, less confusing and more so if you share your smart material.

  • Like 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×