Jump to content
3DCoat Forums
PolyHertz

[Solved] Lock framerate ?

Recommended Posts

Is there a way to lock the framerate in 3D-Coat to 60fps?

I ask because I just got a new Pascal GPU and the uncapped framerate causes coil whine (plus I don't own a 120/144hz monitor to take advantage of it anyway).

Share this post


Link to post
Share on other sites

I would love this aswell. Both gpu's I've had scream when using 3dcoat, (the only program that seems to do it) and it can't be good running at about 800 fps.

It's mildly annoying having to run nvidia inspector everytime I wanna use the program and it does not seem to solve it everytime.

Thumps up for the option of capping it at 60fps. Please!!!

  • Like 1

Share this post


Link to post
Share on other sites

This may be the issue I'm having with 3d coat causing my laptop to shutdown even during retopo. I get the same problem when playing high end games. It causes my laptop to start draining power from the battery as it can't get enough from the plugged in power.

Share this post


Link to post
Share on other sites
On 22.03.2017 at 4:02 PM, Royston said:

It's mildly annoying having to run nvidia inspector everytime I wanna use the program and it does not seem to solve it everytime.

You don't have to start nVidia Inspector each time. Once the parameter is set, it will be remembered.

On 18.11.2016 at 10:37 PM, PolyHertz said:

Unfortunately though, that method causes massive brush lag in 3D-Coat.

That's odd. I have it set to 60 fps and have never observed any brush lag. And that's on a quite old GeForce card (GTX 660Ti).

Edited by ajz3d

Share this post


Link to post
Share on other sites

A other option is adaptive vsync:
Nothing is more distracting than frame rate stuttering and screen tearing. The first tends to occur when frame rates are low, the second when frame rates are high. Adaptive VSync is a smarter way to render frames using NVIDIA Control Panel software. At high framerates, VSync is enabled to eliminate tearing. At low frame rates, it's disabled to minimize stuttering.


Adaptive vsync or normal vsync works with 3D Coat GL. But 3D Coat DX Version does not respond to vsync settings, always over 600 fps. That's why i use the GL version although i have a Geforce card.

setting.jpg

Share this post


Link to post
Share on other sites

I've been using NVidia cards with 3D Coat for several years, and I never hear any coil whine. But then, I always get the cards with aftermarket style cooling (2 or 3 fans). 

Share this post


Link to post
Share on other sites

It should be an option in 3dCoat DX and GL to cap frame rate, possibly turned on by default, since the raging fans is the first thing noticed when launching it.

  • Like 1

Share this post


Link to post
Share on other sites

Furthermore frame rates above 60 fps are useless if the monitor only runs at max. 60 Hz. For what hundreds of fps?

Edited by Spacetime

Share this post


Link to post
Share on other sites

Same on my side. Have that coil flipping, too.

A lock for framerates would be nice

  • Like 1

Share this post


Link to post
Share on other sites

This makes the application appear very amateur. I'm running the demo and my fans are revving like race-cars. Then I notice the frame-rate is ~240fps! I'd definitely settle for 30fps in exchange for peace & quiet.

Share this post


Link to post
Share on other sites

Hi 

In the actual build of "3DCoat" you find new option "VSync" inside menu "Edit > Preferences"

Works under DirectX and OpenGL

Please give a try.

Thx.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×