Jump to content
3DCoat Forums
Andy Yelland

3ds Max unwrapped normal map seams

Recommended Posts

We are having problems exporting geometry/textures from 3D Coat to 3ds Max.  We are particularly interested in the normal map export, and subsequent application to the model in Max.

For testing we have created a simple cylinder, and applied a brick texture.  The normal map we have was originally created from a height-map inside of 3d Coat.  If anyone wishes to download the 3b file, I've popped it here.

We select Export from 3d Coat, and so far have tried both OBJ and FBX and get the same result.

We then import the geometry into Max, and set a "Normal Bump" map type onto the Bump channel of a Standard Material, and apply the exported normal texture to the "Normal" slot in that map.  We keep Channel Direction as default (all unselected), and Method as "Tangent".

If we choose to scanline render, we find that the cylinder has an incorrect seam (See attached image).  In more complicated scenes, there are more visible seams, seeming to coincide with UV atlas edges.

seam render.png

Atlas

unwrap.jpg

We have chosen the "3D-Max" option for "Normal Map Software Preset".  Our full options are:

options.jpg

We have also tried flipping, but no setting got rid of the seam:

  • Swap Y & Z Scene Axes
  • Normals Calculation Method (3D-Coat / Maya Normals)
  • Tangent Space Standard (mikkTSpace / Lengyell / Unity)

I am figuring that this has to be an expected workflow of 3D Coat, but somehow we have a setting wrong somewhere.  I'm unsure of whether this is a 3D Coat setting, or in our setup inside of 3ds Max.

The Max file (2017) is here, and the texture here.

Can anyone see what is wrong?

Thanks in advance

 

Andy Yelland
Technical Director

Share this post


Link to post
Share on other sites

Hi Andy.

There is an Max applink taht could be useful for your workflow.

Could you please take a look ? Ty.

 

Sidenote:

The latest release is 4.7.17

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×