Jump to content
3D Coat Forums
JBT27

[Solved] Only one UV set available when more were created at import

Recommended Posts

I import a LW object, which has two surfaces named, for UV mapping.  The dialog is the one for importing a mesh for per pixel painting, and maybe this is where I misunderstand.  Once I hit OK, I have only the first UV set.  Kind of confusing (to me), when it looks like it's going to generate one UV set per surface.  I assume it isn't, because it doesn't, and that if you want different uv sets per surface, you have to set that up separately.

3DC UV Set Problem.JPG

Share this post


Link to post
Share on other sites

To change this settings help you ?

 

Keep.jpg

TR.jpg

Share this post


Link to post
Share on other sites

Try the below as well if your LW object only has "surface/materials" created and no uv maps.

Keep auto-mapping...

 In the dialog box --------Select " Treat materials as separate textures" It is after auto-smoothing groups.

Materials is the same meaning as "surface"  

EDIt: I am doing some testing as that did not work on my end... I will report back when done testing.

 

Edited by digman

Share this post


Link to post
Share on other sites

My mesh has no UVs out of LW, just those two surfaces/materials.

Thanks digman - I had already tried that, but it still only shows one UV set, the first one in the list, once I hit OK.

Thanks as well Carlosan, but it's the same problem.  The only way I can get the two UV sets into the UV room to work on them is if I import the mesh already with two UV sets.  I tried the settings you listed, but if I tell it to keep UVs, when the mesh has none on import, the mesh is invisible in the workspace and I can do nothing with it.

I was wanting to allocate one surface/material to one UV set, and another to a second UV set; again, I assumed that the dialog was setting up one UV set per surface/material.  If I import a mesh with ten surfaces, I get ten UV sets in the import dialog, but only the first is workable in the UV room - the rest don't appear in the UV menu at the top.

I may well have misunderstood the workflow, and in fact ten UVs for ten surfaces is something I don't want anyway, mostly.  It seems it's easier to allocate surfaces to UVs outside of 3DC, then use 3DC to edit each UV.

Share this post


Link to post
Share on other sites

Have you model different materials assigned ?

Share this post


Link to post
Share on other sites

It has two materials assigned.  'Central Wall' and 'Side Walls', as in the screengrab above where those names are in the UV sets fields.  3DC seems to take the material names and set up a UV set for each, except only the first in the list seems to get used.

Share this post


Link to post
Share on other sites

I've never seen this problem here on my machine. Really strange.

If you would send me the model, then I could take a look at it. Zip it and post it for download or send me a pm with the link.

Share this post


Link to post
Share on other sites

Here is my test object, as a LWO and an FBX.  Very small and simple mesh.  Two materials assigned, but no UVs.

I'm still not sure I am not misunderstanding what is supposed to be happening.  It seems clear enough that each material on the imported mesh gets a UV set on import, and that you can either auto-map it, or keep any existing UVs.  That's what it looks like to me.  I'm using the Windows version 4.7.06.

Thanks for taking a look.

MultiUVProblem_Objects.zip

Share this post


Link to post
Share on other sites

I did the same tests as you and got the same results using Auto-Mapping.

I have derived this problem to developers.

I'll keep you informed as soon as I know something.

--------------------------------------------------------------

To keep it working please use the option KeepUV

 

KeepUV.jpg

Share this post


Link to post
Share on other sites

Thanks very much Carlosan.  KeepUV has the mesh invisible though, so the only way to deal with this is to apply any kind of UV to the required material sets, outside of 3DC, then import and edit UVs - that does work.

Thanks again.

Share this post


Link to post
Share on other sites
3 hours ago, Carlosan said:

I did the same tests as you and got the same results using Auto-Mapping.

I have derived this problem to developers.

I'll keep you informed as soon as I know something.

--------------------------------------------------------------

To keep it working please use the option KeepUV 

 

 

 

 

I found the same problems as well... This is not working as intended...

 "Treat materials as separate textures" should  create separate UV sets according to the tool tip... 

Capture90.PNG

Edited by digman

Share this post


Link to post
Share on other sites

You can create the Uv sets inside of 3DC as well using Perform Retopology. Shown in the pictures.

Right side of the the pictures shows the two options.

Import reference mesh... This will load a reference model into the retopo room, then under the retopo menu import the same model to get the polygon mesh. retopo layers will be created per material. You can create more than one uv set. When asked to snap the mesh to the object select no as the polygon mesh already is a perfect match.

Import retopo mesh will just import the polygon mesh but the rest is the same. Even though it says without a reference mesh this is not a hindrance in creating the uv sets.

The above is not a tutorial on how to use the retopo tools for creating your uv sets or sets but to inform you this is an option.

 

Capture90.PNG

Edited by digman

Share this post


Link to post
Share on other sites

Thanks very much - yes, that does offer an option - just tried it.  However, the FBX seems to work better than the OBJ - the FBX imports with the active UV set solid, and the inactive one translucent.  But, I seem unable to mark seams on the active mesh.  It seems very counter intuitive - I can make a seam stick on the inactive mesh, but not the active one.  Plus, which is likely me, I cannot find how to display the texture panel in the retopo room.  I can't tell if this is working or not, but it doesn't have the clarity of a single UV set in the uv room, which works great.

But fine, I'll wait for a fix on the other, plus plough on trying to understand this retopo option.

Thanks again - appreciated.

Share this post


Link to post
Share on other sites

Once you learn how to use the retopo tools and the use of the retopo objects layer grouping, it is very fast to create the desired seams and uv sets. 

FBX object----This just took a few minutes to complete...

The side walls and the central wall are on their own retopo layer and unwrapped to their named uv set.

 

 

Capture45.jpg

Edited by digman

Share this post


Link to post
Share on other sites

That's making some sense now - I've done what you are showing in the screengrab and getting predictable results.  Great - thanks very much.

Share this post


Link to post
Share on other sites

Hi!

 
Auto mapping always keeps 1 uv-set. The only way now to go with auto-mapping and several initial uv-sets is to import keeping UV, go to UV room and automap each set separately.
 
Andrew
  • Like 1

Share this post


Link to post
Share on other sites

Thanks for the heads up on that... too bad it does not work for auto-mapping too. My method then still stands, import the model into the retopo room and create your uv sets. no mess no fuss. 

My question would be if you have uv sets already and generally they have materials setup too, why would you want to use "Treat materials as seperate textures (uv-sets) since that would override your uv-sets. Maybe in some cases you would do it, can not think of one off the top of my head.

Edited by digman
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×