Jump to content
3D Coat Forums
Alex Z

[Solved] Smart Material - Normal Map how it works ?

Recommended Posts

Hi guys!

I have 12mb 2k Normal map, when i apply it directly to a mesh (via import texture file) it reads fine, the quality is 100%.

When i plug this same texture into a Smart Material (using the same exact scale) and apply it to the same mesh the result is very undesirable. I can only assume the Smart Material compresses the life out of the Normal Map for the sake of speed and hence the quality being very poor.

Is there a way to potentially solve this?

Below are examples :

Direct Normal -

pZVQEOO.jpg

 

Smart Material Normal -

 

N02Twn3.jpg

 

Lastly i'll add a .Rar file with the texture used and the mesh (simple UV unwrap). Hopefully this will provide Hands-on understanding.

 

Cheers,

Alex.

 

Normal Map Comparison.rar

Share this post


Link to post
Share on other sites

This would be best if I could look at your original texture file. It would save time and a bunch of texting back and forth in this thread. If possible share the file through a private pm. Post it on a server and send me the link... 

Share this post


Link to post
Share on other sites

Hi Digman,

I attached the texture and model used at the bottom of the original post, hopefully this works?

If not, reply here and i'll source another way!

Cheers!

Share this post


Link to post
Share on other sites

Alright, I'm very happy to say I managed to solve this problem.

I Converted the Normal Map i was using into a Full Greyscale image via Photoshop ( Image > Mode > Greyscale ). This type of map has a very high quality read. Once plugged it into the Smart Material's Depth slot I was immediately impressed.

I'm guessing when Black and White maps / Height maps are plugged into the Depth slot, they are on-the-fly converted into Normals. Much like most stand alone Normal map generator programs, ( Crazy bump, Awesome bump, etc )

From now on i won't be using Normal maps in the Depth slot, as Greyscale maps ( from Photoshop at least ) are far far superior in Quality and Clarity!

 

I hope this infomation helps anyone else who was struggling to push the quality of their Textures and Smart materials to the maximum!

 

Alex. :D

 

PS : i save my Texture maps as .TGA

Edited by Alex Z
added extra info
  • Like 1

Share this post


Link to post
Share on other sites
58 minutes ago, Alex Z said:

Alright, I'm very happy to say I managed to solve this problem.

I Converted the Normal Map i was using into a Full Greyscale image via Photoshop ( Image > Mode > Greyscale ). This type of map has a very high quality read. Once plugged it into the Smart Material's Depth slot I was immediately impressed.

I'm guessing when Black and White maps / Height maps are plugged into the Depth slot, they are on-the-fly converted into Normals. Much like most stand alone Normal map generator programs, ( Crazy bump, Awesome bump, etc )

From now on i won't be using Normal maps in the Depth slot, as Greyscale maps ( from Photoshop at least ) are far far superior in Quality and Clarity!

 

I hope this infomation helps anyone else who was struggling to push the quality of their Textures and Smart materials to the maximum!

 

Alex. :D

 

PS : i save my Texture maps as .TGA

You are correct, I was going to mention that... I was able to get your direct normal map and the smart material to match in case your workflow demanded it but I prefer the other method as you stated.  I use greyscale in the normal map slot. If you use the built in procedural noise for the depth slot (smart material editor) it uses a greyscale map that is converted to a normal map.

Share this post


Link to post
Share on other sites

Hi Digman,

Thanks for looking into this problem i had.

You mention you solved my original issue regarding using ONLY normal maps, can i ask how you did this? For the life of me i couldn't figure out how to keep the quality once the map was applied to the Smart Material.

I'm a perfectionist by nature so i was looking for an exact 1:1 quality ratio. Small details and fine edges are important to me, allowing a high standard of work.

I thought the loss of quality was due to compression?

 

Cheers, Alex.

Share this post


Link to post
Share on other sites

Here it is if needed though as you discovered greyscale maps are a good way to go as the quality is higher.

Set the depth amount in the top tool panel to 100%

For you case only: Matching a direct import normal map when making a smart material. 

Smart Material Editor

Set type to Uv mapping

Set the Smart Material depth amount here to be a percentage of the top tool panel. In your case I think I set the smart material to 17% depth. The best way to think about this is just have the top tool panel set to 100% always when creating your smart material and then just set the smart material depth as you normally would. If the top tool panel is set at 50% depth and you set the smart material at 20% it is going to be 20% of half strength (50%) depth in the top tool panel.

---------------------------------------------------------------------------------------------------------

Side note: Importing a normal map directly into 3DC, it would not take into account the the amount the normal map is intensified through the depth settings in the top tool panel. The normal map would be imported at how it was created. Renderers have a setting to intensify a normal map after import. This you can do in the normal map layer's panel under the depth setting if needed. 

 Now when you use a normal map in the Smart Material and the setting is at 100% in the top tool depth setting and the smart material normal map depth is set at a 100%, the normal map is intensified to the extreme, like adjusting a renderer's normal map intensity after importing. So you must adjust the percentage amount in the Smart Material Editor to match the the same intensity as the direct one. 

--------------------------------------------------------------------------------------------------------

When applying the Smart Material, in the Preview options panel, click on reset before applying. This will insure that the image is at the same scale as the imported direct one. whether you have to adjust a little per case, that would need to be seen.

In my picture, the Smart material depth could be adjusted just a tiny bit more but they are close. I lined the images up to get a good comparsion.

Hope the above helps you some.

 

 

123.jpg

reset.JPG

Edited by digman
  • Like 1

Share this post


Link to post
Share on other sites

Thank you for a detailed reply Digman!

Sadly, these are the exact steps i made when i originally ran into the problem. Even in your example you can see artifacts and loss of clarity via the Normal map being plugged into the Smart Material, but all is good knowing Greyscale maps are the perfect solution. I found they are extremely versatile when altering via the Levels Curve within the Smart Material, so many high quality variations can be made with just 1 Greyscale map.

I could never achieve such results so easily with a Normal map!

I'll attach the texture i created in Photoshop incase you are interested, also for anyone else interested in the results.

File Format : 16-bit .tif Greyscale

Thanks again,

Alex.

DiamonPattern_16bit.rar

Share this post


Link to post
Share on other sites

Yes true some difference but close. Maybe because the depth in a sense is recalculated with intensity which is necessary to match the direct import. If a normal map has to be used this is the way but oh yeah a 16 bit tif has much higher fidelity for conversion to a normal map. I never use a normal map in the Smart Material depth slot...

Edited by digman

Share this post


Link to post
Share on other sites

Thanks Digman, your help and input has been much appreciated!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×