Jump to content
3DCoat Forums
dreatern

3D Coat is not saving some keyboard shortcuts/hotkeys

Recommended Posts

Hello i have this problem with 3D Coat, this is not a new thing, it has always been this way in several versions, in several computers, I'm living with this problem for +- 3 years.

So, i have my Hotkey/Shortcut setup on paint room like in Photoshop, E to Erase, B to brush, etc most of the things works fine and are always saved (Common keyboard keys like , A, B, C, D, E ,F, CTRL, SHIFT, ALT...). 
I also use the [  to decrease radius and  ] to increase radius.  
The problem is, 3D coat never saved shortcut ] (That i use to increase radius) and I have to set the key every time I open the software, every time I open a file, every time I reload a mesh, every time I have to do something else inside the software or when in some way i change the geometry I'm working.
 

I know about the "Options_Hotkeys.xml" file and I have tried to change it many times but 3D Coat will always overwrite the file, even if I mark it as "Read Only".

yQQ8Umm.png

I'm in Brazil, my keyboard layout is ABNT https://en.wikipedia.org/wiki/Portuguese_keyboard_layout and I believe 3D Coat don't have total support.


Take a look at the image below, the "Decrease Radius" is set to ( ] ) even when I manually set it to ( [ ) it will always appear as ( ] ) but it will act as ( [ ).
 When i set the "Increase Radius" to ( ] ) the key became invisible there (but works until i do something else, load a model, open a file, close the software). 

I have tested with different computers, different keyboards ( All ABNT layout, the layout used in Brazil ) and I always have the same problem.  I have 2 desktop computers and 1 laptop to test.

eQFQWjZ.png
 

Right now I'm using 3D Coat 4.7.24 on Windows 10 64bit but as i said before this was always like that,  different versions of 3D coat, different versions of windows and on different computers that I had.
And as I said, yes, I know about the hotkeys XML file, but that is not the Solution in my case, don't do anything unfortunately...  

This is something with 3D Coat and the Brazilian ABNT keyboard layout because I've tried all sorts of things and nothing solved the problem.
https://en.wikipedia.org/wiki/Portuguese_keyboard_layout

 

 

 

Edited by dreatern

Share this post


Link to post
Share on other sites

Hi !

Please send this support-related question to Andrew Shpagin at

support@3dcoat.com

Ty !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×