Jump to content
3DCoat Forums
TallBhoy

Trouble with Calculate Occlusion

Recommended Posts

Hey

I'm currently tying out the "Calculate Occlusion" tool on a few of my models but have run into a problem on one of them. The occlusion map produced has a lot of ugly sort of patches all over it. I ran the tool on a very similar model and never had any issues. I have all layers, paint objects and surface materials unlocked. I have attached images of the before and after of the model with errors and the similar model without. Any help on how to solve this issue would be much appreciated.


Thanks.

noAOgunner.PNG

AOError.PNG

alchnoAO.PNG

AlchAO.PNG

Share this post


Link to post
Share on other sites

Hi !

Are you using the latest version ?

The model is very tiny ?

Separate Paint Objects is = ON ?

Separate.jpg

Share this post


Link to post
Share on other sites
57 minutes ago, Carlosan said:

Hi !

Are you using the latest version ?

The model is very tiny ?

Separate Paint Objects is = ON ?

Separate.jpg

Tried all the solutions above but still happening :(. I updated to 4.7.24 as I was out of date. I don't have the option to tick "separate paint objects" and I tried scaling the character up by a lot. I have also tried re-importing the model without any textures applied and I still get the exact same effect happening.

Edited by TallBhoy

Share this post


Link to post
Share on other sites

can you share the model -PM- to take a look ?

Share this post


Link to post
Share on other sites

I also get the ugly patches over some models as well. I still have not figured out the reason yet...

This is on simple models as well and not just complicated ones.

Also sometimes I get very tiny little dark squares over the model in the curvature map. 

I know one person updated their video drivers and some of their problems went away. Not saying it will but could test. I am stuck for preset with my video drivers. If I update them my Oculus Rift stops working and to busy took into fixing the matter.

AO and Curvature I believe use the GPU for the operation.

Side Note: If I have baked from the Retopo room, I can sometimes hide the surface mode model in the sculpt room, run AO calculations and then it works but not always.

Atm no time for deep testing.

Share this post


Link to post
Share on other sites

Reported as bug, -please dont delete the Gdrive share, thx-

I found 2 issues with this project. Baking the AO give errors -looks as some UV overlapped issue-
The original Scene Scale is very high, after changing it the model with the default values is very small.
Because the model is tiny, in tweak room i cant select it to scale up, could be nice to have a command option to select all and scale all.

Scaling up the model (+100%) in external app and importing it in new fresh PPP project... still give AO bake errors.

Share this post


Link to post
Share on other sites
15 hours ago, digman said:

I also get the ugly patches over some models as well. I still have not figured out the reason yet...

This is on simple models as well and not just complicated ones.

Also sometimes I get very tiny little dark squares over the model in the curvature map. 

I know one person updated their video drivers and some of their problems went away. Not saying it will but could test. I am stuck for preset with my video drivers. If I update them my Oculus Rift stops working and to busy took into fixing the matter.

AO and Curvature I believe use the GPU for the operation.

Side Note: If I have baked from the Retopo room, I can sometimes hide the surface mode model in the sculpt room, run AO calculations and then it works but not always.

Atm no time for deep testing.

I'll try updating my drivers and get back to you'se with how it goes. Thanks for the help everyone.

Share this post


Link to post
Share on other sites
20 hours ago, Carlosan said:

Reported as bug, -please dont delete the Gdrive share, thx-

I found 2 issues with this project. Baking the AO give errors -looks as some UV overlapped issue-
The original Scene Scale is very high, after changing it the model with the default values is very small.
Because the model is tiny, in tweak room i cant select it to scale up, could be nice to have a command option to select all and scale all.

Scaling up the model (+100%) in external app and importing it in new fresh PPP project... still give AO bake errors.

 

22 hours ago, digman said:

I also get the ugly patches over some models as well. I still have not figured out the reason yet...

This is on simple models as well and not just complicated ones.

Also sometimes I get very tiny little dark squares over the model in the curvature map. 

I know one person updated their video drivers and some of their problems went away. Not saying it will but could test. I am stuck for preset with my video drivers. If I update them my Oculus Rift stops working and to busy took into fixing the matter.

AO and Curvature I believe use the GPU for the operation.

Side Note: If I have baked from the Retopo room, I can sometimes hide the surface mode model in the sculpt room, run AO calculations and then it works but not always.

Atm no time for deep testing.

I updated my drivers but no luck. I did however find a workaround. I exported the body, belt and harness from the character with the working occlusion as they share the same UV's. I then exported the beard, pickaxe and barrel of the error character. I imported them all into a new scene and ran calculate occlusion again. It worked and I finally got an occlusion map. I'm not sure what the problem was though and this isn't a solution everyone who encounters this problem can take as I'm just lucky to have similar characters. It's certainly strange as the characters share so many of the same objects/uv's. Thanks for all the help guys.

workaround.PNG

Edited by TallBhoy
  • Like 1

Share this post


Link to post
Share on other sites

Glad to know you found a workaround.

The support ticket is still open and i keep you informed if any news.

Best

C.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×