Jump to content
3DCoat Forums
TorQueMoD

Tool Pattern/Voxel Stamp is missing smoothing?

Recommended Posts

So I'm trying to import a mesh to use with the Voxel mode of 3D coat. I used to do this all the time for re-topology but for some reason lately any obj file I import loses it's smoothing groups. I have checked off smoothing groups in the export settings of the obj but when I bring it into 3D coat it's completely faceted. Any idea how to fix this would be greatly appreciated.

 

 

faceted.jpg

Share this post


Link to post
Share on other sites

Did you try using another shader ?

Share this post


Link to post
Share on other sites

Yes, it's not related to the shader as when I bring the mesh into another 3D package it's completely faceted. I was able to mitigate some of the faceting when I noticed the Subdivide button but I can only do this about twice before the program crashes and sometimes that's not enough to smooth everything out. It's strange though because the mesh is smooth when it leaves 3D Studio max and this wasn't an issue before. It seems like an issue with one of the latest updates for 3DC.

Share this post


Link to post
Share on other sites

First, always good to give the version of 3DC you are using and your complete workflow.  I do not know if you are importing for just retopology or sculpting more on the model or a combination of the two.

3DC should not be crashing after 2 subdivisions but I do not know your system specs. 

There are a few ways to get a smoothed model into 3DC.

1. Sculpt room using the import tool. Subdivide for voxel mode. This one is crashing on you for some reason, again should not be happening with just 2 subdivisions.

2. Sculpt room using the import tool. Flat subdivision for surface mode. Only subdivide once and Import without voxelization.

3.New Menu. Import for Vertex Painting.  Surface mode will be used but you will also see the sculpt room model in the paint room as per normal.

4. New Menu ---Perform Retopology--- Import huge reference mesh. Surface mode will be used.

5.New Menu--- Perform Retopology----Import reference mesh. Retopo room will be used. No model in the sculpt room here as this is just used for retopoing.

6. New Menu--- Import for Per Pixel Painting. Switch to the sculpt room ---- Geometry Menu--- Paint Mesh to Sculpt mesh. Surface mode will be used.

7. New menu--- Import for Paint with Deep displacement, Choose  a subdivision level. Switch to the sculpt room--- Geometry Menu--- Paint Mesh to Sculpt Mesh. Surface Mode will be used. 

You may delete the model in the paint room if not needed in the two above methods, 6 and 7.

7b. Export a high polygon model using File --- Export from the paint room. Choose from a list of 4 polygon subdivision levels. Next import that exported high polygon model into the sculpt room.

8 . Surface mode---- drag a model from the Model's tab, it imports being smoothed and not faceted. Choose without voxelization in the import panel. No need to choose Flat subdivision.

9. Last is subdivide the model in your modelling application and then import the model to the sculpt room. Of course keep a backup of your original lower polygon model.

I am not saying which method to use as that is a artist call depending upon his workflow associated with his specific model.

My version of 3DC is beta 4.7.32 Windows

 

Edited by digman
correctiions
  • Like 1

Share this post


Link to post
Share on other sites

Version 4.7.33

Sorry. I thought I was specific enough... I'm bring in the mesh under the modeling tab for Voxel sculpting when you press the Plus icon to import your own model.

models_tab.jpg

When I used to do this before, I didn't need to add subdivisions it would just bring in the model as it looks in Max. And the subdivisions are only smoothing out the mesh a small amount. It's still faceted but the polys just get smaller. The frog model was just one that I had on hand, I'm not using it specifically in the voxel sculpting but here's what it looks like in Max:

Frog_Max.jpg

As I said, a few months back when I was last using the voxel room, if I exported the smooth model from max, it would import into 3D coat smooth. I shouldn't have to subdivide it. And it's not crashing on 2 subdivisions, it's more than 2 that causes it to crash (when the mesh is in the 1 million plus poly count range).

My system is an i7 3.5ghz 6 core with hyper threading and 32 gigs of ram and a GTX 780 so I'm pretty sure it's not my system. Like I said, this is definitely abnormal behavior to what was happening previously. It's like 3DC is ignoring the smoothing groups of the obj file. I tried using an FBX as it supposed to be supported, but when I did, the model doesn't even show up after import.

Share this post


Link to post
Share on other sites

Thanks for the information on your workflow. I was not being critical to let you know.

 I very seldom add models to the model's tab as a general way of importing a modeling into 3DC. I am not saying it is a bad method, just one I do not use as a general method for importing external models. 

The above methods I gave minus the voxel subdivide that is crashing for will give you a smooth model. 

For your method, When dragging a model from the Model's tab, choose from the import panel without voxelization and subdivide once using Flat subdivision.

I do not myself remember 3DC every bringing in models without them being faceted unless they were very high in polygon count which by it's nature would appear smooth. That is really what subdivide does anyway from the import panel. That is my memory though it could be faulty about the faceted nature but I have been using 3DC for long time. I will say that using the models tab is not well used on my part so there could be something I missed since I have not used it as often as others.

 

Edited by digman

Share this post


Link to post
Share on other sites

Ok, I just did a test...  

If I am in surface mode and drag a model from the Model's tab, it imports being smoothed and not faceted if without voxelization is chosen in the import panel. No need to choose Flat subdivision.

That will  become number 8 and number 9 is now subdividing externally on my list of importing smoothed non-faceted models. 

I edited my first post to include the changes.

Mainly I just hope the information I gave you will help also for future workflows.

Edited by digman
corrections
  • Like 1

Share this post


Link to post
Share on other sites

Auto-Smoothing in major 3D apps merely make the model APPEAR smoother than it actually is. It's a VIEWPORT trick of sorts (similar to how normal maps work compared to real displacement) to make the model seem smooth, even when it's in a low polygon state. Voxels/Surface mode does not take smoothing into account. You have to smooth with real polygons. That typically will happen when you subdivide the mesh on Import, in Tool Options panel. To keep any sharp edges or areas of detail, you will want to prep the model a bit before importing, so that subdividing won't affect those areas much, if any.

This is what you do in a major 3D App anyway, before subdividing the model much. Yes there are some tricks that allow the user to harden edges and such, but it still requires some degree of prep work.

Share this post


Link to post
Share on other sites

@ AbnRanger, You know this stuff already, so talking here as I find this thread interesting. 

The user's problem got me thinking of the many ways of importing a smooth model with or without subdividing mainly for the purpose of importing into the sculpt room.  Either using real polygons or smoothing groups or whatever smoothing routine that 3DC uses.

Voxel mode--- You subdivide not for the purpose of increasing the voxel resolution but giving enough subdivided polygons for the conversion to voxels to create the same smooth appearance with voxels.

If I import a model into voxel mode scaling up the resolution to 1,000,000 voxels to capture the details and then subdivide the model 3 times, I will not increase my voxel count after pressing apply but still get 1 millions voxels appox. 

Surface mode is different, scaling here makes no difference in the final polygon count, only the number of subdivisions plus the model is triangulated. My 10,000 quad polygon model with 3 subdivision plus the triangulation ends up being 1,450,000 polygons appox. 

--------------------------------------------------------------------------------

I need one correction on my first post. 

You can import without voxelization using the import panel plus no use of flat subdivision to get a smooth model.  To use flat subdivision depends upon the model. I did not state that in my post.

Of course to sculpt on a smooth looking low polygon model imported into surface mode you will have to increase the polygons. That brings another set of problems and solutions but is not the topic of this thread.

Since 3DC will recognize hard edges created in another software, I will use a hard edges, edge holding loops or a combo of them both depending upon the model when importing into the sculpt room to hold the form. This is in reference to your words about holding edges or hard edges and preparing your model for import.

 

 

 

Edited by digman

Share this post


Link to post
Share on other sites

Thanks for the help guys. I have lots of experience with 3D modeling in general so I'm aware of what smoothing groups are doing etc. but it's useful info for anyone else who stumbles across this thread so thanks AbnRanger. My lack of experience is with 3DC specifically and as I said, I haven't had any issues with imported meshes being faceted before (regardless of resolution) which is why I posted. 

digman, I didn't think you were criticizing so no worries there ;)

I'll try my hand at importing using the methods you suggest the next time I load up 3DC but I'm still really confused why using the models tab is giving different results than it did previously. I haven't used 3DC in months (possibly more than a year I can't really remember) so I thought maybe something changed in an update. I even have some fairly low res models in the tab from months back that stamp down perfectly smooth in the voxel room so something changed. It very well could be the obj files though, I just don't know how to debug it so to speak.

Edited by TorQueMoD

Share this post


Link to post
Share on other sites
4 hours ago, TorQueMoD said:

Thanks for the help guys. I have lots of experience with 3D modeling in general so I'm aware of what smoothing groups are doing etc. but it's useful info for anyone else who stumbles across this thread so thanks AbnRanger. My lack of experience is with 3DC specifically and as I said, I haven't had any issues with imported meshes being faceted before (regardless of resolution) which is why I posted. 

digman, I didn't think you were criticizing so no worries there ;)

I'll try my hand at importing using the methods you suggest the next time I load up 3DC but I'm still really confused why using the models tab is giving different results than it did previously. I haven't used 3DC in months (possibly more than a year I can't really remember) so I thought maybe something changed in an update. I even have some fairly low res models in the tab from months back that stamp down perfectly smooth in the voxel room so something changed. It very well could be the obj files though, I just don't know how to debug it so to speak.

I wasn't implying a lack of understanding what smoothing groups are, just comparing it to how normal maps are a visual trick, making a low poly object LOOK like it has more polygons/detail than it actually does. From what Andrew explained to me, Voxels has no inherent smoothing at all...because it has no normal vectors. So low-poly imported objects will need to be subdivided quite a bit when importing.

Surface mode is a bit different. You won't have any smoothing groups, but it does smooth the appearance a fair amount. So, my guess is you imported it as a voxel mode object. If you imported it as a Surface mode object it would look fairly smooth. You can see a comparison here, with the same imported mesh, stored in one of my MODELS pallet folders. Voxel mode is the one that is faceted.

 

 

Voxel Mode.jpg

Surface Mode.jpg

Share this post


Link to post
Share on other sites

A picture is worth a thousand words... I typed it you showed it... :rofl:

Thanks for the info from Andrew that voxels have no normal vectors.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×