Jump to content
3DCoat Forums
Sign in to follow this  
Trismegistus

Normal Baking with Imported Meshes

Recommended Posts

I have been using 3D Coat occasionally for the past few years.  I have a full mesh (high polygon) and a 'cage mesh' (low polygon).  I would like to use the low polygon mesh in a project with the normal map of the high polygon mesh.  The high polygon mesh fits more or less neatly inside of the low polygon mesh.  I made these meshes in another application. They are both uv-mapped, but have different uv maps from each other.

I would like to bake the detail of the high polygon mesh as a normal map onto the uv map of the low polygon mesh. Is this possible with 3D Coat.  If so, how would I do this? Thanks.

Share this post


Link to post
Share on other sites

You could also merge the high poly model into the Voxel Room, and 3D Coat will bake all the color information onto the vertices of the model in the process. So, you basically have your texture map converted to Vertex paint. If it looks good enough in the voxel room, you can import the low poly into the Retopo room and use that as your Retopo mesh. Then simply go to the Retopo menu and merge to PPP or MV mode

 

Share this post


Link to post
Share on other sites

Your workflow details are sketchy and the version of 3DC you are using is not stated. Since you been using 3DC for a few years, having a more detail workflow keeps us from shooting in the dark.

What process did you use to import the high polygon mesh and low polygon mesh, What was your method of baking in the retopo room.

What was the resolution of the normal map created. 512, 1024, 2k, 4k, 8k?

Did you hide the voxel object in the paint room after baking. 

Some pictures of the areas of the normal map details you are not happy with.

I found that generally 3DC does a good job of capturing details, of course it depends upon your texture resolution. A lot of tiny details will need a higher texture resolution to capture them effectively.

 

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for the replies and sorry for my slow response.  I have baked normal maps three times in 3DC, so my experience is limited.  The first time was on a model that I had created in the voxel room and then retopo'ed in 3DCoat 4.7.06 (OGL) which is what I am using.  I thought the normal map was pretty faithful to the model I created.  I even textured the model in 3D Coat.  This encouraged me to do more normal map baking in the quest of low polygons.

Then I decided I wanted to have a low-poly model of a Romanesque Arch that I modeled in 3DS Max, but baked with the normal map detail of the high poly model.  I modeled the high and the low polygon meshes in Max. They are both uv-mapped very differently.

5976a02ddb871_RomsqArches.thumb.png.1ca24e4937480606ea7e59e39afc3f34.png

 

Then I imported them into 3DC. I did this in the retopo 'room' through File --> Import Retopo Mesh for the low polygon model and then Imported the high polygon mesh (I forgot which path I used).  The low polygon mesh encloses the high polygon mesh. The two models have different uv maps.

RomsqArch_.thumb.png.7a1eea283b97e94be5884e76e737880a.png

Then I went to the baking menu and baked a normal map. I saved out the normal map from the texture room as a .tga. This normal map below observes the uv map of the the lower poly mesh for which it is intended.

RomA_Low.thumb.png.9c4ec1e6a9933c3a40f2b845abd9e0f9.png

 

Then I  tried it it my chosen renderer, Daz Studio (DS), which is what I am making these assets for.   Unless the first and now second models that I've sculpted (voxel room) and retopo'ed in 3DC with very good baked normal map as I saw in DS, the Romanesque Arch's normal map looked pretty shoddy.  As I said, I've rendered the two other models with their appropriate normal maps in DS and the results were very good, so I'm pretty sure it's the normal map for this particular model, not DS.  I'm sure it's due to how I made it in 3DC, but I don't know what I did wrong.

As you can see in the render below, all the molding detail of the high polygon arch should be reflected in the normal map (applied to the low polygon model), but doesn't show up much at all.  There should be deeper details in the molding. I realize that normal maps don't change the actual geometry, but this isn't even close.  As I said, the other models that I made and rendered in DS with their 3DC-baked normal maps were very good and very faithful, so I don't think it's DS and I don't think it's 3DC either. What do I need to change?

DS_RomsqArch_IrayNormal.thumb.png.f92dd1970483afedf31ab2c259fbe667.png

 

If you have any more questions, please ask. Thanks.

Share this post


Link to post
Share on other sites

At this stage, I would suggest sharing the arch if possible for others to test.

I see you are using what appears to be a world space normal map and not a tangent space normal map. Is that correct?

There have been many improvements since 4.7.06 to let you know, just for your FYI and not saying it solves your problem.

Current Beta is Version 4.7.34. All new features and bug fixes go in the betas till Andrew decides he has a good stable beta version then it becomes the new version that is sold at the 3DC site.

I think the new stable is version 4.7.24 but I could be wrong. There have been some good improvements since then as well.

Edited by digman
  • Like 1

Share this post


Link to post
Share on other sites

Ok, first testing... I imported the high polygon model into surface mode in the sculpt room and imported the low poly model into the retopo room for the retopo mesh.

1. The models were not aligned up. Used Maya LT to first move the pivot point of the objects to their center. Next used snap to grid to align them.

2. I noticed in the high polygon model and low polygon model that you had unwelded vertices. This could cause baking problems if surface mode importing is used. Either case I would correct for a cleaner models for baking

3.Note. I did not snap the repoto mesh to the sculpt room mesh.   In the picture you can see after importing the low cage that in my opinion would need a few extra edges to help the normal map projection. Also you need to move some edges so they line up better with the where the small rounded sections meet the flat areas. The retopo mesh does not quite line up with the sculpt room mesh The top is lined up but as you move down it gets father off. Even using the transform tool in the retopo to move the retopo mesh a little, the alignment is not quite good enough for a good normal map so it could be closer aligned to the high polygon mesh..  The grooves section of the low polygon mesh also are off a little. Because of the above problem the normal map will have a hard time getting a good baked normal map. 

4. I generally do not snap my imported retopo meshes to my high polgyon mesh as the snapping will of course get closer to the surface but also might not quite snap correctly. I get my low polygon model as close to the surface as possible of the high polygon model. Of course it will be off in some areas as the low can not meet the curvature completely but the closer the better.

5. As time allows I will fix the models and bake for a normal map. Once done, might be a few days I will post back here... 

6. The last pic is not a final retopo mesh but just a quick version... Still need to really go back and fix things up before I get to this step. Like I said I will do some real work in the next few days.

All the above is only my artist version of what I would do, nothing is ever set in stone except overall principles.

 

 

 

 

edges.JPG

new.JPG

Edited by digman

Share this post


Link to post
Share on other sites

Possible I was wrong about some not welded vertices... need to check closer. 

I checked closer and I see you have polygon elements segments that are end capped on the high poly model...  

I understand now your model. 

Will continue to work in the low polygon without model adding edge loops

 

Edited by digman

Share this post


Link to post
Share on other sites

I voxelized the model this time to 16 million to capture the very sharp edges, subdivided a few times from the import panel to remove the facets on the rounded curves. 

Ran smooth all a couple of times which at this 16 million resolution only smooths a small amount to help the edges be cleaner.

Imported the low polygon retopo mesh. In the case snapped to the high voxel mesh then moved some edges for a better fit. No added edge loops. 

Not sure if in surface mode the disconnected segments were causing baking problems but the voxelized solid model, I did get a better normal map.

render.PNG

marble.PNG

Edited by digman
  • Like 1

Share this post


Link to post
Share on other sites

I made a new low poly with a few more polygons.  Now I get a somewhat better normal map.  But it seems like it is 'inverted.'  I'm not sure how I got this.  I actually made two versions of the high polygon model (voxelized), one 'clean' and one with wear and tear.  

Share this post


Link to post
Share on other sites

I finally got this to work. I'm not sure what did it.  I updated the latest build and I made the internal scan about 5 and the external scan 2.  It's not a perfect normal map, but it's much better than it was and I think I can play with the settings until it's optimized. Thanks for the help.

  • Like 1

Share this post


Link to post
Share on other sites

Glad you got it working on the most part. If you ever want to get together through Skype to go over your current problems send me a pm. I use Skype for voice and  screen sharing. Also I have Twitch but it's screen sharing is not as good as Skype. Busy this week but after that is good.

Yeah, I did type a lot, much to digest. That is why sometimes Skype just is much faster. As I have the time, I will help a 3DC user to figure out a problem that is currently stopping their workflow. I can not do it all the time as this is volunteer work. I am solution minded though and just hate to see a 3DC user get stumped on a problem. 

Share this post


Link to post
Share on other sites
Sign in to follow this  

×