Jump to content
3DCoat Forums
Sign in to follow this  
JustAnotherName

Wrong scaling with Photoscan Import

Recommended Posts

Hey guys,

I am using Agisoft Photoscan to take pictures and build a 3d model from people.

Previously I was using the Sense 3d scanner and usually used the Autopo import to get a sufficient

mesh for creating some cutting patterns from the UV map.

With the Agisoft .obj file after importing it is like a point object and after zooming

I realize it has the wrong scale (about a factor 170 too small). The Autopo also is not able

to build a decent sufficient mesh on this model.

Do I miss some tweaks for importing or is it the Agisoft Software I have to be careful with?

Share this post


Link to post
Share on other sites

Hi !

Please test latest version. Thx !

 

Share this post


Link to post
Share on other sites

Which 3DC version are you using ?

Latest is 4.7.35 and have several bugs fixed.

Share this post


Link to post
Share on other sites

Is the issue solved if Scene Scale is set to 1 ?

Latest versions have added warning popups about wrong Scene scale values.

SceneScale.jpg

  • Like 1

Share this post


Link to post
Share on other sites

This is how it looks from top to bottom.

-After Autopo.

-After zoom.

-After zooming some more the mesh disappears (which is bad too).

-The last picture shows the wrong scale (It's about 1.4mm but should be about 250mm).

 

Rastergrafik.png

Edited by JustAnotherName
Uploaded higher res pic.

Share this post


Link to post
Share on other sites

Check if Define Measurement Units value is ok

 

Define Measurement Units.jpg

Share this post


Link to post
Share on other sites

Another option will be to use Auto Scale mesh to preserve most details when importing.

 

Auto Scale.jpg

Share this post


Link to post
Share on other sites

I use Photoscan as well. 3DC is a great tool for working on photoscan models.

The model is small from photoscan I would assume. Scaling for increasing your voxel resolution to capture all the details in voxels is what you want do do. The original scale will be remembered as long as you say yes when ask about keeping scale when importing. 

Grab the center of the gizmo and scale up to a voxel resolution to capture the details of the photoscan model. In the import panel you will have an estimated voxel count shown as you scale up.

Do not import for surface mode. Cleaning up a model is much easier in voxel mode.

Edited by digman

Share this post


Link to post
Share on other sites

Thanks for the tips!

I got a reply now from Agisoft and it seems that the trial version I am using does not support scale features.

I am trying to get along like this now:

-Import model with Voxel sculpting method

-Using Edit Scene Scale and changing it until a measurement fits a length on the object

Can you please tell me how I can go from here and do something like AUTOPO after the rescaling?

If I save as .obj and import again it does't show any mesh now.

Share this post


Link to post
Share on other sites

I prefer to use the gizmo scaling method as my original mesh scale will be remember when I export the model but that is an artist call .

Once you have imported the photoscan model and finished your cleanup work.

Run the autopo routine. It will create your retopo mesh and place you in the retopo room.

Create your uv seams, unwrap and bake to the paint room for your normal map.

The above is what to do but not really a tutorial or best practices. Leaving town and rather busy atm.

Some Photoscan models to 3DC shown in my wip thread. Scroll down a few post and you will see them.

Photoscan is worth the money in my opinion. I have the Standard version. Also there are best practices to get higher quality models.

 

Edited by digman
  • Like 2

Share this post


Link to post
Share on other sites

I had to clean up the scan some time because the Autopo didnt work before,

but now I am quite satisfied, though 3dCoat had some crashes throughout the process.

It's a shame though that Photoscan does not calculate the correct scale.

Just one further question, I used AUTOPO w. PTEX, is there a big difference between this and the "simple" AUTOPO option?

001005.jpg

Share this post


Link to post
Share on other sites

3DC will crash on autopo if there are interior voids in the mesh or take a very very long time to calculate and then still create a retopo mesh that is not good. 3DC sees the voids but the routine is a surface curvature routine and I think it just can not figure out the true surface with those interior voids. This though is a guess on my part as I have not ask in e-mail to Andrew about it.

Right click on the vox tree layer and select " Fill voids". If that does not do it, then now select fill invisible hulls. The second process might create some artifacts on the model which need a little cleaning.

Run Autopo again.

I use the Autopo without any selection of going directly to the paint room. Once I am in the Retopo room. I can work on the retopo mesh to improve it or create my on UV seams. 

Now you are using Ptex which does not require a UV set but I still do the above so I can carefully check the retopo mesh or manually improve it.

I check the baking projection cage to see how well it covers the model both exterior and interior. Adjusting as needed.

If using a method for that requires a uv set, then I create it using one of the two auto uvs but for real work that is all done by hand, creating the uv seam layout. Then unwrap for baking.

Last I choose my method of baking and the bake to the paint room.

The above is my method but again it is an artist call.

Edited by digman
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×