Jump to content
3DCoat Forums
Sign in to follow this  
Royston

Gradient Fill

Recommended Posts

Hi there, i been doing some terrain tests and it seems the gradient fill tool is still not working. (V 4.7.36)

It shows it how it should be in the smart window but when you apply it there's no gradient as such. (just the two colors without the blend)

It works if i just create a new scene cube from scratch and fill it.

Just when i import a mesh either ply or obj.

 

Oh also the icon for the material get corrupt when i edit the values (oldschool paint)

Should i use oldschool paint if I want to just paint the vertex colors?

 

I also have a feature request, theres a similar one on trello but it would be nice if you moused over the layer blend text you could press the up and down keys to cycle through the blend modes.

(like photoshop)

 

I would of posted this in the new release/beta thread but i am unable too.

 

Cheers

Royston

 

3DCgradnotworking.jpg

Share this post


Link to post
Share on other sites

Your model has a UV map?

Or are you painting an imported model in Sulpture Room > Surface mode ?

Share this post


Link to post
Share on other sites

I used the import object to vertex paint option.

I did the UV,s in blender. Used the displacement modifier on a 1024*1024 grid.

If im vertex painting though this should not matter?

I think its surface mode yeah.

Im importing it as a ply into toolbag with just vertex color no texture.

Edited by Royston
More info

Share this post


Link to post
Share on other sites

Use Vertex Paint when you want to paint mesh without UV mapping it.

Try Paint UV mapped mesh option.

Vp.jpg

PaintUVmappedMesh.jpg

Share this post


Link to post
Share on other sites

I think that Royston imported for vertex painting.

Vertex painting:

In the paint room, here is my result shown in Flat shade... The Gradient appears to be working in 4.7.36. 

I do not go by the preview window as is seems not so accurate.  I do just color gradient filling ( no depth / no glossness) by adjusting the distance of the balls till I see I get what I want. Depth is not supported in the paint room while painting in vertex mode. All details have to be in the surface mode model in the sculpt room.

Check in Flat shade, then at that point I do real work once I am  happy and I switch back to Smooth Shade under the View Menu.

Side Note: no smart material used.

 

working.PNG

Edited by digman
Added intormation
  • Like 1

Share this post


Link to post
Share on other sites

I think its something to do with scale why its not working.

If I create a new mesh or load a smaller one it works as intended. When I load these big terrains I been saving out its not working.

It looks right in the smart material view but when you press enter to fill layer its not doing it the same. I tried filling the object aswell but that does nothing.

I've attached a test file so you can check it.

Is there any chance in the future that the smart view will go? Just have the program WYSIWYG?

Test2.ply

Edited by Royston

Share this post


Link to post
Share on other sites

I do not know if this is what you are asking for but here it is. I do not use gradient fill much so it took a little testing.

First do not use the Smart Material Preview window, it is inaccurate. 

Orthographic Mode.

Depending upon the scale of the model, you have to adjust the spheres. 

Zero out all the axis. Now only use the Y axis by manually typing in your setting, the two spheres in Y space. Both negative and positive. 

Depending upon the scale of your object the settings can get quite large look at my picture.

Y positive is 15,000

Y negative is -100

Your numbers could vary depending upon your need. 

I put a cheap noise on the terrain for better viewing. 

Picture shows the result in perspective mode

gradient.JPG

1234.JPG

Edited by digman
  • Like 1

Share this post


Link to post
Share on other sites

I tried updating my graphics drivers, re-installing 3dcoat and deleting the leftover folders in my documents.

The smart material view shows it how it should be. When i press fill layer its not filling the same.

I do the same as you, its just not giving me the same output.

Here's a video you will see.

 

Grad_HB.mp4

Share this post


Link to post
Share on other sites

Beta 4.7.36

Here is your model imported the same way as shown in your first video. Smart Material Preview is not used. ATM it is not accurate. Andrew will have to look at it. Remember I said not to use the Smart Material Preview.

Scale of the object does matter for your gradient settings.

Picture shows my gradient settings that work. Yes on each object you will have to play with the gradient settings a little to get the gradient as you need it. Filling temporary colors is fast  though to test your gradient settings. Of course set the gradient settings point 1 and point 2 to your desired settings but remember it is effected by the scale of your object.

 

works.JPG

Edited by digman

Share this post


Link to post
Share on other sites

I did watch the grad_hb.mp4. and  the other video has well Then used your the steps for importing the model through vertex painting as shown in the first video... 

My settings are shown in the picture I put in my last post.  

The gradient was filled correclty between the two colors chosen. Look at my settings and do not use the smart material preview... 

There is no more I can give you on this matter. If I have time I will make a video over the weekend.

Edited by digman

Share this post


Link to post
Share on other sites

Are you scaling the model at all?

I noticed the settings for the gradient points seemed very high compared to mine.

When I import the model in I only need a value of 200 (point 2 y) for the gradient to get to the top of the model.

Yours says 40,000 (point 2 y)

 

3DCGradprob.jpg

Share this post


Link to post
Share on other sites

No scaling at all. From the beginning you have stated that the preview window is not acurrate. When you fill the model with the gradient it is different from the preview window.

I have found this true as well. What you see in the preview window is not what is applied to the model. I do not use the preview window at all... I adjust my sphere numbers to get the gradient Range I desire. 

Since you have stated yourself that the preview window does not work correctly for gradient and I agree,  I have given you a workaround. The preview window is not required for the fill tool to function. 

  • Like 1

Share this post


Link to post
Share on other sites

I never said the preview window is not accurate, I said it is how it should be.

I'm getting that horrible fill of two colors like the image above. (with no gradient)

 

Why is it that the scale is different when you load the same model in?

Share this post


Link to post
Share on other sites

The two color problem is what I mean by inaccurate. The preview looks one way and the fill gives you only two colors... I was getting the same problem till I started setting my numbers much higher on the positive Y...

Setting my sphere numbers as I did gives me the right amount of gradient that I was shooting for. Of course I can play around with the numbers to create the gradient fill I want or need.

I set my numbers, fill only with color, check the gradient, then starting adjusting the numbers to get the gradient that is needed.  Depending upon the model's scale it will take a few test to get the right range of numbers to work with. 

That is the workaround to avoid the two color problem. 

Edited by digman
corrections.
  • Like 1

Share this post


Link to post
Share on other sites

Yeah your right you have to overcrank the values to get it to work.

So its a bug then? Because its not working as intended.

Im sure I never had this problem before doing large scale terrains.

 

Would be good if there was a vertex color smart material, so you could control the overall values aswell like hue/sat/val or summin.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×