Jump to content
3DCoat Forums
smallfavor

Dismayed

Recommended Posts

Whenever i try to import and work on a simple construction of walls i end up with incomprehensible problems.  I need some fundamental understanding of the 3d system and I'm wondering if any could point me in the right direction.  At this point I'm getting the same feeling i had when i tried to make use of Zbrush - (not good)

In these 3 SSs you can see the mesh that's opened, it's wirerframe and what happens when I try to increase the resolution - the corners disappear!   The same thing happens in the voxel space but not as bad - the edges all become very rounded and uneven.  This model was exported from Rhino and I'm trying to add stone work to all the sides.

 

 

2017-08-15_13-11-15.png

2017-08-15_13-13-30.png

2017-08-15_13-12-13.png

Share this post


Link to post
Share on other sites

Is the Geometry Open ?

Geometry > Weld vertices help ?

Share this post


Link to post
Share on other sites

Thanks for the response.  The geometry is closed - that is the objects created in Rhino are water tight.  I'll try the weld vertices option if I can find it.  Actually, I don't see that option when I try to open or import.  I get this the last time:

 

2017-08-15_15-18-12.png

Edited by smallfavor

Share this post


Link to post
Share on other sites

Can you share the model please ?

Share this post


Link to post
Share on other sites

Howdy... 

Ok, first is that you had a lot of un-welded vertices, I would say duplicated vertices. There were 2098 vertices and after welding 944 vertices. Same number of separated objects. I used Maya LT to weld the vertices. It is not uncommon for software like Rhino to export obj with duplicated vertices. Maybe a setting in the export panel to weld upon export.

Exported as FBX from Maya LT.

Imported into Voxel mode at 24 million voxels, The reason is to create the sharp edges. Still there are a few errorrs, might have a lingering vertex or two but one smooth all got rid of the errors.

Also for voxel mode selected "Import as Child" to get the 9 separate objects into their layers. Not necessary for surface mode.

Method 2:

If you lose your hard edges when welding  your model, you can make edges hard again of course. If the model comes in looking funky in surface mode because of the shader, it is no problem as the below will fix it.

Import into surface mode. Remember though you have to have the vertices all welded as above. Try to fix all of them if possible or clean up in 3DC.

Select one layer at time. Press enter on the keyborard and add them amount of voxels you think you need to get the sharp edges. Experiment a few times to understand generally how many voxels you need per layer. The higher the number the sharper the edges will be.

After you apply for the voxels, the layer will be voxelized but return to surface mode when the operation completes. 

Also you could try Resample as well in surface mode. same principle applies, the higher the amount the sharper the edges.

I did not take the time to clean up every single vertex error in the mesh. You will see a few errors on your mesh unless you fixed them all. That is why I chose voxel mode as it was easy to fix them.

I take it that you desire to add sculpted details to the model in the sculpt room then bake those details to the paint room vs adding normal map detail by importing directly the model into the paint room.

First picture is from Maya LT.

In the second picture, the zaggies on the edges, is just no anti-aliasing in the sculpt room.

 

 

  

verts.PNG

good.PNG

Edited by digman
Corrections
  • Like 1

Share this post


Link to post
Share on other sites

Digman,  I really appreciate the extensive help you offered.  That's the the kind of specific eductaion that's so valuable.  I'm very ignorant at this point of many concepts needed to proceed effectivly.  For instance, I don't really know what welding vertices signifies, or import as child  for  that matter.   I went back to the Rhino export dialogue and found the weld vertices option - that helps - but I don't really understand the left side of the options box presented.

AbnRanger - thanks for the link - I was actually watching that collection of vids when I finally gave up and went to the forum!

2017-08-16_09-14-48.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×