Jump to content
3DCoat Forums
smallfavor

Multiple objects merged on import

Recommended Posts

I have a model comprised of a number of seperate meshes - all watertight and existing on seperate layers.  The meshes are exported to the .obj format out of Rhino 3d.

When I import that object file everything comes in on one layer.  These are the settings used to export the model and what's set for importing it to 3dc.  What am I missing??

 

help.:huh: 

2017-08-21_15-28-56.png

2017-08-21_09-39-33.png

2017-08-23_14-16-17.png

Share this post


Link to post
Share on other sites

Try Import to Separate Instances = ON

Hope this help

 

Separate.jpg

Share this post


Link to post
Share on other sites

For best results I would suggest to go to the advanced interface in the Rhino mesher and enter 0 in all fields (also uncheck simple planes): Only enter a number of at least 256 in one field: Initial Quads. 

That setting gives you a reasonably dense mesh quickly. Also it makes sense to convert extrusions to polysurfaces before meshing as Rhino's mesher wants to keep extrusions Low Poly by all means - this might answer your "break up large polygons" comment.

- Export Rhino Layer/group names = Dont export layer group names

Share this post


Link to post
Share on other sites

Try this setting in the import tool panel shown in picture. 

If that does not work then something in your Rhino 3D export panel needs changing. I do not know Rhino 3D.

Generally 3DC is good on creating the sub-object layers for surface mode even without selecting "import as child" 

Voxel mode generally needs import as child selected.

I put both voxel and surface mode in the above as you did not state which method you wanted to use. 

If all fails, you could merge all your layers in Rhino, then export Rhino names as obj objects.  

Last method, after merging all your layers would be to group your obj objects and the export groups as obj groups.

Remember I do not know Rhino 3D so making a best quess on the export settings.

Important before merging layers in Rhino be sure to make a backup copy first to save your original file.

 

import.JPG

Edited by digman

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×