Jump to content
3DCoat Forums
Sign in to follow this  
Hrungdak

Normal map is scattered

Recommended Posts

Hi Folks,

I have already completed some simple objects and imported them to unity. But some of my models don't do what I want. One example: I want to sculpt a simple block for a stair or a wall. The sculpt looks like this:

Block001_Sculpt.thumb.png.09ee2bcbbf4d0a2305cde13363c4c996.png

Very simple, very basic, very boring, I know.

Next, I do the low poly mesh, define Seams and unwrap:

Block001_UV.thumb.png.4bcaf658e1c3f0fc628fb740b7a8f9c7.png

The UV needs some workover, I know. The problem begins with the BAKE:

Block001_Bake.thumb.png.73085a1c9e94cbfa851113f7a4cbe22b.png

I choose Unity and let the standard settings as is. The result is this:

Block001_Normal.thumb.png.f90e6251d0d585fed48270fb6df20138.png

The normal map looks very scattered, and the model is not usable with this map.

What am I doing wrong here?

 

Share this post


Link to post
Share on other sites
Hi Folks,
I have already completed some simple objects and imported them to unity. But some of my models don't do what I want. One example: I want to sculpt a simple block for a stair or a wall. The sculpt looks like this:
Block001_Sculpt.thumb.png.09ee2bcbbf4d0a2305cde13363c4c996.png
Very simple, very basic, very boring, I know.
Next, I do the low poly mesh, define Seams and unwrap:
Block001_UV.thumb.png.4bcaf658e1c3f0fc628fb740b7a8f9c7.png
The UV needs some workover, I know. The problem begins with the BAKE:
Block001_Bake.thumb.png.73085a1c9e94cbfa851113f7a4cbe22b.png
I choose Unity and let the standard settings as is. The result is this:
Block001_Normal.thumb.png.f90e6251d0d585fed48270fb6df20138.png
The normal map looks very scattered, and the model is not usable with this map.
What am I doing wrong here?
 
This is not bake settings, its export window in paint room. Please go back to retopo room and use the command in bake menu.
  • Like 1

Share this post


Link to post
Share on other sites

The workflow in the Paint room is not the problem. The way TO the paintroom is.

I think, i found the solution. In the sculpt room I took the Clay-Shader for the model. If I reset this to Default, it works.

 

Share this post


Link to post
Share on other sites

I ran into a similar problem recently and the problem seems to be that the shaders bumpiness/depth setting isn't scaling with layer resolution during baking.  As the voxels increase in resolution the shaders texture scale, etc decreases accordingly but when you bake that shader information to a low poly model the scaling isn't being applied to the bumpiness setting of the shader.

To test this I created a quick test object, duplicated it and then increased the layer resolution on the duplicate to x4,

3DCShaderDepthIssue1.thumb.JPG.5a9a28bc4aa0b6cb60451526b9ff08d4.JPG

then I applied the clay shader to both and baked them,

3DCShaderDepthIssue2.thumb.JPG.61395e5c109733c04f05f6d79ed63cf7.JPG

As you can see the version baked from the x4 voxel object has the same issue you described, while the x1 version appears as expected.

Just to test the theory about shader bumpiness not scaling with voxel density I went back and changed the shader settings for the x4 voxel object and reduced the bumpiness from 10.0 to 2.5 then rebaked.

3DCShaderDepthIssue3.thumb.JPG.0291ba7d780de1839669f2270a315ebc.JPG

 

So as a quick workaround try editing the shader settings on each of your voxel layers, divide the current bumpiness value by the voxel density of the layer and that should fix the noisy normal map issue.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×