Jump to content
3D Coat Forums
Sign in to follow this  
ss3D

Bake Creates Bizarre Seam

Recommended Posts

Struggled to find any information online with folks who have had a similar baking issue.  

I get a seam where the normal map appears to have zero information.  Look closely at the UV and you can see a green brush stroke.  Except I didn't brush that on and this was the result of the bake. 

  1. I've attempted three different UV unwraps,  didn't change anything.
  2. I messed around with the cages, didn't change anything.
  3. I screwed with it's orientation.  Nothing.  
  4. Checked the model for errors - nothing.

I get the same seam regardless of what I've tried on multiple attempts at baking. 

Any help would be greatly appreciated.  

 

bakeissues1.png

Share this post


Link to post
Share on other sites

Can you split the model ?

Looking at the image, it seems that some faces overlap.

Share this post


Link to post
Share on other sites

Used Maya's cleanup.  There are no lamina faces. There is no overlap that I am aware of.  I specifically targeted this particular trouble spot from the image (there are more) and pushed the vertex around, didn't reveal anything.  Something, as near as I can tell,  is going horribly wrong during the bake.  I have zero clues as to why.  It's not the UV unwrap either.  I've tried three different unwraps and the outcome is the same.  I get the seam in the exact same locations.  

Share this post


Link to post
Share on other sites

can you share the model to take a look ?

Share this post


Link to post
Share on other sites

Hi !

I found that the model to work is very small, with that size I could not perform any bake.

Look at the baking settings. working with decimals is not recommended.

 

Size.jpg

10.jpg

BakeSttings.jpg

Share this post


Link to post
Share on other sites

HP_Hair have 4 floating vertices.

HP_Bangs have a floating Edge with 111 verts.

 

Bangs-Edge.jpg

Share this post


Link to post
Share on other sites

After scaling all to 50% in external app

 

BS.jpg

50%.jpg

The project ready to perform bake test

HB.zip

Share this post


Link to post
Share on other sites

Thank you so much for your time and effort! 

Unfortunately, this does not appear to resolve the issue.  I still get the hair lines after the bake.  I quadrupled the size of the model just to be sure.  I located and fixed the additional vertex.  

Did you actually run a bake to test the results?  Mine came out the exact same even after making the fixes.  

Edited by ss3D

Share this post


Link to post
Share on other sites

Yes, please look at the end of the post above.

My test project link was added.

3DC v4.7.37

Share this post


Link to post
Share on other sites
2 minutes ago, Carlosan said:

Yes, please look at the end of the post above.

My test project link was added.

3DC v4.7.37

To clarify: I tried baking the file you attached, as well as my own version after cleaning up the HP models. Both displayed the same normal map artifacts from my original post. 

The artifacts always appear on the front right and left side of the hair model, and the tip of the bangs model. The angle of your screenshot does not display these areas.

Share this post


Link to post
Share on other sites

I can make another bake later to display that area.

Have you tried using another shader for H_models ?

Share this post


Link to post
Share on other sites

Sorry cant replicate.

Try using this settings. Hope it helps.

 

SCapture.jpg

Settings.jpg

Share this post


Link to post
Share on other sites

Ok, so I fixed the problem, but the solution feels...  wrong.  Baking normals with dithering turned on didn't appear to affect the result for me.  Here is what worked.  On the 'Import Object for Per Pixel Painting panel, I had everything checked off but 'Don't Snap Sub' and turned on the 'Auto Smoothing Groups'.  I set the Max Angle to 70.  This created an anti aliasing issue along the more acute/obtuse angles of the model.  To fix that, I went into preferences and changed Realtime padding mode to 'Naive padding' and boom, it's given me the best result thus far. 

Thanks again for your time.  

 

 

Edited by ss3D
  • Like 1

Share this post


Link to post
Share on other sites

Smoothing groups are supported via OBJ format. But you need to export normals also from your 3D-model app. 3D-Coat uses normals in OBJ file to recover smoothing groups.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×