Jump to content
3D Coat Forums
Sign in to follow this  
TC Oz

Colour information missing when using smart materials

Recommended Posts

Hello everybody,

I have created a model in 3D Coat consisting of 3 objects with three different UV maps in it. Whenever I try to apply a smart material, only roughness, metalness and depth information is projected on the model. The colour information is missing no matter if I use the preview window or apply the texture. The colour information in the menue is activated. I am using 3D Coat version 4.7.36. Do you have an idea where the problem is?

Regards,

Ozan

Share this post


Link to post
Share on other sites

Hi

Color, Specular and Normal map channels are check ?

Main colors selector is block ? -press over with RMB to blockin/out-

Is there any layer blending at top ?

image.jpg

image1.jpg

Share this post


Link to post
Share on other sites

The channels are checked. The color selector is not blocked. I have got a whole bunch of layers in the layers panel. Each objects has it's own diffuse, roughness and metalness layer. If I click those, the colour information is there but I want to have the combined information on layer 1.

3D Coat001.jpg

Share this post


Link to post
Share on other sites

By the way, I am not sure if all those layers are needed. They have been created by 3D Coat autmatically but as you can see, some of them seem to be double.

Share this post


Link to post
Share on other sites

Use the command Delete All Unused Layers to delete it.

Try adding a new layer on top and hand paint something, is working ?

DeleteAllUnusedLayers.jpg

Share this post


Link to post
Share on other sites

It seems to work but now I have another problem. In the preview window, everything looks nice but when I fill the layer, it looks rather crappy. I have used the brass material in the 3D Coat default materials.

preview window.jpg

applied material.jpg

Share this post


Link to post
Share on other sites

Another interesting thing: The areas which are hidden from light are black. I have a black uv map and I have a black color, when I paint. I think it has something to do with the ambient occlusion. How can I fix that?

black areas.jpg

black uv.jpg

Edited by TC Oz

Share this post


Link to post
Share on other sites

Latest version have great improvement on textures quality, give it a try.

Bake Ambient Occlusion again using this command and this parameter, i always avoid to use AO option when bake from retopo Room.

Calculate Occlusion in Paint room make better maps.

Hope this help.

CalculateOcclusion.jpg

OcclusionParameters.jpg

Share this post


Link to post
Share on other sites

O.k., thank you. I can paint the whole object now but even though I have installed the latest version, the fill bucket still gives another result than if I directly paint by hand. Is that a bug? And I have another question. Sometimes I have the feeling that in some materials the bump ist to strong. Even if I go down to 2% depth information, the bump ist very visible. Is there a way how I can "finetune" the bump information?

Edited by TC Oz

Share this post


Link to post
Share on other sites

Create a new Project pressing Shift + M > Switch to Paint UV Mapped... option selecting any default models..

Use fill tool.

Can fill the whole object ?

PaintUV.jpg

Share this post


Link to post
Share on other sites

It works with the default models. The preview windows shows almost the same result like the filled voxelobject. I mean the fill bucket works but there is a huge difference between handpainting  and filling when I use uv mapped objects.

Share this post


Link to post
Share on other sites

It is possible that your voxel/surface mode object is hiding the baked normal map model.

If this is the case under the View window deselect "show voxels in paint room"

I have been able to achieve much higher quality by using a combination of high resolution textures and a nice high resolution mesh/UV.

Share this post


Link to post
Share on other sites

Hello Carlosan and thanks for your support again. I am not quite sure if "show voxels in paint room" is the same as "Voxelebenen anzeigen" in the german version. Translated into english it means "show voxel layers". I couldn't find somethin meaning the same as "show voxels in paint room". I have attached a screen shot. I have deselected it but I still have the same problem using the fill tool (see pictures). The preview windows shows somethin totally different than the result of the fill bucket.

Voxelebenen anzeigen.jpg

previev.jpg

fill tool.jpg

Share this post


Link to post
Share on other sites

Can you share the model ? 

Which workflow are you using ? Metalness and Specular are two different ways of working.

Do you apply UV-set and bake before switch back to Paint Room ?

 

 

 

Workflow.jpg

ApplyUVset.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×