Jump to content
3D Coat Forums
wheelmanforhire

Paint Layer above metal - alpha shows black not metal

Recommended Posts

I made a cylinder in the voxel room. 

I switched into Paint room.

Created a new paint layer - gave the object the Smart Material: Bronze

Add a new layer above Bronze called paint

Applied the white paint Smart Matrial - the preview shows the bronze peaking through the worn edges of the paint, but after I applied it with the paint bucket the worn edges are black and the bronze is not showing through like the preview... see attached.

What am I doing wrong - it works if I start over and go into Paint UV Mapped Mesh and use a supplied test object (like the robot).  It works if I pull in a poiygon model from Lightwave - I just can't seem to get it to work on my voxel objects.

 

3DCoatPaintOverBronzeIssue.jpg

Share this post


Link to post
Share on other sites

Hi

View > Show voxels in paint room is off ?

 

Show.jpg

Share this post


Link to post
Share on other sites

3DC have 3 sculpt modes: Voxel, Surface and Liveclay.

When you had done with rough voxel sketch and want to definitely switch to surface mode press over letter V (voxel mode). The layer prefix change to S (surface mode)

To switch back press S again, layer becomes V. -when switch back to V, you loose definition, be careful-

Voxels models cant be painted, if you switch to Paint Room any voxel model switch automatically to surface mode and allow to be painted using vertex paint.

Please try painting using any primitive, not your model.

 

This video demonstrates some of the advantages of using Voxel (Vertex) Paint, in 3D Coat, as opposed to the standard UV based texture painting tools.

 

Share this post


Link to post
Share on other sites

Thanks Carlosan,

Stumbled across that video earlier today - interesting & informative, but could not find where I went wrong.

I also though maybe it was something to do with Voxel vs Surface mode and re-did my experiment... same problem... here are my exact steps:

 

In Voxel room add cylinder
Click the "V" to make it "S" (Surface Mode)
Switch to Paint room
Add a layer (working on Layer 1 now - name it "metal")
Apply Gold_Rough Smart Material using paint can > Layer
... model is now gold looking (good)
Add a layer (working on Layer 3 now - name it "paint")
select paint_2 (a white looking paint)
...Preview shows gold showing through chipped white paint)
Apply paint_2 using paint can > Layer
...the result shows "blackness" showing through chipped white paint, not gold (bad)

Have tried this in both GL an DX versions - same result.  Have tried with paintbrush instead of paint can - same result.  Rebooted - same result.

However, If I do this:
File New
Paint UV Mapped mesh
Select the "desk camera" model
Add new layer call it "metal"
Apply Gold_rough Smart Material using paint can > layer
... desk cam looks gold (good)
Add new layer call it "paint"
Select Paint_2 (a white looking paint)
...Preview show gold showing through the chipped white paint
Apply paint_2 using paint can > layer
... the result is as expected (good - gold showing through chipped white paint - exactly what I wanted)

What am I doing wrong ?  Something about the voxel model that I'm forgetting to change?
 

Share this post


Link to post
Share on other sites

Your workflow is Gloss/Color ?

Your workflow is GlossColor.jpg

Share this post


Link to post
Share on other sites

Can you share the model please. I like to take a look about this issue.

Thx

Share this post


Link to post
Share on other sites

I open your project. 

I switched into Paint room.

Created a new paint layer - gave the object the Smart Material: Bronze

Add a new layer above Bronze called Paint

Applied the white paint Smart Material

The preview shows the bronze peaking through the worn edges of the paint, because the option more in convex show how the final look can be.

After applied it with the paint bucket the worn edges are black and the bronze is not showing through like the preview because you need to change the Paint blending mode or use the layer Paint as mask condition for Bronze layer.

Hope this help.

Sidenote: Surface material is used on Uvmapped meshes. May be an early  test? .Can be deleted.

MoreOnConvex.jpg

SurfaceMaterial.jpg

Share this post


Link to post
Share on other sites

But if I follow these steps... I do not need to mess with paint blending modes or set masking... it just "automagically" happens...

1) File NEW
2) Paint UV Mapped Mesh
3) Select the "Desk cam" object
4) Crate a layer (named "metal")
5) Apply Gold_Rough Smart Material (paint bucket > layer)
6) Create a layer above "Metal" named "Paint")
7) Apply Paint_2 Smart Material (paint bucket > layer)

Gold shows throw chipped paint with no changes to paint blending modes, or masking needed.

GoldDeskCamWithWhitePaint_GoldDOESShow.3b.jpg

  • Like 1

Share this post


Link to post
Share on other sites

Yes, the procedure between UVpaint vs. Vertex Paint modes is very different.

Share this post


Link to post
Share on other sites

Okay, here is a dumb question... what do you have to do to make a voxel model have metal on one layer and then paint on the other and have the metal show through?  Or is this simply not at all possible in 3D Coat?

I tried doing a retopo of the cylinder with the goal of creating a UV... I believe I made a UV but still no luck.

Share this post


Link to post
Share on other sites

Please check this video to understand the process

 

Share this post


Link to post
Share on other sites

I think I'm actually experiencing something similar. It seems every material that has some sort of alpha to it isn't properly making use of that alpha and instead is just using whatever color I have selected. I feel like this is going to be an obvious thing that I'm missing but yeah.

Here is an image to better show what I mean. On one hand, the smart material preview is showing what I am expecting will happen, while on the right shows what is actually happening. It happens regardless of the color I chose. This happens with all dusts, paints or leak default smart materials.

Selection_087.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×