Jump to content
3D Coat Forums
Narushima

3D-Coat renderer won't render rougness properly

Recommended Posts

Hi all. I'm wondering if anyone else is experiencing this problem. I've been having it since 4.7. Basically I have a problem with 3d coat refusing to render metal properly, but only in the render room. In the paint room everything looks fine, but when I go into the render room 3d coat decide to give a super dark contrast to even the smallest roughness values.

Example, paint room vs render room.

asd.thumb.png.e8cc06bdde2e5b11a5ce4bbadd96b710.png1.thumb.png.bdae835edba95ce548efe5f97462f689.png

I'm running 3d coat in opengl with a Nvidia 1060.

  • Like 1

Share this post


Link to post
Share on other sites

Hi,

Have you upgraded to lastest version ?

Render room will render what is visible in paint and sculpt room. Do you have visible geometry in sculpt room?

 

Share this post


Link to post
Share on other sites

Yes, it's the latest version (4.8.03), but I've had this problem for a white (since I bought the 1060 and installed the 382 nvidia drivers). I have no visible sculpt layers. In fact, I've deleted all the sculpt object and still didn't see any change.

So I've done some testing and it only happens when I have shadows enabled. But without shadows the render looks flat. Also, if I set roughness to bellow 70 the problem kind of goes away but then the metal doesn't look metal-ish enough.

I've also rendered the model in Unity game engine and it looks pretty much how it does in the paint room.

Btw this happens on all my models that use metal smart materials.

Edited by Narushima
  • Like 1

Share this post


Link to post
Share on other sites

I have reported this issue to developers. please keep in touch with support@3dcoat.com

Thx

Share this post


Link to post
Share on other sites

At the first glance problem is that shadow can't capture small details (rings) because of map size limits. Try not using directional lights, only ambient one. Try DOF to randomize light a bit.

Share this post


Link to post
Share on other sites

I've tried what you've said, as well as enlarged and shrunk the model and disabled all height map data. I've also made all roughness white and instead transferred all detail to metalness maps, but it didn't change much.

  • Like 1

Share this post


Link to post
Share on other sites

Maybe something unusual in model structure? For example several very close parallel layers of polygons?

You may send me the scene to support to check, I may diagnose immediately.

Share this post


Link to post
Share on other sites

I can't send the scene because it's too big (close to 2GB).

But I did a test with a simple cube and the steel material that comes with 3d-coat.

Here is the result.3dcoat_render.thumb.png.25396296fbaa8fe87b71f9fd8292926d.png

First image is from the paint room, second from the render room (with default settings).

I've also attached the scene file. Thanks for your help.

rendertest.3b

  • Like 1

Share this post


Link to post
Share on other sites
On 10/18/2017 at 11:14 AM, carrots said:

Narushima
thank you for message.

Try to replace these shaders in the folder 3D Coat is installed
https://drive.google.com/open?id=0B1SDhIuLdbgtMTBobnRvMTc0STQ

This got rid of the dark and white spots but it made the metal very shiny. It looks more like silver than steel now.

Edited by Narushima

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×