Jump to content
3DCoat Forums
Enhirement

Reocurring issue - Pen Pressure not working.

Recommended Posts

Hello everyone,

The pen pressure for 3D-Coat has been randomly not functioning lately. It just has the default size, and no opacity no matter the amount of pressure. My pressure works on Photoshop just fine.

For reference:

Windows 10

Wacom Intous Pro - Latest Drivers

3D-Coat 4.7 (Broke after a while, switch to 4.8. Worked for a bit and now broken again).

I have tried the following solutions.

Upgrading program and drivers.

Restarting PC.

Deleting tablet preferences.

 

If anyone can help, please let me know. Thanks!

 

 

Share this post


Link to post
Share on other sites
Hello everyone,
The pen pressure for 3D-Coat has been randomly not functioning lately. It just has the default size, and no opacity no matter the amount of pressure. My pressure works on Photoshop just fine.
For reference:
Windows 10
Wacom Intous Pro - Latest Drivers
3D-Coat 4.7 (Broke after a while, switch to 4.8. Worked for a bit and now broken again).
I have tried the following solutions.
Upgrading program and drivers.
Restarting PC.
Deleting tablet preferences.
 
If anyone can help, please let me know. Thanks!
 
 
Hi, and welcome!

This has been an issue with various tools on Windows that use wacom devices. Try ALT+ Tabbing from 3DC and back. That seems to work for me most of the time. Hopefully for you too.

Sent from my XT1650 using Tapatalk

Share this post


Link to post
Share on other sites
4 minutes ago, Javis said:

Hi, and welcome!

This has been an issue with various tools on Windows that use wacom devices. Try ALT+ Tabbing from 3DC and back. That seems to work for me most of the time. Hopefully for you too.

Sent from my XT1650 using Tapatalk
 

Thanks a bunch, but unfortunately this did not work for me. Here's my painting room, if anything looks off.

Screenshot_3.png

Share this post


Link to post
Share on other sites
Thanks a bunch, but unfortunately this did not work for me. Here's my painting room, if anything looks off.
Screenshot_3.thumb.png.e8c273061bd3bddd7532938abaf332a9.png
Tried uninstalling/reinstalling 3DC?

Sent from my XT1650 using Tapatalk

Share this post


Link to post
Share on other sites
I tried last week, worked for a bit and now it's back to this again.
If you use an older version of 3DC, does it work then?

Sent from my XT1650 using Tapatalk

Share this post


Link to post
Share on other sites

Try switching this icon to pen (pressing LMB over the icon)

Pen.jpg

  • Like 1

Share this post


Link to post
Share on other sites
Try switching this icon to pen (pressing LMB over the icon)
Pen.jpg.2e6cde371ee33af8f37ff62c25556353.jpg
And that if you haven't done it! =)

Sent from my XT1650 using Tapatalk

Share this post


Link to post
Share on other sites
1 minute ago, Javis said:

And that if you haven't done it! =)

Sent from my XT1650 using Tapatalk
 

 

2 minutes ago, Carlosan said:

Try switching this icon to pen (pressing LMB over the icon)

Pen.jpg

Okay so this is weird, I usually keep the same radius when painting so I keep that on mouse. I just turned it on, size and opacity started working again. So I turned it off, and now opacity pressure works. Strange bug, thanks guys!

Share this post


Link to post
Share on other sites

So the issue is happening again, randomly. Turning the mouse to pen like above didn't help this time. I did a fresh install of 4.8.07 (Was using 4.8.04) and the issue still happened. No opacity or radius changes when pressured with my Wacom tablet.

Again, I'm running Windows 10, and reinstalling the driver /  resetting the Wacom service did not help.  Any ideas?

Thanks!

 

(The 3D-Coat pressure tester has shown me inputting pressure, and it works fine with Photoshop).

Edited by Enhirement

Share this post


Link to post
Share on other sites

Preferences >Tablet Library

This option let you select input used by "3D-Coat". Switch between two tablet libraries: "WinTab" and "Tablet PC".

Currently "3D-Coat" uses "WinTab" which will work only if you will install Wacom "WinTab" driver.

When using "Tablet PC" library which should work without additional Wacom "WinTab" driver.

Please report any issue directly on e-mail "support DOT linux AT 3dcoat DOT com".

Thx

TabletLibrary.jpg

Share this post


Link to post
Share on other sites

Unfortunately, this didn't work, switching between both. I updated my driver to the newest version as well. Here is a gif with me performing a simple light pressure stroke. You can see that the opacity and radius are not changing and there seems to be some kind of initial input lag.

broke2.gif

Share this post


Link to post
Share on other sites

Hi!

It seams that your stroke mode is set to constant pressure. Try to change that and see if there is a difference. It's located just above where you pick your color.

Edited by haikalle

Share this post


Link to post
Share on other sites

I was getting ready to say the same thing Haikalle said, but it seems he beat me to it. Hover over each of the BRUSH draw modes in the E-Panel to see a quick tooltip for how stylus pressure affects the radius and opacity. Next to the Radius parameter in the Toolbar (above the viewport), there is a little icon that will bring up the Tapering panel. That will give you even more control over the amount of tapering you may want to use, when painting or sculpting.

 

Share this post


Link to post
Share on other sites

Hi 

Switching to WinTab (on Preferences) not fixed the input issue ?

 

Wintab.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×