Jump to content
3DCoat Forums
sHAYM4N

Lagging viewports & Slow Performance | Fall Creators Update

Recommended Posts

Hi all

Grabbed myself a copy of 3DC a couple of weeks ago, have been loving it so far.  Last week I got the dreaded Win10 popup for the fall creators update - dismissed it with remind me tomorrow, and it installed itself anyway that evening on shutdown (the joy!)  Anyway it pretty much messed up my adobe CC installation - all psd's saved out were corrupt, so I decided to reformat my OS drive and start afresh (as I usually do every 6 months or so).

Installed 3D Coat again today, and the peformance seems to have taken a massive hit.  I'm running in DX Mode, but the viewports lag when rotating and panning, even with just a basic primitive.  Have tried toggling cuda on and off, and still the same.  PC Specs aren't amazing but wasnt a problem before the update - would have thought it would be better now after the refresh rather than worse!  Am running all the latest drivers for the below

Any ideas greatly appreciated!

 

  • Windows 10 Pro 64Bit (Fall Creators Update)
  • i7 6700k (OC'd to 4.5Ghz)
  • 16GB Corsair Vengeance 3200
  • Gigabyte Geforce 980 Ti Windforce
  • Samsung EVO 850 SSD for OS and 3D Coat installation
     

Share this post


Link to post
Share on other sites

Do you get this lag in other 3d software as well?

If yes its a driver issue , had the same issue a couple times with win 10 updates , uninstalled , clean uninstall drivers and 3d coat , restart , re install , restart.

  • Like 1

Share this post


Link to post
Share on other sites

There's got to be some kind of driver issue going on. Doesn't lag on my end. Try doing a clean install of the latest video card drivers.

  • Like 1

Share this post


Link to post
Share on other sites
10 hours ago, Michaelgdrs said:

Do you get this lag in other 3d software as well?

If yes its a driver issue , had the same issue a couple times with win 10 updates , uninstalled , clean uninstall drivers and 3d coat , restart , re install , restart.

Thanks!  I only have Blender installed atm, but no lag whatsoever with that, neither on Battlefield 1.  I've uninstalled 3DCoat and just clean installing the latest driver 388.00 then will try again.

 

Share this post


Link to post
Share on other sites

Problem solved!  (Mostly) :(  Issue remained after the driver update, if I pan, zoom or orbit slowly its fine, but any reasonable speed and the lag occurs. 

Really strange, wondered if it could be the 3dconnexion drivers for my space navigator, uninstalled those and now its fine!  Although not sure if it's now an issue at 3dcoats end on the 3d mouse or I should contact 3dConnexion?  My navigator wasn't plugged in at the time btw, so definatley seems to be those drivers with 3dcoat?

Share this post


Link to post
Share on other sites

It sounds like it was those drivers. Good job on fixing it.

I think Don (AbnRanger) has a 3dConnexion or at least this is what i understand from his tutorials , navigation feels like it.

  • Like 1

Share this post


Link to post
Share on other sites
18 minutes ago, Michaelgdrs said:

It sounds like it was those drivers. Good job on fixing it.

I think Don (AbnRanger) has a 3dConnexion or at least this is what i understand from his tutorials , navigation feels like it.

Thanks!  Managed to narrow it down further.  Reinstalled the 3dConnexion drivers, issue remains but ONLY when the navigator isn't plugged in, so hah typical!  Can live with it for now, but one for the next 3DCoat update hopefully!

  • Like 1

Share this post


Link to post
Share on other sites
I have built separate "3Dconnexion" navigator test. Please download and try this test:
http://www.3d-coat.com/~sergyi/Tests/3D-Coat-3Dconnexion-Test.zip
This is the engine of "3Dconnexion" input from "3D-Coat". It will show how "3Dconnexion" device effects on the FPS (plugged and unplugged). Please look at FPS. Please try both executables (DX - DirectX, and GL - OpenGL). Do you see any slowdown? For example, on my system under DX gives more than one thousand FPS and GL gives almost one thousand FPS (with plugged and unplugged "3Dconnexion SpaceNavigator", during navigation and without navigation).
 
Also I have compiled two special executable files of "3D-Coat 4.8.04" for Windows:
http://www.3d-coat.com/~sergyi/Executables/3D-Coat-4.8.04-NoSleepExecutables.zip
Overwrite existing executable files "3D-CoatDX64C.exe" and "3D-CoatGL64C.exe" (or rename them before extracting the archive). Using these executable files FPS should never be low (even if you do not move the mouse or tablet pen, please pay attention to this detail). Run them and select Voxel Sculpting > small sphere. On my system DX give almost 300 FPS (with plugged and unplugged "3Dconnexion SpaceNavigator", during navigation and without navigation).
 
Please contact me directly "support DOT linux AT 3dcoat DOT com".
  • Like 2

Share this post


Link to post
Share on other sites

Andrew pointed me at this thread, so I hope there's no issue in me posting here. I'm seeing severe performance issues with both 4.8.03 and 4.8.07 on the following system :

 

6700K

64 GB RAM

6 GB GTX 1060, current drivers via Geforce Experience

Win 10 Pro (Slow Ring Insider)

SSD storage throughout.

 

Using the example humanoid with voxel sculpting, the lag is over the order of a second or more between action and response. This is pretty much identical between GL and Direct X, maximized or small window application.

I don't have 3D Connexion drivers installed, but do have the device (physically disconnected, rarely used)

 

Using the navigator test build,


DirectX is reporting a constant 60 fps.

OpenGL is reporting a varying ~1500 fps

Log.txt

Edited by philstopford
typo

Share this post


Link to post
Share on other sites
On ‎12‎/‎22‎/‎2017 at 4:30 PM, philstopford said:

I'm seeing severe performance issues

I have fresh installed on my old unused system (Core 2 Duo E8600 3.33GHz, 4GB RAM, GeForce 8800 GT 256MB) Windows 10 Home (64-bit) from Microsoft site and graphics driver from NVIDIA site. When "brushing" with size 20 on standard "Head" model "3D-Coat 4.8.07"  shows ~51 FPS under DX, and ~48 FPS under GL immediately applying brush strokes. The strange thing is that inside "Log.txt" on my system the driver is "nvd3dumx.dll" (which according to Google search is part of "NVIDIA Windows WDDM D3D driver"), but inside your log the driver is "nvldumd.dll" (which according to Google search is "NVIDIA driver loader").

DX.jpg

GL.jpg

Log.jpg

Share this post


Link to post
Share on other sites

Not sure what to say. The nVidia drivers from GeForce Experience are installed (388.71) and DirectX is being used by games, etc. as one might expect. For both OpenGL and DirectX, the experience is extremely laggy and I can't explain why that might be, either.

 

Share this post


Link to post
Share on other sites
1 hour ago, philstopford said:

Not sure what to say. The nVidia drivers from GeForce Experience are installed (388.71) and DirectX is being used by games, etc. as one might expect. For both OpenGL and DirectX, the experience is extremely laggy and I can't explain why that might be, either.

 

Have you updated your Wacom tablet driver? That, too, can be a source of INPUT lag. Has happened to others in your situation, before, and sure enough...updating it fixed the problem. Also, if you subdivided the mesh where it is 30mill polygons+ in voxel mode, it might have some impact. But, I think it is an issue with either your graphic card drivers or wacom driver. I'm leaning toward the latter because it seems to point to INPUT lag, rather than display lag. 

Share this post


Link to post
Share on other sites
31 minutes ago, philstopford said:

No tablet was in use or installed on the system 

Ouch. You're using a mouse to sculpt with? That's a bit like trying to eat soup with fork. I'm kidding...but not really. :D

Can you try to uninstall the app and install the latest version for your OS?

Share this post


Link to post
Share on other sites

My tablet died, so I'm making do for now. I've seen/heard of a lot of trouble being caused by Wacom drivers of late, so have been holding fire until the dust settles.

 

The slow down is the same for both 4.8.03 and 4.8.07, so I don't think it's installation-related.

Share this post


Link to post
Share on other sites
4 minutes ago, philstopford said:

My tablet died, so I'm making do for now. I've seen/heard of a lot of trouble being caused by Wacom drivers of late, so have been holding fire until the dust settles.

 

The slow down is the same for both 4.8.03 and 4.8.07, so I don't think it's installation-related.

I know you said the drivers aren't installed for the 3dconexxion but have you tried connecting it and seeing if the performance is the same?  For me the lag only occurs when the device isn't connected

Share this post


Link to post
Share on other sites

No, I haven't tried that. I have discovered that the tablet is actually working - not sure what changed. So I've installed the Wacom drivers and will take it for a spin.

I don't know what, if anything, the developers need from me at this point to figure out why the software is running so slowly.

Share this post


Link to post
Share on other sites

Hi, Sergyi, looking at your report, it seem you had a fresh installation of windows 10 and installed the windows update drivers for the video card and not got it from the nvidia web site directly.
Can you confirm that you downloaded and installed the driver from NVidia web site?

The lag, I saw in the video were refresh redraw update, like as 3D Coat requested an update to the rendering of the scene and something interfered (could be potentially a issue with the GeForce experience or Windows 10 game mode stuff). I doubt it could come from a driver tablet.

I'm working with the GL version here in Windows 10, but keep GeForce experience not opened. On Windows 10 they recently implemented in game mode the game bar with DVR screen recording. That may be interfering with 3D Coat. All of that stuff is off here.

Edited by ChristianClavet
  • Like 1

Share this post


Link to post
Share on other sites

Finally found this thread, and so happy I did.

OS Name    Microsoft Windows 10 Pro Version    10.0.18362 Build 18362
System Manufacturer    Dell Inc., System Model    Precision 7720, System Type    x64-based PC
Processor    Intel(R) Xeon(R) CPU E3-1535M v6 @ 3.10GHz, 3101 Mhz, 4 Core(s), 4 Logical Processor(s)
Installed Physical Memory (RAM)    32.0 GB
Quadro P5000 (mobile)
Nvidia Driver v 416.78 (now 431.94)

3D Connection Space Pilot drivers installed, but device unplugged (I did not bother testing with it plugged in, I needed this problem solved ASAP, and might bother to try with it plugged in, but probably not - using the space pilot is rare)
Try and do anything in 3D Coat, and the input lag is crazy 0.5-1s between location samples.  Yet pan/dolly/spin works just fine.  
Disabled the 3D Connection service and killed the drivers, but ** upon starting 3D Coat the processes all started up again. ** << this might be important to Andrew ;-)
Uninstalled the 3D Connection drivers, and the problem disappears - didn't even restart.

===

I've been using 3D Coat for a LONG time! like over 8 years... maybe 10.  But it's not my day-to-day thing.

I've never had lag issues before so when this came up after not having used 3D coat for a while, and recently having installed the latest available release (4.9.05), I was like ok ok maybe there's an issue with the transfer of settings.  so I deleted all my prefs.  nope.  so I reverted to an older version... still no.  so I took to the forums looking for answers and this is what frustrated me most - the highest hits have lots of posts complaining about trolling - sorry - since there is a potentially REAL issue, it would be nice if that post that contributes very little to solving people's problems was taken down a notch or 100.  FINALLY found this post and deinstalled my 3D connection drivers, as the Space Pilot is usually unplugged and only used on rare occasions.  100% completely fixed my lag. 

I REALLY wish this was the top hit for slow performance in the forum.  And this should be the first question, not Nvidia drivers.  If someone with a non-ancient system says "I have horrible lag", I'd first, before anything else, ask if they ever had a space mouse and if it's unplugged! (haha - sure that's me selfishly wishing that was the first thing I found)

anyway... hopefully bumping this issue up helps someone else find the solution quicker than I did.

Edited by cakeller
re-wrote the post to be more concise and provide better background

Share this post


Link to post
Share on other sites

Also - just found that CUDA was not showing up in the Geometry menu of the sculpting room.  hmm...  I went looking for it also when I was first looking for solutions.  Use CUDA and CUDA Smooth Boost were not available when I was having the problem (and I assumed they had been moved/removed or something) but now they are there, so... perhaps that is relevant? 

Share this post


Link to post
Share on other sites
On 10/25/2017 at 4:15 AM, sHAYM4N said:

Thanks!  Managed to narrow it down further.  Reinstalled the 3dConnexion drivers, issue remains but ONLY when the navigator isn't plugged in, so hah typical!  Can live with it for now, but one for the next 3DCoat update hopefully!

Thanks for this -- I had no idea what was going on. But yes -- if my space mouse isn't plugged in... viewport performance is insanely slow (1fps) 
easy enough -- plug it in and everything works great again

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×