Jump to content
3DCoat Forums
kwhali

File -> Import Multiple Objects, not like File -> Import Object [bug]

Recommended Posts

I have trouble importing larger mesh data, such as over 500MB in PLY or FBX(both binary). I have tried several settings like include vertex colour and no luck. This is version 4.8.04 on DX and GL modes for Windows 10. I also tried another approach, add as a new model "brush" with the primitives, this didn't take long for 3DC to render a thumbnail of what it looks like. Yet when trying to import it(30M triangles, around 600MB) it would make the sound of error like previous import out of memory crashes, but continue doing it's thing and memory usage would rise while this sound keeps happening. It got much further, around 12GB of RAM I think before it gave up. Worth noting, I have GTX 1080Ti, so 11GB VRAM, perhaps although 3DC use system RAM(128GB total), it also sometimes makes a copy on GPU VRAM?

I have looked at system settings for page file, it's automatic and enabled, is about 17GB. Plenty of disk space on SSD drive.

Import Multiple Objects experience
I tried another approach, split big data into smaller chunks and try import that way. 3DC have no problem import smaller than 500MB files of this kind of data, so I use the "File -> Import Multiple Objects" option and let it try import the original data(33GB, 400 or so PLY files of various size under 200MB each). Over the hours I monitor it while work on another workstation, it fill up all 128GB RAM no crashing, then start caching to disk to free up RAM presumably to continue the operation. At one point I get to see how much it has imported visually, it looks a bit broken but I think maybe it just not imported pieces yet. Eventually CPU drop to 0% and stay, about 90GB of RAM in use, I imported each piece to it's own layer, trying anything or just selecting a layer would cause long pause/unresponsive, I view task manager, 3DC process doesn't have much activity but one called "System" is active and transferring to disk and GPU using bit of CPU(16 core 32 thread AMD ThreadRipper 1950X), so clearly it move copy to GPU for working with? I notice the GPU VRAM is maxed out, tried to use Geometry proxy, but when enable after waiting a while bluescreen and crash.

I try load just 10 pieces, quite quick, but I notice the mesh look very broken. I view in MeshLab, and see that a part is looking wrong, shouldn't look so bad, so I try regular "File -> Import Object" instead, and mesh look correct and have vertex colour. So this seem like bug, not sure what difference between import method is but would be nice to import multiple objects/files correctly like regular import does.

You can see in attached images, the difference between the two options, one import the hi-res data(photogrammetry model, texture via vertex colour). No idea why multiple import option break so bad.

3dc_import_object.PNG

3dc_import_objects.PNG

Share this post


Link to post
Share on other sites

Hello

Please send this support requests to Andrew Shpagin at

support@3dcoat.com

Thanks.

Share this post


Link to post
Share on other sites
On 11/22/2017 at 2:19 PM, Carlosan said:

Hello

Please send this support requests to Andrew Shpagin at

support@3dcoat.com

Thanks.

Done, thanks :) Look forward to seeing bug fix.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×