Jump to content
3D Coat Forums
Shu

Camera rotation lag (Navigation)

Recommended Posts

Hey everyone!

I am currently running into a weird issue.
When rotating the camera view with my mouse (in any room), there is a small lag between clicking and the rotating happening.
Panning and zooming is not affected by this.
Also, this does not happen when using my Macbooks trackpad.
This does not happen when using the mouse in Blender either.

Does anyone know what could cause this issue?

Even though this problem showed up after tweaking the navigation settings to match the navigation I use in Blender, when choosing Custom Navigation -> 3D-Coat (it seems, this sets back the controls), the issue persists.

This may seem like a small issue, but it has a strong influence on workflow performance since I'm rotating around objects quite a lot.

Hardware used:
Macbook Pro 2015, 16GB RAM, 2,8GHz i7 CPU
Software used:
Mac OS 10.11.6
3D-Coat 4.5.02

If possible, I'd like to not update anything since I'm in the middle of important projects.

Best wishes,
Shu

Share this post


Link to post
Share on other sites

Hello, Shu! I have checked rotation with mouse on old "3D-Coat 4.5.02" on my MacBook Pro. Works as expected (no lag). Therefore please follow these steps:
1. Try to rename your user data folder "Finder > Go > Home > 3D-CoatV45" into something like "---3D-CoatV45" and run "3D-Coat 4.5.02" to see how navigation works using default "3D-Coat" settings. Then you can manually copy your scenes into newly generated user data folder.
2. At any moment you can safely update "3D-Coat" by renaming your existing "3D-Coat" installation and after that installing new one. For example, rename folder "Finder > Applications/3D-CoatV4-5" into something like "3D-CoatV4-5 (4.5.02)". Then download and install the latest "4.8.04" from here:
http://3dcoat.com/forum/index.php?/topic/21433-3d-coat-48-beta-testing-thread/
Note that your existing "4.5.02" uses user data folder "Finder > HOME > 3D-CoatV45" (which besides your scenes also contains your camera settings). But the latest "4.8.04" will use user data folder "3D-CoatV48" (therefore you will need to copy your scenes into it from "3D-CoatV45").
Please report me directly on my e-mail "support DOT linux AT 3dcoat DOT com".

Share this post


Link to post
Share on other sites
On 11/28/2017 at 12:32 PM, Shu said:

Hey everyone!

I am currently running into a weird issue.
When rotating the camera view with my mouse (in any room), there is a small lag between clicking and the rotating happening.
Panning and zooming is not affected by this.
Also, this does not happen when using my Macbooks trackpad.
This does not happen when using the mouse in Blender either.

Does anyone know what could cause this issue?

Even though this problem showed up after tweaking the navigation settings to match the navigation I use in Blender, when choosing Custom Navigation -> 3D-Coat (it seems, this sets back the controls), the issue persists.

This may seem like a small issue, but it has a strong influence on workflow performance since I'm rotating around objects quite a lot.

Hardware used:
Macbook Pro 2015, 16GB RAM, 2,8GHz i7 CPU
Software used:
Mac OS 10.11.6
3D-Coat 4.5.02

If possible, I'd like to not update anything since I'm in the middle of important projects.

Best wishes,
Shu

Hey were you able to find a fix for this issue?

 

I am experiencing EXACTLY the same symptoms and I have the EXACT same machine. Macbook with those specs.

 

Im going crazy here!

Share this post


Link to post
Share on other sites

Please report this issue directly on e-mail "support DOT linux AT 3dcoat DOT com

Thx

  • Like 1

Share this post


Link to post
Share on other sites
On 1/26/2019 at 2:52 PM, allanmrtn said:

Hey were you able to find a fix for this issue?

 

I am experiencing EXACTLY the same symptoms and I have the EXACT same machine. Macbook with those specs.

 

Im going crazy here!

Unfortunately, I didn't find a fix for this problem. I am now sculpting using the Macbook's trackpad. Not as convenient and takes some practice, but better than working with lag.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×