Jump to content
3D Coat Forums
kwhali

[BUG] Sculpt room surface, primitive tool, lattice deformation

Recommended Posts

Please move to bug forum as I'm unable to create posts there for some reason.

I used the Sculpt Room Primitive tool, I selected a cube from the models tab where alphas and such are for brushes. I enabled Click to Place, Scale to Brush Radius, Use Stroke Direction. I place the primitive on to an existing surface(eg another cube), it looks correct, I can keep placing it. If I change my mind and choose a different model(or just click the same cube model again), the latice deforms.

To correct this one must click reset axis(or reset primitive), then select the model to load again, the latice will be corrected, which avoids distorted mesh, although orientation was lost(I'm not sure why orientation was  changing slightly in the first place). You may notice that the reloaded mesh/model had grown in size, this is a 2nd bug, just keep clicking the model icon to reload it, it will grow in size progressively to a certain point(not sure why there is a limit). This 2nd bug occurs when scale has been altered(only seems to affect smaller scale not larger than original scale). So altering scale via transform/lattice toggle or Scale to Brush Radius cause this error.

1st bug is related to Use Stroke Direction. Using Transform/Lattice Toggle and scaling/rotating the model, repositioning it with Click to Place and reloading the model doesn't appear to distort the lattice, but slight rotation offset can be noted of the lattice from the model, this fixes itself(applies incorrect lattice transformation to model) when transforming or repositoining the lattice/model(Click to Place or Transform/Lattice toggle gizmo). I noticed no difference with Use Stroke Direction(just testing now). It was when the scale was made smaller like Scale to Brush Radius setting when enabled that the lattice distortion was more evident from a rotation.

No rotation, just click to place with Scale to Brush Radius and small brush radius, then reload the model, the lattice has enlarged but model stays original size,  use Click to Place without scaling to the brush or use gizmo to move/transform the shape and it will then apply the lattice to itself, if you load another model in again instead of a transform, it will also apply the lattice(increase scale), then grow the lattice again with the model being replaced with larger size model.

I have tried with Use Stroke Direction on different sides of the cube I was attaching the primitive model to, the lattice behaves differently(no orientation via Use Stroke Direction, and just Click to Place and Scale to Brush Radius results in lattice growing equally all lengths), on the top face I was noticing only scaling in the y axis, it also adjusted the orientation on that axis.

  • Like 1

Share this post


Link to post
Share on other sites

I see that in the new updates there are a lot of not very useful innovations, but the old bugs and errors are not going to be fixed. Pass Comrade  Shpagin, that it is better to fix a bicycle that squeaks and in which the steering wheel looks in the opposite direction from the rider than to paint it in other colors or to stick around with LED tape.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×