Jump to content
3DCoat Forums
Sign in to follow this  
tekgecko

[Solved] Parts of textures exporting as Black?

Recommended Posts

Hi Guys,

I am urgently trying to finish some work and yet as you can see the textures where there is grey metal export as solid black.

Does anyone know why this may be? As you can see from the UV layout from within Coat they are displayed correctly.

I have also included my export settings.

Many thanks.

3.PNG

1.PNG

2.PNG

Share this post


Link to post
Share on other sites

Please try exporting each channel individually.

 

Textures.jpg

Share this post


Link to post
Share on other sites

The black zone is the metalness, cycles principled shader support it ?

If not you can change the workflow here: (remember to change the workflow option on export window too)

 

Workflow.jpg

Share this post


Link to post
Share on other sites
3 minutes ago, Carlosan said:

The black zone is the metalness, cycles principled shader support it ?

If not you can change the workflow here: (remember to change the workflow option on export window too)

 

Workflow.jpg

Thanks I will try exporting individually, I know what you are saying about the metalness but it shouldn't be exporting this on the diffuse texture should it? As you can see from my screenshot of the diffuse, its overwriting the grey metal colour with pure black.

Share this post


Link to post
Share on other sites
18 minutes ago, Carlosan said:

Please try exporting each channel individually.

 

Textures.jpg

Exporting the Albedo on it own worked! Is there any way I can get the correct texture without having to manually export the colour each time?

  • Like 1

Share this post


Link to post
Share on other sites
On 19/01/2018 at 3:28 PM, digman said:

Deselect export constructor shown in picture. You will get a new menu.

Make sure "Store gloss/roughness in Metal alpha is deselected.

This will export all your maps correctly. 

FYI. Currently the new Principled Shader in Blender Cycles appears not to read the roughness map as we see it in 3DC. I had to adjust my roughness map externally to match 3DC's viewport.

Yes, something appears not quite right with the export constructor for Blender Cycles.

 

 

Great thank you, I will use these settings. I noticed that too with roughness. I use the RGB curve node within Blender to tweak it to match.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×