Jump to content
3DCoat Forums
guats

Smart Material Transparency Issues

Recommended Posts

Hey guys, really need help with this one as it's halting production on my art pipeline. 

So as you can see this smart material is very simple. It paints on fine, but when I export the layers it inherits the flat colour from the colour picker as part of the layer. I need the transparency from the green layer to stay intact.

So in other words what I am after is a smart material that fills this pattern with green and no blue in the background just transparency. I've achieved this before with the same setup on a different smart material and now the old smart materials are inheriting the same problems.

Is this a reinstall situation?

Please help! 

Thanks, Guats

 

Transparency fail.jpg

Share this post


Link to post
Share on other sites

Dont use alpha in color map is deactivated ?

 

Dont use alpha.jpg

Share this post


Link to post
Share on other sites

Hey Carlosan, Thanks for the prompt reply. :) Yes this is unchecked, tested it and still no alpha/transparency on the layer. I also uninstalled 3d Coat, deleted the prefs files form window>documents, Reinstalled the latest version (4.8.10) Still no luck. I'll try installing on another machine and see what happens.

Share this post


Link to post
Share on other sites

Please try switching layer0 visibility

Switch layer visibility.jpg

Share this post


Link to post
Share on other sites

I tried opening an old document where I had done similar work and then exported to photoshop, it worked and retained the transparency. I ten filled the object in the old doc with the same new smart material and got the issue again. Seems like a smart material problem. But.... an old smart material that I used without problem previously also has the trans. issue now too. ?! Super confusing.

Edited by guats

Share this post


Link to post
Share on other sites

Can you share the old smart material to take a look ?

File > Create extension

Share this post


Link to post
Share on other sites

Okay I will attach the older smart material, however I don't think that will help because it doesn't work any longer either. Transparency is still functioning in my old documents where the smart material has already been applied, but the same smart material that I used to create that layer now is affected by the same issue.

Here's a graphic and explanation of it as logically as I can explain.

------------------------------------------------------------------------------------------------------------------

See attached image: These bright Red, Green and Blue layers are used in our game in conjunction with our custom Unity shader to create custom colours within our game. These may look strange but I assure you this is intentional and is used in our production pipeline.

(1) Opened an old production document in 3d Coat.

(2) Clicked 'Edit all Layers in Ext. Editor'

(3) Hid all layers except the one pertaining to the smart materials in question. Here you can see the transparency clearly, this is working as expected. Please note these materials have not been touched since I used them 3-4 months ago.

(4) Deleted the green layer and re-filled it with the same smart material I used previously.

(5) Clicked 'Edit all Layers in Ext. Editor' and hid all the layers that I didn't need to see. You can now clearly see the green layer has lost it's transparency and has fille dit with the white fore3ground colour that 3d Coat has selected currently.

 

3dCoatTransIssue01.jpg

Share this post


Link to post
Share on other sites

Hey still battling this issue I have made progress though...

* The problem became apparent to me in 3d coat 4.8.3

* I updated to 4.8.10 and the problem persisted.

* I went to a different pc with a fresh install of Windows 7 in our studio and installed 4.5, 4.7 and 4.8

* Same problem EXCEPT version 4.5 will export with transparency

So is this a version thing or is it the settings in the version?

I really need help here, Carlosan or anyone else can you please help.

 

Edited by guats

Share this post


Link to post
Share on other sites

It is  a possible bug... I would send an e-mail to support directing them to this thread and the urgent need because of your production workflow for them to look at it.

I downloaded your smart materials. Recreated your steps and got the same results as you described.

Did other test to show the problem.

I created a png file with some color and the rest is transparent.  I then created a smart material using that png file. You can see in the picture that the larger smart material thumbnail view has transparency showing.

I filled the sphere with the smart material. It appears to respect the transparency but if you freeze painted pixels, the entire model is frozen.  Somehow 3DC is seeing a color in what is supposed to be transparent. The background color you spoke of is possible being the fill color but it is hidden from the user in 3DC.

If you try to freeze transparent pixels nothing is frozen.  Now if you take the eraser tool and erase where areas have no color, choose freeze transparent pixels, then that areas will be frozen. This is shown in the second picture.

Stencils are respecting transparency, I tested just to be sure.

Pictures shows the results of my test. The larger white areas are just glare.

I posted a link to this thread in the beta forum and my test there too.

bug_possible.PNG

 

 

transer.PNG

Edited by digman
More information.
  • Like 1

Share this post


Link to post
Share on other sites

Hey Digman & Carlsoan, thanks for your efforts to help me so far. So after reading what you wrote I see you are getting issues also. I realise this may have slipped under the radar because I am trying to extract layers with transparency to use in a way that most people may not. I will definitely post this thread to support, since it seems to be gaining some traction.

Cheers ;)

Share this post


Link to post
Share on other sites

New version 4.8.13
- Correct PSD export, correct dropping to PS with smart materials with masks. But still have problems with attached materials. Export is OK, getting back is sometimes problematic.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×