Jump to content
3DCoat Forums
agelvik

[Solved] Retopo Symmetry problems

Recommended Posts

Hey,

I continue to run into this problem. Sometimes all I have to do is undo a few times, but most of the time this doesn't solve it.

My retopo mesh suddenly doesn't show when I turn on symmetry back on again, sometimes it does but just barely visible in a strange behavior. It's very random when it happens, how can it be avoided and fixed when it occurs?

P.S, I don't turn on symmetry mid-way, I always turn it on before I begin retopo.

Before symmetry:

5ab8f59bc5024_2018-03-2615_22_20-coral.3b_-3D-COAT4.8.07(DX64)floatingused7of100.thumb.png.584bb6e188c3c9d69657e8120db4eb31.png

 

After:

5ab8f59ec3930_2018-03-2615_22_50-.thumb.png.f6914e4b8bfd5aacbaddf05887a11173.png

 

Another example:

5ab8f5956877f_2018-03-2513_22_02-coral.3b_-3D-COAT4.8.07(DX64)floatingused5of100.thumb.png.34b7b2c074006b3ea7afe5e6c7eb094b.png

Using version 4.8.07

Share this post


Link to post
Share on other sites

Hi

Is Virtual MIrror mode = off ?

VirtualMirrorMode.jpg

Please check this videos showing some workflows about it:

 

 

Share this post


Link to post
Share on other sites

No, Virtual Mirror mode is on.. I found a strange fix though. 

I noticed there was a missing polygon right here

5ab9128cca4bb_2018-03-2617_27_50-coral.3b_-3D-COAT4.8.07(DX64)floatingused3of100.png.a3a1c4ee2c7ba18370152685d178b8d1.png

 

After i filled it, it turned out just fine

5ab91250be4ea_2018-03-2617_28_25-coral.3b_-3D-COAT4.8.07(DX64)floatingused3of100.thumb.png.2d21abe2cee2f4e73b5efcb4f79c06ca.png

But I don't quite understand why this matters tho, what's the difference from before and after I filled it?

 

I tried to recreate what caused the symmetry to bug for this model, which got me closer to figure out what's causing it and how to fix it, but still uncertain if this is a solid fix for the issue regarding other models.. Any thoughts?

Video of the process:

 

Share this post


Link to post
Share on other sites

Using radial symmetry try turning off Virtual Mirror Mode to avoid symmetry issues.

  • Like 1

Share this post


Link to post
Share on other sites

Radial symmetry got it working.. kinda. Virtual mode has to be on for the mesh to be shown tho. But now it looks like an abomination haha

 

Before Virtual Mirror:

5ab93cbfbfaeb_2018-03-2620_27_12-coral.3b_-3D-COAT4.8.07(DX64)floatingused3of100.thumb.png.e7058c6e7fa5a53f8aa2533ef8e06781.png

 

After turning on Virtual Mirror:

5ab93cc447643_2018-03-2620_27_51-coral.3b_-3D-COAT4.8.07(DX64)floatingused3of100.thumb.png.10966eda2af49244f178562becce5303.png

Share this post


Link to post
Share on other sites
On 4/29/2012 at 4:04 PM, TimmyZDesign said:

Basically Virtual Mirror Mode is useful because it allows you to work exclusively on one side of your mesh while viewing a virtual preview for the other side. It is a nondestructive method of working, which I really like. It also allows you to snap the edges of polygons along the symmetry line using "mirror snapping". It is a nondestructive method of working, allowing for quick and easy changes to symmetrical models. I prefer to always leave it on during retopo, but it does have one slightly annoying bug: It doesn't work with the strokes tool. The workaround is to turn symmetry off temporarily and delete the unwanted faces it has created. This isn't a big deal, but I will report this bug when I get around to it.

FYI, here are two threads about this same exact topic that will probably answer any other questions you might have:

http://3d-coat.com/forum/index.php?showtopic=9674&st=0&p=74468&hl=+virtual%20+mirror&fromsearch=1entry74468

and:

http://3d-coat.com/forum/index.php?showtopic=9673&st=0&p=74485&hl=+virtual%20+mirror&fromsearch=1entry74485

 

 

Share this post


Link to post
Share on other sites

Hmm I see. From what I've gathered up until now, I guess you just gotta be careful when creating new faces on the center, mostly. If the bug were to occur, just delete newly created faces, and recreate them on the correct side (as show at the end of my video). Seems to be the case for me at least :) 

Feels good finally having an overview of this, this made me so angry at times haha. Thanks for you assistance Carlosan!

Share this post


Link to post
Share on other sites
6 hours ago, agelvik said:

Hmm I see. From what I've gathered up until now, I guess you just gotta be careful when creating new faces on the center, mostly. If the bug were to occur, just delete newly created faces, and recreate them on the correct side (as show at the end of my video). Seems to be the case for me at least :) 

Feels good finally having an overview of this, this made me so angry at times haha. Thanks for you assistance Carlosan!

You are correct...  When using the radial symmetry,  I leave the areas near the converging symmetry plane till the last. Then turn off symmetry and fill in manually that section. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×