Jump to content
3D Coat Forums
David BK

[Solved] Normal Map Export from 3D Coat to Maya

Recommended Posts

What are the proper export settings for normal maps from 3D Coat to Maya (Arnold IOR)?

In File > Preferences I have tried using numerous normal settings (Software Preset, Calculation Method, Swap TB), but I still feel like my normals are looking inverted in the Maya Arnold render.

What is the proper normal map export workflow?

Share this post


Link to post
Share on other sites

Hi

Which problem do you have when use File > Export objects and textures > Use export constructor for per/channel packing ?

 

Export.jpg

Share this post


Link to post
Share on other sites

Why you selected 3dmax archdesigin preset ? 

Sorry i dont understand.

Share this post


Link to post
Share on other sites

Can you please try this settings ?

 

Normal.jpg

Share this post


Link to post
Share on other sites

This is what I would like to achieve in the normal map export. It's possible to do the edit in Photoshop, but I'm wondering whether there is a setting in 3D Coat for this.

SwapRG.jpg

Share this post


Link to post
Share on other sites

The flip R and G Channels in Arnold could be useful.

I was wondering whether I could export proper maps straight from 3DC. If it's not possible, there are other solutions elsewhere (through Photoshop or Arnold settings). Thank you!

Share this post


Link to post
Share on other sites

I am sending support ticket to invert the green channel output by default when choosing Maya Normal Map style in the Preferences.

To invert the green channel for normal maps to appear correctly you can try a workaround:

Go to "Edit" - "Preferences", find "Normal Map Export", the default standard is "Maya, Blender", you can select "3DS-Max, LW".

The difference between these two Normal Map standard is that green channel is inverted.

Share this post


Link to post
Share on other sites

That would be great to send a support ticket. But I think the issue has to do with Red and Green needing to be swapped (not inverted green). To solve the problem:

Take RGB and do GRB so the channels are shuffled.

Share this post


Link to post
Share on other sites
2 hours ago, Carlosan said:

I am sending support ticket to invert the green channel output by default when choosing Maya Normal Map style in the Preferences.

To invert the green channel for normal maps to appear correctly you can try a workaround:

Go to "Edit" - "Preferences", find "Normal Map Export", the default standard is "Maya, Blender", you can select "3DS-Max, LW".

The difference between these two Normal Map standard is that green channel is inverted.

If you invert the green channel by default when using Maya / Blender Normal Map in preferences then your normal maps in Blender will be incorrect. 

Better to leave this up to the user with a setting in preferences to flip the green channel or in the export panel when needed.

Edited by digman

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×