Jump to content
3D Coat Forums
Andrew Shpagin

3DCoat 4.8 BETA testing thread

Recommended Posts

Initial scale question popup. You select yes or not ?

Is Scene scale ok ? (geometry > edit Scene scale)

 

 

keep.jpg

Share this post


Link to post
Share on other sites

@Carlosan

You are correct, if I choose no, then it works. If I click yes, then they get rescaled. Actually, now I understand what this box is for. I didn't understand it before :) However, I would think that if I scale the imported then apply, regardless of what my initial option was, shouldn't it behave as I control it upon applying it?

Regardless, there may be a use case for this behavior. At least I know how to revert it back (Geometry->Edit Scene Scale)

 

By the way, you always answer quickly, even on the weekends. Sometimes I feel bad for posting questions on weekends. Thanks a lot!

Edited by Makketronics
  • Like 1

Share this post


Link to post
Share on other sites

Perhaps Carlos has morphed into a virtual entity that never sleeps. For instance, I'm on the west coast of N America and you posted around 9:00 PM my time when I'm watching Netflix .

Share this post


Link to post
Share on other sites

....looks as though you are trying to paint a bump/normal map on an obj that has not been retopoed or UVd yet, bump painting only works on texture maps.

( apologies if Ive misinterpreted your vid.)

Share this post


Link to post
Share on other sites
6 hours ago, stusutcliffe said:

.... 아직 retopoed 또는 UVd되지 않은 obj에 범프 / 노멀 맵을 페인트하는 것처럼 보이지만 범프 페인팅은 텍스처 맵에서만 작동합니다.

(아이디가 당신의 화상을 잘못 해석하면 사과드립니다.)

The 21st version is good.But not from version 22~23 ㅠㅠ

Share this post


Link to post
Share on other sites
2 hours ago, superman punch said:

.3dcoat 4.8.22/3dcoat 4.8.23

 The version is not available.

3dcaot 4.8.23SL 
It works very well.

Oh. That's right. SL stands for Sculpt Layers. Andrew is offering builds with it and a version without it, for stability purposes.

Share this post


Link to post
Share on other sites

Hi at first thanks to try keep unit scale between session for new beta. But what I really annoying thing is,, 3d coat unit seems not apply for grid.

I import 1m cube from blender with default scale (1.0) as obj.

then I set  Unit  etc ,

1 in sculpt room>geometry>Edit scene scale ,   scale 1.00 and all off set = 0.00   ,

2  geometry > Define mesurement units  , set  Units = Meters,  Voxel per unit = 1000 (so I hope to generate voxel  1 mm density), Unit scale = 1.00

3  I set Measure tool option,   Units as meters = 1M

So in my pic, it seems correctly shown. But I needed to tweak around for Grid units,,,    as I mentioned,,  I set 1 unit as 1 meter.

but 3d coat grid seems not use the 1M units, even though I set up-so.

I needed to set Grid Step as "1000," "0.001" (edit),  then it can show reasonable 1m grid (division 1) .  when  I set Grid Step as 1 without knowing it,, my obj is too small in 3d view. 

so I needed to serch around what cause problem still.  untill I set grid step as 1000,  I can not find any grid to get aproximate size,   without mesure tool.

I do not think, it is reasonable.  usually I expect, mesurement units = grid units.

  so Grid step seems try to count voxel density too?    and I hope to know, what means, "keep unit scale between session" ?

because once I close 3d coat, then next time I import new obj for paint room, I needed same step from scratch. 

 So I need to save scene first, and everytime use the scene untill import obj? 

 I definetly suggest, please offer option to use same unit scale, and grid setting in user preference. It is most important setting I believe.  

once I decide it, do not hope to change it for each session.  without I need to change them. 

It  is not useful, just to get same unit scale,,  If  I need to keep session or I need to use same saved file to import obj,  everytime. 

coatimport1.JPG

grid.JPG

Edited by tokikake

Share this post


Link to post
Share on other sites

3d Coat  beta  (windows 4.8.23(64bit)) ,  winows 10 XP.

Even though I change "voxel per units" from 1 to 100 , there seems no change about,  geometry "voxel density" 

So it only matter for 3D grid ?  if So there seems no reason, we have menu for "3d Grid custom density"

I change "voxel per units" 1  to 100" ,  but keep measurement unit as 1m.    and import same obj, it do not change voxel density, when I check it with wire frame view.

But the voxel per units effect 3D  "grid". 

There are some properties  about "unit" ,but each unit means is really un-clear.

eg I change paintroom> measurement tool> tool option> measurements units ,from M to cm,

Basically I hope,  it never change actual geometry size. just change how represent actuall size.

so I hope 1M cube need to show as 100 cm.  but it not work so.  if I change "mesurement units",

1m cube change as 1cm.   at same time it change grid size.   

 

I think, to measure geometry for actuall world

1 world units .    it decide "1 unit distance" to import and  generate mesh.  from import format each values.

2  measure tool units ,  it never effect mesh size.   just change how represent "length". so 1M length = 100 cm  , if it not work so,  it can not work as measure tool.

3 3D view Grid density,  it simply decide sub grid counts of 1 units.  

4 voxel density, it decide voxel (for sculpt) counts for 1 units 

every 1 unit length should be same. and it decide by "world units"

So about 3d coat, each tool "units"  represent what value?  

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

Possible bug in 3D-Coat-V4.8.23SL (demo mode)

Move tool triggers "hidden color information" icon in vox layer.

Similar thing in pose tool.

 

move-color.thumb.png.965e61417f466d07366e222511750622.png

 

I don't know if that's how it should be.

Share this post


Link to post
Share on other sites

×