Jump to content
3D Coat Forums
Andrew Shpagin

3DCoat 4.8 BETA testing thread

Recommended Posts

On 11/7/2018 at 7:40 AM, Werner_Z said:

Very very slow loading of scenes in the latest build. 4.8.25A-SL

Load screen stays on "prepare for texturing"  way too long.  Even on lighter scenes.

 

It's only the first time you load an old file. After you save it and reload it won't do that.

  • Like 1

Share this post


Link to post
Share on other sites

Hi,

I recently installed the latest 3D-Coat for macOS (4.8.26), and noticed the following:

I start 3D-Coat and choose auto-retopology, then after the window with the initial settings I press S and check x symmetry. Subsequently I press Next in the following requesters, because I want to skip the density painting and guide drawing. Finally, nothing happens. I just see the imported mesh, without Autopo.

So I need to right-click on the imported mesh layer and reinitialize Autopo to make it work.

Is this a bug or is there a specific moment you need to activate symmetry? A symmetry option in the initial Autopo options would be more convenient.

Thanks.

Share this post


Link to post
Share on other sites
On 11/6/2018 at 12:33 PM, Andrew Shpagin said:

(1) - Merge visible was not changed. Possibly there is difference on your side - voxel/surface, different layers selected etc. If you will provide scene/steps to reproduce, I will investigate and fix.

(2) - not understood.

I will contact you sometime next week and show you what I mean. Both topics. It's fast to show. I can provide you the example scene then.

Removing undercuts needs very long to calculate too. Much longer then v4.8.20.

Share this post


Link to post
Share on other sites
On 11/8/2018 at 5:31 PM, lesaint said:

It's only the first time you load an old file. After you save it and reload it won't do that.

I guess I spoke too hastily. sometimes it doesn't do it on reload, but other times it does

Share this post


Link to post
Share on other sites

4.8.25A-SL(GL64) "Don't snap subdivision vertices to surface" is missing from the import object box when you do "Update paint mesh with retopo mesh"

Share this post


Link to post
Share on other sites

Since the devs are working on the brush engine, could they take a look at the clone tool ? Pen pressure works fine with the clone tool for per pixel painting, but not in vertex painting mode, and yes I know bout setting opacity in tool options, but it just isn't the same.

Also is copy/paste tool broken ? It doesn't do anything.

Share this post


Link to post
Share on other sites

Hey everyone,

I've been sculpting a lot in 3d-coat 4.8.25A - SL (DX-64) and it's possibly a problem...
The problem is as follows:
When I'm in Surface mode, I hide a part of the mesh to be able to sculpt using the Move Brush and the Pose Tool and after I finish making the necessary modifications I appear with the complete mesh, the result is that the mesh that was hidden was also deformed by the Move Brush or Pose Tool.
How is this possible?
I believe that when you hide a mesh, this hidden mesh should not receive any modification or alteration, but in my case, even if I hide the mesh that I do not want to deform, it is being altered as if it were still visible on the screen.

Could someone please let me know if this is a bug in 3D-Coat ?
I noticed that this problem that I'm going through has happened to me in previous versions of 3D-Coat.

Thank you

Share this post


Link to post
Share on other sites

21.11.2018 4.8.28

- Important! 3B scenes are zipped on the fly, so will take much less space on the disk! Saving does not lock main procss, so you may continue to work while 3D-Coat saves scene.

- Fixed crash related to screenshot in multi-display mode.

- Fixed problem related to picking volumes after scene loading

- "Naive" padding seamlessness improved essentially.

- stability of cutoff improved

- fixed crash in spike/muscle/etc tools

- Smooth all in surface mode works correctly with multiselection.

- Pose rect selection, gizmo at center mass

- fill layer problem fixed

-  fixed crash during DEL

Curves:

- Possibility to save curves to separate files

- Support of multiple modifiers per curve

Sculpt Layers

- Remove stretching compatible with SL

  • Like 4

Share this post


Link to post
Share on other sites

3B scenes being zipped by default is really awesome. I manually would zip them in packs when I finished projects but may not have to do that anymore which is cool.

  • Like 1

Share this post


Link to post
Share on other sites
6 hours ago, Andrew Shpagin said:

21.11.2018 4.8.28

- Important! 3B scenes are zipped on the fly, so will take much less space on the disk! Saving does not lock main procss, so you may continue to work while 3D-Coat saves scene.

- Fixed crash related to screenshot in multi-display mode.

- Fixed problem related to picking volumes after scene loading

- "Naive" padding seamlessness improved essentially.

- stability of cutoff improved

- fixed crash in spike/muscle/etc tools

- Smooth all in surface mode works correctly with multiselection.

- Pose rect selection, gizmo at center mass

- fill layer problem fixed

-  fixed crash during DEL

Curves:

- Possibility to save curves to separate files

- Support of multiple modifiers per curve

Sculpt Layers

- Remove stretching compatible with SL

NAIVE Padding? Is that it's proper name or a typo?

Share this post


Link to post
Share on other sites
1 hour ago, Andrew Shpagin said:

Probably not typo. Imo naive ~ simple, primitive. 

Naive is not a good word to use, then. It should be SIMPLE. Naive, in English, is basically the same as IGNORANT. It has a negative connotation.

https://www.merriam-webster.com/dictionary/naive 

: deficient in worldly wisdom or informed judgment

Share this post


Link to post
Share on other sites

! I think I've found a critical file save error in 4.8.28

If I open up one of my larger project files created in a previous version of 3D Coat (like 9GB 3b file) everything appears ok (models, normal maps, textures etc). However once I 'save as' the file and the saving is complete (I waited until the 'don't close' message at the top disappeared) when reopening the file many of the models in the paint room have no textures, normal maps, and all other layers associated with those models are just white rending the project file broken pretty much. It compressed the 9GB file down to 190mb roughly, that seems like a huge amount of compression for a file that had a lot of textures, it seems like it purged a lot of it by accident.

Good thing I did not overwrite my original. This means if I try to do any work though in 4.8.28 and save the file and try to reopen it loses a lot of the data. There must be a problem with the compression on larger 3b files as I saved a smaller one (like a  260 mb file) and when I reopened it everything was ok.

 

I noticed on the larger file the saving progress freaks out as well:

M8Yv0ei.jpg

 

As a side note when it was saving I didn't do any work, I just let 3D Coat sit until it completed saving.

Edited by Mystical
  • Like 1

Share this post


Link to post
Share on other sites

Will these zipped .3b files open in older versions of 3DC? I don't plan to downgrade or anything but it would be good to know if that will be a problem.

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, Mystical said:

! I think I've found a critical file save error in 4.8.28

If I open up one of my larger project files created in a previous version of 3D Coat (like 9GB 3b file) everything appears ok (models, normal maps, textures etc). However once I 'save as' the file and the saving is complete (I waited until the 'don't close' message at the top disappeared) when reopening the file many of the models in the paint room have no textures, normal maps, and all other layers associated with those models are just white rending the project file broken pretty much. It compressed the 9GB file down to 190mb roughly, that seems like a huge amount of compression for a file that had a lot of textures, it seems like it purged a lot of it by accident.

Good thing I did not overwrite my original. This means if I try to do any work though in 4.8.28 and save the file and try to reopen it loses a lot of the data. There must be a problem with the compression on larger 3b files as I saved a smaller one (like a  260 mb file) and when I reopened it everything was ok.

 

I noticed on the larger file the saving progress freaks out as well:

M8Yv0ei.jpg

 

As a side note when it was saving I didn't do any work, I just let 3D Coat sit until it completed saving.

Thanks for reporting!

Please try to unzip manually the 3B file. It is just zip archive. Then try to open. Look the size.

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, philnolan3d said:

Will these zipped .3b files open in older versions of 3DC? I don't plan to downgrade or anything but it would be good to know if that will be a problem.

You may unzip it manually and then open with older versions.

  • Like 1

Share this post


Link to post
Share on other sites
5 minutes ago, Andrew Shpagin said:

Thanks for reporting!

Please try to unzip manually the 3B file. It is just zip archive. Then try to open. Look the size.

Unzipped it jumped up to roughly 877mb from the 200mb compressed (original is 9GB). When I open the file it looks like the textures on several of the models was still missing the same as the compressed version.

Share this post


Link to post
Share on other sites

×