Jump to content
3DCoat Forums
Andrew Shpagin

3DCoat 4.8 BETA testing thread

Recommended Posts

8 hours ago, gbball said:

Is it possible to get an instancer brush?

Something that is a mix between the instancer tool and the import tool?  

I'd like to be able to import a simple mesh for all these orbs and then later export to Blender without it being treated as one big object.. 

If I could brush into the scene from an instance of a 3b object...then I could adjust the 3b object afterwards and have the placement and size be kept.  Further...I'd like to be able to export this out to an external package like Unreal or Blender and have each orb be instances of the same mesh.

This was done with sphere tool with max spacing on the brush and some size and position jitter.  Currently it's all on one voxel layer.  But this hurts my pipeline because I will have to duplicate work.  I want to optimize this for real-time rendering.

Iimage.thumb.png.9dad42bc680cb6b93f88ac2768743712.png 

I've been meaning to ask for something like that for a while, mainly to where you would have a panel where you could select multiple models from the MODELS pallet, and choose to randomly apply each of them, or only the selected one. Call it the Scatter brush, and a similar one, called Particle Scatter, using dynamics to make objects fall and react naturally. I think Houdini added something like that a few versions ago. 

  • Like 1

Share this post


Link to post
Share on other sites

source...

On 10/30/2011 at 9:41 PM, kay_Eva said:

What would be really nice, is if you could create instances of polygon objects at the precise location/orientation of any given voxel layer or sublayer.

This way, you can use voxel modeling for kitbashing, retopo a single instance of whatever needs to be replicated.

And then use some "Create Polygon Instances at Voxel Layers" command. Then you could drag/drop or better yet, in a perfect world, use some kind of nodes system to connect any given polygon object to any given voxel layer.

In this way, you can have a method of procedural modeling that will allow people to kitbash directly from voxel -> polygon version without having to do overly complicated retopo and without having to manually reconstruct the polygon object by hand after having already modeled it in voxels.

 

  • Like 1

Share this post


Link to post
Share on other sites

Thanks Carlosan,

I've bumped the thread you linked with a description of the tool I'm looking for.  

Share this post


Link to post
Share on other sites

I do not know which version worked or not, but current beta version (Open GL win 64)  can not up-date texture layers  belong to current UVset.

In this mesh, I have painted  once with custom PBR shader. (I do not stick shader for layer, do not know clear about the procedure, so just use Fill tool with materials) and separate by layer.  there was  no prolbem.

paint1.thumb.JPG.e2ba5f776b1b5c12baddaaf3e20a3153.JPG

 

then I plan to edit UV in UV room, add one new UVsets  (name as Front) move some island to new "Front",  and  arrange again. then apply UV set. it is all what I did.  in UV room, I think there is no problem. (add new pic which I edit in UV room, to compare after broken,,)

retopoedit.thumb.JPG.bd610f637fe0c8b2cc052ed9af4a0b58.JPG

But after apply UV set, 3d coat freeze (it often happen with my pc,, when there is already many layer)  and, when I check texture it broken. I think UV seems correctly changed.  but paint layer not up-date correctly I think.

break.thumb.JPG.ac09f8d35c0316819e95a79ceafc8ab1.JPG

 how many times I try same procedure,  (but change UV in UV room, with add new UV set)  it seems break my textures of layers in pant room.

Then  I check UV and mesh In UV room, after apply UV set,  it seems somehow corrupted around seems edge. like this pic. (It not shown when I edit it in UV room) and if I select and move island, it stack edge vertices as if I pin these.

corruptedmesh.thumb.JPG.c3cc89d61911edb7fbf92a424e7374ea.JPG

When I merge UV sets before, it worked  without problem.(keep all textures layers as same as before) So I suspect, when I add UV sets, this problem happen,,,  or with PBR shader ? 

=====
I try one more test, then now I clear see, even though I click apply UV set,, untill I change room to paint, UV keep clean. but after change room to paint, and retrun UV room, now I see corrupted UV. 

Edited by tokikake

Share this post


Link to post
Share on other sites

Hey everyone,
Problems with Project tool:
Currently, on my computer, preview In and Out is not working.

Share this post


Link to post
Share on other sites

On my computer, preview In and Out is working fine on both projection method. And reproject color too.

v8.4.34 SL

Share this post


Link to post
Share on other sites

I am using v.4.8.34 SL (DX) and update my Video Card driver --
In the Sculpt Room, Reproject Tool is not showing me the preview In and Out. I have already looked at all the settings and the Reproject Tool does not give me the preview.
I do not know what's happening, I choose the preview and change the slide and the preview does not appear. I already tried to change the shader to know if the shader influences the Preview, but the same thing happens. No preview. :( 

Edited by Rygaard

Share this post


Link to post
Share on other sites

could you share this project please ? I like to take a look. Thx

Share this post


Link to post
Share on other sites

Just a tip: My 3D Coat installations became extremely slow some time ago.

I've deleted the complete user data folder and registered the version anew. All works fine now.

Share this post


Link to post
Share on other sites
1 hour ago, Carlosan said:

could you share this project please ? I like to take a look. Thx

Of course ... I quickly made a blocking of a sculpture of a face so you can test the reproject tool of the sculpt room ( Please do not notice the badly made sculpture). Here, the preview does not really work.

reproject_preview_not_work.rar

Share this post


Link to post
Share on other sites
3 hours ago, Rygaard said:

Of course ... I quickly made a blocking of a sculpture of a face so you can test the reproject tool of the sculpt room ( Please do not notice the badly made sculpture). Here, the preview does not really work.

reproject_preview_not_work.rar

I can confirm that here the reproject tool does not show a preview when loading your file.

However, I made a quick test from scratch and the preview did work, with the same version of 3dc.

 

Share this post


Link to post
Share on other sites
42 minutes ago, lesaint said:

I can confirm that here the reproject tool does not show a preview when loading your file.

However, I made a quick test from scratch and the preview did work, with the same version of 3dc.

Thanks for testing. Did you use the same shader for your tests? Or Did you use a different shader for each test?


I think I found the error for this problem of the Preview of the Reproject Tool (Sculpt Room).
The problem is the shader. Not all shaders allow the preview of the Reproject Tool to happen. Before, any shader I used had the preview of the Reproject Tool, now I realized that only a few shaders work with the preview of Reproject. I believe this is a related bug between the Shader and the Reproject Preview.

  • Like 2

Share this post


Link to post
Share on other sites

I received multiple inquiries regarding bugs I reported on Mantis, whether they were fixed in the most recent version or not, and I can't even comment on them because the last GNU/Linux version is months old.

Share this post


Link to post
Share on other sites
On 3/6/2019 at 3:59 PM, Rygaard said:

I am using v.4.8.34 SL (DX) and update my Video Card driver --
In the Sculpt Room, Reproject Tool is not showing me the preview In and Out. I have already looked at all the settings and the Reproject Tool does not give me the preview.
I do not know what's happening, I choose the preview and change the slide and the preview does not appear. I already tried to change the shader to know if the shader influences the Preview, but the same thing happens. No preview. :( 

 

I can't see the reproject tool in my UI. I use 3dc 4.8.34

image.png

Share this post


Link to post
Share on other sites
On 3/6/2019 at 7:43 PM, Rygaard said:

I think I found the error for this problem of the Preview of the Reproject Tool (Sculpt Room).
The problem is the shader. Not all shaders allow the preview of the Reproject Tool to happen. Before, any shader I used had the preview of the Reproject Tool, now I realized that only a few shaders work with the preview of Reproject. I believe this is a related bug between the Shader and the Reproject Preview.

 

Share this post


Link to post
Share on other sites
3 hours ago, Frimasson said:

I can't see the reproject tool in my UI. I use 3dc 4.8.34

I use only the latest versions of 3D-Coat beta (SL). Maybe the reproject tool does not appear because this tool should be beta (Go to Edit / Preferences and check the Show Beta Tools option) and you are using the other version of 3D-Coat that does not have Sculpt Layers, check if the name is written in final (SL).

Share this post


Link to post
Share on other sites
On ‎3‎/‎10‎/‎2019 at 3:34 AM, ajz3d said:

@SERGYI How long until new GNU/Linux build?:dash2:

Sadly but long because a lot of problems have been encountered. In the meantime I have received a letter from our user which reported that "3DCoat" works good under Wine from WineHQ repositories. Maybe worth trying that while native version will be built.

  • Thanks 1

Share this post


Link to post
Share on other sites
3 hours ago, SERGYI said:

Sadly but long because a lot of problems have been encountered. In the meantime I have received a letter from our user which reported that "3DCoat" works good under Wine from WineHQ repositories. Maybe worth trying that while native version will be built.

It's happened to me.  Sculpting in 3d coat under wine on ubuntu mate feels more responsive, but baking AO map would crash 3d coat (this problem seems to be gone under latest version of wine).

  • Like 1

Share this post


Link to post
Share on other sites

15.03.2019 4.8.35

- Possibility to unwrap stripe-like UV islands into straight lines. Use "UV->Selected->To Stripe".
- Store pose selection to layer, picking pose selection from the layer. Works similar (to some degree) to poly groups in ZB.
- Edge for all curve modifiers may be customized in really rich way.
- Less memory consumption during the export. It means possibility for stable 16K textures export.
- Unused locked textures will be deleted automatically to save disk space.
- Running several different versions of 3D-Coat will not interfere with each other. Previously it was causing problems with Undo, eliminating cached volumes.
- FBX import without vertices welding to preserve vertex order during the export/import
- Curves got really rich update. Now it is possibly to construct many different shapes using curves in non-destructive way. Click RMB over the curve and look at the list of modifiers. There are videos that describe how it works:
  Swept Surface 1 - https://youtu.be/8BCawmVqGK4
  Creating a surface of revolution - https://youtu.be/XdYuoaNIwsA
  Polyhedron - https://youtu.be/c7Xld8udEXM
  Swept Surface 2 - https://youtu.be/pLkBVx8vKPI
  Swept Surface 3 - https://youtu.be/p8g6pn_810s
  Sword - https://youtu.be/Qyy-aqPG1iY
  Goose - https://youtu.be/f9mY5wlvvwA

  • Like 6
  • Thanks 1

Share this post


Link to post
Share on other sites
2 hours ago, Andrew Shpagin said:

- Store pose selection to layer, picking pose selection from the layer. Works similar (to some degree) to poly groups in ZB.

Could anyone tell me how I can use the function? I tried to find , but... What are the steps? thank you!

--------- I found ... Sorry....

Now that I've realized that this function is inside the Pose Tool ....

Edited by Rygaard

Share this post


Link to post
Share on other sites
On 3/12/2019 at 7:13 PM, SERGYI said:

Sadly but long because a lot of problems have been encountered. In the meantime I have received a letter from our user which reported that "3DCoat" works good under Wine from WineHQ repositories. Maybe worth trying that while native version will be built.

@SERGYI, thank your for the info. I appreciate that you guys are working on it.

Last time I checked, I couldn't run 3D Coat under WINE. It crashed on each launch attempt. Before crashing however, it did manage to create its configuration directories in ~/Documents - the location I don't want them to be in... Anyway, maybe I didn't try hard enough, I admit. After all, I didn't upgrade my system to GNU/Linux to launch Windows binaries. ;) I can only imagine how using 3DC through WINE complicates the pipeline.

I think I'll wait until you guys get those things sorted out, and for that I keep my fingers crossed. I have full trust in you. :good:

Edited by ajz3d

Share this post


Link to post
Share on other sites

@Andrew Shpagin
Please, Could you give some news to all of us about 2 things?

1) About the new brushes system you were developing?

2) Please, would a function similar to MidValue be possible for Alphas (this function exists in ZB)? This function is essential and very important, it would help a lot to the detail of the mesh surface avoiding problems of edges around the alpha and control of the alpha in the surface of the mesh (control in the scale of grays) helping the alpha to stay flat in the surface and not inflating the surface!

Thanks for the great work on 3D-Coat!

Share this post


Link to post
Share on other sites

I hope that the new brush system means that corresponding brushes from Surface and Voxel worlds would be unified in how they affect the surface (minus dynamic tessellation for obvious reasons).

What I like about ZBrush sculpting is that all brushes are available in each sculpting "mode" and behave in exactly the same way,  no matter whether they're used in Dynamesh, standard SubDiv sculpting or even dynamic tessellation. I'd like to have this in 3D Coat too. Predictability and consistency.

Edited by ajz3d

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×