Jump to content
3D Coat Forums
Andrew Shpagin

3DCoat 4.8 BETA testing thread

Recommended Posts

Thanks 3D coat developer teams :)

 I know all about curves tools are still in development process. No hurry .  Just expect it will be offered as stable powerful tool.

Share this post


Link to post
Share on other sites
On 4/5/2019 at 11:52 AM, animk said:

EEvee is great, too. It's real time or almost real time.   I always render my sculpt in eevee, but need to decimate my sculpt before importing to blender, because it takes blender forever to import a large file.

"Professional" animation solutions have the same problem and need a poly reduction, too. So no matter...

Share this post


Link to post
Share on other sites
On 4/10/2019 at 7:15 AM, bocs said:

@Carlosan

Radeon ProRender may have some licensing issues?
Step 2 says "sign a Radeon ProRender Commercial Software Licensing Agreement"
Have not looked into the details, but ProRender seems nice and cross platform.

Now for Cycles and Lux, I integrated them into unity over 3 years ago. 
https://bit.ly/2UIZSt3

both are fairly easy to integrate, send mesh and shader/texture data...render to memory buffer, display
converting shaders is not that hard with PBR, they are "physically based" which is kinda universal.

any path tracer will be noisy (cycles), but just as example...32 samples (a few seconds) with my unity plugin using optix 
2IoQ9BC

Just a note: The NVIDIA AI Denoiser is already supported by "D-NOISE" a free AddOn for blender and works great. But let us move this topic better to a seperate thread...

  • Like 2

Share this post


Link to post
Share on other sites
7 hours ago, tokikake said:

Thanks 3D coat developer teams :)

 I know all about curves tools are still in development process. No hurry .  Just expect it will be offered as stable powerful tool.

For now, use the top panel to move, if that helps.

1.png

Share this post


Link to post
Share on other sites
On 4/2/2019 at 5:42 PM, Andrew Shpagin said:

Context sensitive RMB menu in retopo room, it is especially helpful in "Select" tool for low-poly modeling. 

That's great. But is it possible that this menu does not appear when i'm still holding the Alt key while navigating (Alt+RMB). Sometimes this can be annoying and can lead to errors when you miss it and click some function randomly.

  • Like 1

Share this post


Link to post
Share on other sites
11 hours ago, Andrew Shpagin said:

4.8.38

 - Fixed problems related to tiling and filling layer with material.

 - Fixed a lot of errors related to curve modifiers and instancing volumes, loading/saving scenes with instances and modifiers.

 - Fixed "To uniform + Undo" problem.

 - Fixed problem of mesh exploding during extrude faces in retopo room.

Oh, and now we have the bridge tool. Awesome!

Share this post


Link to post
Share on other sites

4.8.38

major problems switching between surface and voxels. takes forever or crash (crash most of the time). no such problems in 4.8.35

Share this post


Link to post
Share on other sites

@Oleg_Shapo

11 hours ago, Oleg_Shapo said:

For now, use the top panel to move, if that helps.

1.png

Thanks to teach me the option.^_^

  I do not know, if it have been there already ,  I hope if future version can move these menu to another place which can be more compact and easy find.p(eg I think they can be moved as Curve layer top menu, or add one more section "Curve options" ,which controll  each curve  or segments postion, scale etc) 

Because These "Point postions" (when select segments) and "Center"  x, y, z , sclale x, y, z  often ,not visible without I keep stretch  3d View right side.

=========

And  yes finally we can use  bridge tool !!!   This new beta seems really good up-date for me.. (I can confirm, curve tool Swept N gener becom more stalbe too )

 

 

Edited by tokikake

Share this post


Link to post
Share on other sites

I do not know when it started, but about some exr , it often lost color infomation when I use them as enviroment map.

I have used some exr  (blender cloud etc), then it work (eg can open in gimp, or blender , ds), but when I import them as enviroment map, they do not  work for 3d coat.

it lost color infomation then only generate black and white enviroments..   Is there any limitation about 3d coat env exr image ?   it seems not change with (normalize or not normalize)

exrmiscolor.thumb.JPG.8664904f209179ccca818a1634b0f406.JPG

Share this post


Link to post
Share on other sites

Grey scale Panorama i switched off ?

 

Greyscale.jpg

Share this post


Link to post
Share on other sites
1 hour ago, Carlosan said:

Grey scale Panorama i switched off ?

I often forget these improtant option setting, but about this case, I keep the Grey scale Pnorama swithced as OFF (so not use it)

As you can see, About imported EXRs, which I  use "Panorama list"   to add image,, some map show as gray scale. but some keep colors.

To confirm I try to import another HDRI (16K) image as new neviroment, but it show as gray only..

list.JPG

setting.thumb.JPG.07c94e0b594ef50047ba7280bfc58b55.JPG

Edited by tokikake

Share this post


Link to post
Share on other sites

Could you share it to take a look ?

Share this post


Link to post
Share on other sites

Unfortunately I can not share them.(these are  not free downloadable ones)

I tried more low  res version  (eg 8k, 4k) about these maps, but no luck.  On the other hand,

 I can import other HDRI EXR without problems. (So I have not found this problem)

Share this post


Link to post
Share on other sites

Reported. Importing this panorama FORMAT=32-bit_rle_rgbe, same issue found.

 

Share this post


Link to post
Share on other sites

Thanks Carlosan to report. I do not know  what make difference to change as grey only about these HDRI, but I tried to re-save as Open-exr with Gimp from your reply. 

file size becom large,, from 340M to 430M when convert garage.hdr to garage.exr (16k)

But when i try to import the new saved garage.exr , 3d coat deny it to open as enviroment map. just , say "incorrect extends, look like png" .   

 

 

Share this post


Link to post
Share on other sites

Your hdr file size is 430Mb ?

Share this post


Link to post
Share on other sites

I believe so ,it is most high-quarity version which I downloaded before (blender cloud, though I have no inention to PR blender cloud etc,,)

then Gimp or xnconrvert viewer etc, can load it with color. (hdr version). daz studio too.

So I do not know what cuase problem for 3d coat.  I tried with directX version too, but it seems same.

Then it is just test , (I hoped to see how it look, with use same HDRI for final render, to adjust metal mat) so it not cause me serious problem,

But I hope , Andrew  test with many format. (at leas about format, which t 3d coat support)

 

 

cloudimage.JPG

Share this post


Link to post
Share on other sites

It has really become a challenge to weld vertices using right click with the Add/Split tool, because of the popup menu. Doesn't anyone else have this issue ?

Also, not really related to the beta builds, but I think it would make sense to automatically force-select the brush tool when you click Retopo menu > Bake with normal map (because if you have another tool selected when you start, you can't brush to tweak the inner/outer shell)

Share this post


Link to post
Share on other sites

Is it expected behaviour that when your use the reproject tool, if you uncheck "re-project color", then you lose vertex color on the original in the areas that you brushed with the reproject tool.

Also, when you use the pose tool, you sometimes lose vertex color on the areas that you move. (reverts to the shader in both cases)

Share this post


Link to post
Share on other sites
5 hours ago, lesaint said:

It has really become a challenge to weld vertices using right click with the Add/Split tool, because of the popup menu. Doesn't anyone else have this issue ?

Yeah, RMB popup window can be annoying. Even while navigating in viewport. And also, we already have Spacebar popup window, so there is kind of redundancy.

But you can "pin" RMB window :rofl: It will be always visible, but will never pop up again while pinned down.
 
UPD: Oh, looks like I just found a bug (or an inconsistency in the interface). When you "pin" RMB window and then change selection mode, let's say from Faces to Edges, RMB window will switch to Spacebar window.
Edited by druh0o

Share this post


Link to post
Share on other sites

Yes, if you change tool too, for example
Right click with Add/split > Pin menu > switch to select tool.

Anyway, pinning it would have been a workaround... if it could be docked, or at least resized, minimized, or moved outside the viewport. But no, you can't do any of those things.

Share this post


Link to post
Share on other sites

4.8.38-SL (GL64)
 

Undo deselects Strip ? (even if you made several strokes with it), anyone has the same ?

Share this post


Link to post
Share on other sites

Hi Sergyi,

Any luck with the Linux build? I'm happy to help test if that's needed. Lots of cool new things we're missing out on since the last Linux build...

Cheers,


Peter B

  • Like 2

Share this post


Link to post
Share on other sites

4.8.38-SL (GL64 and DX)

Bug;Whenever I hit apply when running brush along curve (either using old curves or new curves) I get a big jump in camera zoom.

The curve stroke is applied correctly in space but the camera jump is extremely annoying especially when you need to apply strokes multiple times,

Can anyone test and confirm?

thx
 

Share this post


Link to post
Share on other sites

×