Jump to content
3DCoat Forums

3DCoat 4.8 BETA testing thread


Recommended Posts

  • Advanced Member

@AbnRanger

I do not know I could test as you need, but import robot to 3d coat paint room, then delete occulusion, curvature layers once, and From top menu  textures>circulate occulusions

Light source = sphere, AA samples 4 x,  it seems work (not so slow) as same as before. 

so your problem is retopo room occulusion baking?

and when  Fill Material, as you know it start occulusion baking too, it work without problem for my pc, I am windows 10 64bit user. 4.8.36 build (not SL version,,,) GTX980ti

 

 

testAO.JPG

Link to comment
Share on other sites

  • Reputable Contributor
28 minutes ago, tokikake said:

@AbnRanger

I do not know I could test as you need, but import robot to 3d coat paint room, then delete occulusion, curvature layers once, and From top menu  textures>circulate occulusions

Light source = sphere, AA samples 4 x,  it seems work (not so slow) as same as before. 

so your problem is retopo room occulusion baking?

and when  Fill Material, as you know it start occulusion baking too, it work without problem for my pc, I am windows 10 64bit user. 4.8.36 build (not SL version,,,) GTX980ti

 

 

testAO.JPG

No, It's Paint Room > TEXTURES menu > CALCULATE OCCLUSION. I think I may have figured out a possible solution/reason. I had mixed results, but at times it was horribly slow. But, one time, when I tried recording the screen to show Andrew, it started behaving for a while. 

It took several tries and when I went to 16 AA samples, it finally came to a grinding halt. I closed 3DCoat started again, but this time, I went into Windows Task Manager and under CPU AFFINITY, I deselected the first 2 cores > tried again and suddenly it works properly and I can see the GPU does the bulk of the heavy lifting.

It must have something to do with Windows scheduling, because I got the idea from the following video, regarding ThreadRipper slowing down because of this issue. I was monitoring the activity of the CPU and GPU on Task Manager the whole time and when it worked right, the GPU would get under roughly 100% load. When it wasn't working right, it was the GPU not getting hardly any load and just CPU core #1 pegged to maximum. And it would slow my entire system down, as if everything depended on that one core. 

 

Link to comment
Share on other sites

  • Reputable Contributor
On 3/30/2019 at 7:20 PM, Andrew Shpagin said:

Is there a way to reproduce?

I'm on Win10 and use the the latest SL beta in GL mode. This happens to me all the time, when I have ghosted volumes in the vox tree, they become unghosted upon save/autosave, every time.
I just assumed it happened to everyone, not sure what else I can say to help reproduce.

---

@Carlosan Attached Here is a small doodle that takes 10 second to save on my computer, when much larger files take a second or so. Please let me know if you are able to "reproduce".

---
 

About the latest version, shouldn't the right click menu in Retopo room appear only when the select tool is active ?
It kind of breaks the add/split tool : it can't easily be used to merge vertices anymore, because that menu pops up instead.

small file that takes 10 seconds to save.zip

Link to comment
Share on other sites

  • Member

@Andrew Shpagin

Could you please fix this bug? It's present in every version of 4.8.

Bug description:

If you change an object with the Transform-tool you get a non Uniform message at the bottom of the program-window (status message).

001-nonuniform.png.15b1c7cb52b56f40bdbad18fbba31c0a.png

To make the object uniform again one should click "TO UNIFORM SPACE" (located in layer-context-menu).

2129333534_touniformspace.png.f99d7885aab424586f342c0716f396e9.png

 

But the "TO UNIFORM SPACE"-function breaks/damages the object.

 

You can see it when you sculpt on it and make an UNDO.

 

Examples:

bug1.thumb.png.dd25469810ce28e1f64d69aa80877fd6.png

 

bug2.png.32caa839aa698aff27145503360e03f5.png

 

Thank you.

P.S.

This bug is a nightmare! I don't know why nobody fixed this yet.

 

 

 

 

  • Like 1
Link to comment
Share on other sites

  • Reputable Contributor

Boolean operations that used to fail a lot seem to work better all of a sudden ? Things like import-on-brush, the close hole tool ?

I notice that Resample now seems to go through voxelization, which is bad, because it causes narrow areas to merge.

Res+ from a low poly still makes a surface mesh explode after a few times.

Link to comment
Share on other sites

  • Contributor

Possible Bug in layers:

In version 4.8.37 SL (DX):
When I go in the File / New menu ...
Layers used in the past project remain present in Sculpt Layers / Paint Layers.
So in the new project, I have to click the Delete All Unused Layers button to reset the layers and create a new base layer.

Link to comment
Share on other sites

  • Advanced Member

Tube/array,  radial scale is affected by brush radius of points.  Inserting a point with a different brush radius to adjust a curve will get uneven thickness, I can't seem to find a way to adjust thickness on that point.  

Clipboard01.thumb.jpg.15d0fbd24d409588578eb54c98dbd832.jpg

Link to comment
Share on other sites

2 hours ago, animk said:

Tube/array,  radial scale is affected by brush radius of points.  Inserting a point with a different brush radius to adjust a curve will get uneven thickness, I can't seem to find a way to adjust thickness on that point.  

 

Try changing the point connection type.

 

1.png

Link to comment
Share on other sites

  • Member
4 hours ago, Oleg_Shapo said:

Please write what version of the program are you using? In version 4.8.37 there is no such problem.

Hi!

As I said it's in every 4.8 version.

But I just found out that this bug only happens when in voxel mode/layer.

000.png.523b3a4a8b4f1a6018e580fa7e23b043.png


I put together a new description below.

----------------------------------

1. Start with a volxel-sphere.

0000.png.c7a7f26d93bc1fb964dcc34accd092e0.png

2. Press the "To Uniform Space" Button.

002.png.d90add3129428b67611f03ddfc2c907a.png

3. Sculpt on voxel-sphere (e.g. with grow)

003.png.f04f795b6ed7dade4413f9f6c590e6f1.png

4. Press UNDO.

005.png.b761a98eb05251a0bc9cdbd89e79c319.png

5. BUG!

006.png.c1ef973c00ad15b9a51162f33005a3cd.png

 

The "To Uniform Space"-function/button (in voxel-layer) breaks the object!

  • Like 1
Link to comment
Share on other sites

  • Advanced Member

All these bugs work every time. I know a person whose computer is weaker than mine, but at the same time almost none of those I wrote about are experiencing. At the same time, sometimes in the new version, it does not work what worked in the previous one, and at the same time it was buggy and continues to be buggy for me. The fact that it works for you does not mean that there is no problem.

Of course, all combinations of factors of computer hardware, system, installed programs, it is difficult to take into account, but please at least try to correct errors.

I shot more than 10 videos with playback of bugs, but less than half of them were corrected for the five released versions of the program. 

Link to comment
Share on other sites

19 minutes ago, Sorda said:

All these bugs work every time. I know a person whose computer is weaker than mine, but at the same time almost none of those I wrote about are experiencing. At the same time, sometimes in the new version, it does not work what worked in the previous one, and at the same time it was buggy and continues to be buggy for me. The fact that it works for you does not mean that there is no problem.

Of course, all combinations of factors of computer hardware, system, installed programs, it is difficult to take into account, but please at least try to correct errors.

I shot more than 10 videos with playback of bugs, but less than half of them were corrected for the five released versions of the program. 

If I have way to reproduce, I fix. If you post video, bu I can't reproduce after many attempts, I can't fix.

Link to comment
Share on other sites

  • Advanced Member
Quote

 

Hi!

As I said it's in every 4.8 version.

But I just found out that this bug only happens when in voxel mode/layer.

000.png.523b3a4a8b4f1a6018e580fa7e23b043.png


I put together a new description below.

 

 

 

 

Quote

Thanks for clear steps, reproduced and fixed.

 

 

The bug was described by me on  December 26, 2018. 

 

With all due respect, the answer to "I'm fine, no problem" is like the answer of an oncologist to a cancer patient. Like, I have no cancer, so you do not, and we will not treat you. Clear the bed.

 

Edited by Dmitry Bedrik
Link to comment
Share on other sites

  • Advanced Member
1 minute ago, Oleg_Shapo said:

Thank. We know the problems of the Cell tool. This tool is in the finalization. Alternatively, you can use the tool Vox Hide (Скрыть) or Cut Off (Отрезать)

That's not the point. I even wrote to Shpagin in the mail about this. And the reaction is only now, as if he sees it for the first time.  

Link to comment
Share on other sites

 

33 minutes ago, Sorda said:

That's not the point. I even wrote to Shpagin in the mail about this. And the reaction is only now, as if he sees it for the first time.  

I can't imagine why. Tone it down.

  • Like 2
Link to comment
Share on other sites

  • Advanced Member
10 hours ago, Oleg_Shapo said:

Try changing the point connection type.

 

1.png

It doesn't do anything by changing the point connection type.  Is it possible to add a radial scale control for selected point to future build?

Link to comment
Share on other sites

  • Advanced Member
8 hours ago, The_Mikeman said:

Hi!

As I said it's in every 4.8 version.

But I just found out that this bug only happens when in voxel mode/layer.

000.png.523b3a4a8b4f1a6018e580fa7e23b043.png


I put together a new description below.

----------------------------------

1. Start with a volxel-sphere.

0000.png.c7a7f26d93bc1fb964dcc34accd092e0.png

2. Press the "To Uniform Space" Button.

002.png.d90add3129428b67611f03ddfc2c907a.png

3. Sculpt on voxel-sphere (e.g. with grow)

003.png.f04f795b6ed7dade4413f9f6c590e6f1.png

4. Press UNDO.

005.png.b761a98eb05251a0bc9cdbd89e79c319.png

5. BUG!

006.png.c1ef973c00ad15b9a51162f33005a3cd.png

 

The "To Uniform Space"-function/button (in voxel-layer) breaks the object!

Yeah, in voxel sculpting even though I've never used "To Uniform Space", not every undo but it happens very often.  Hitting undo again brings object back to previous normal stage.  I have to hit "to Globle space" so the next few undos wouldn't break the object.  For the time being I assign a hotkey to  "to Globle space" and constantly hitting it in voxel mode to prevent this.

Link to comment
Share on other sites

  • Contributor
4 hours ago, Andrew Shpagin said:

It works correctly on my side.

I discovered the problem that was happening to me so that the Geometry / HighLight function was not working properly.
If the same thing happens to you, what happened to me, you should be aware of the Shader you are using.
Depending on which Shader you are using the HighLight function will not work.
I do not remember a function that also was not working and the solution was for me to change Shader and so the function returned to work.
In my opinion, Shaders could go through a review, this is just a little advice to developers, Shaders are influencing or interfering with some of the 3d-coat functions not working.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...